Recommendation for simple ethernet-to-wifi adapter

Hoping someone can recommend an ethernet to wifi adapter that will work well with hubitat. I was using an old TpLink WR710 "pocket router" that I had in the spare parts drawer, which was working great in client mode (where it acts as an ethernet to wifi adapter) up until a couple weeks ago. Not really sure how it was working before, I just know it worked as intended for past year, but after a recent power outage and the devices reset, I am unable to get into the local web UI on hubitat. Port 80 takes me to the admin UI for the router, not hubitat, and I can't seem to find a way to turn it off! Seems like I would need to either change port on hubitat, or on the wifi adapter. Anyway, this TP Link is at least 5 years old, probably more, so I figure I'll just buy a replacement. Wondering if anyone has a recommendation. Thanks!

You can see this in the screenshots in the docs, but it's even better if you actually go to that page on the hub: Settings > Networking. Hubitat has three specific TP-Link adapters that they recommend, including links (on this settings page) to their Amazon product pages.

We know from staff's description that these require specific drivers to be installed in the underlying OS (which doesn't happen until you enable this feature), so while it's possible other devices may work, I'd recommend staying on the safe side and choosing from among those three.


Thank you for the quick reply, had no idea that Hubitat could directly support a USB Wifi adapter like that! I'll get the parts ordered and report back on how it goes.

Well, I see in the docs that:
"Setting a Static IP address and configuring a WiFi USB adapter is not available for hubs prior to Model C-7"
And I have a C-5 :frowning:
However, after updating to latest firmware, I do see Networking option now in settings. So I ordered the nano adapter and cable (whole $15 for both items) so I'll give it a try. If the docs are correct and C5 hardware won's support USB wifi, then I'll be back to investigating ethernet to wifi adapters again, and still looking for recommendations!

Looks like C5 is supported with latest firmware. Whew!

1 Like

It's a typo - will get that fixed. C5s are supported.

1 Like

Wifi is working well for the most part after installing the adaptor and configuring. My feedback after ~6mo of using Wifi. The UI to configure is pretty limited, it gets the job done, but if the wifi password changes, there is no way to get into the device to update. Lesson learned, update the password on the Hubitat prior to changing the WiFi password. Otherwise be prepared to connect back to ethernet to be able to get back into the UI to set the new password. That's a minor issue, bit inconvenient, but easy enough to workaround.
The more significant issue I am having is that if the Wifi drops for some reason (power outage, AP reset, etc.) then Hubitat fails to refresh the Wifi connection, and I am forced to unplug and restart the device to get back on the network. When I am home not a big deal, I can cycle Hubitat power, but I was recently away from home for the weekend and had a power outage, and was unable to get back into Hubitat until I retruned home and cycled the power. Question I have, is there a setting I can try to get wifi to refresh, a script I can use to ping and force a wifi reset or device restart if network is unreachable, etc. or request an enhancement to address this? Anyone else encountering this issue?


i dont rely on wifi for things like the hub if i can help it.. i use gocoax devices to connect upstairs and downstairs via extra cable runs and put switches behind each.. this is what my hub is connected to instead of wifi.

1 Like

2.2.9 (not sure starting with which revision at this point) includes automatic reconnect for WiFi. I've added it because I run WiFi for my primary home hub and it had some connection drops. This automatic reconnect does exactly what you describe - shuts down WiFi interface, reloads the kernel module, and starts WiFi interface back up, forcing a new DHCP request.

The restart button mentioned in this post did the trick for me every time, but it's a sample of one.


Thank you for the quick reply... I have been too busy with other stuff to work on my Hubitat past couple weeks. Anyway, digging into this again, and after the latest update my Hubitat's Wifi is completely unreliable now past few days its been loosing the WiFi connection within 24 hours. Can't rely on the built in WiFi support anymore and I am now going to order an ethernet over power line as noted above. Haven't had much luck with wifi to ethernet devices which is why I posted my original thread, they seem to work fine for typical devices that just need to get out to the Internet (my Directv box uses one because they don't support WPA2), but problematic when trying to make inbound connections to Hubitat e.g. one adapter insisted on returning its admin page (port 80) instead of forwarding to that port on hubitat.

I checked device logs and I can see when the connection drops - start getting errors for any outbound connections to Amazon Alexa, etc. Happy to help further troubleshoot if someone can point me to how to capture debug info for the Wifi driver.

Hubitat Elevation® Platform Version
Hardware Version
Rev C-5

I've just moved to wifi as I had to move the hub and I cant get an ethernet cable to it with out spending a day ripping the kitchen apart...

And its not great dropping connection at least twice a day and not reconnecting with out a reboot.
I have a webcore piston set up to reboot the hub if it drops connection which works but the whole system is now not as responsive and its causing havoc with my automations.

I went with the TL-WN823N wifi adapter, going to see if there's a firmware update for it but I'm not holding my breath

Mine was dropping about once per day after the latest update. It was actually pretty reliable up until the last Hubitat update or two and would only loose the connection when my wifi APs lost power or were restarted. Until resolved in a future Hubitat update (hopefully) WiFi is unusable for me. I have switched to a powerline ethernet adapter. Has been working flawlessly for me past few days. Reviews on these devices are mixed quite a few complaints about slow speed which is not an issue for this application, and both devices in the pair need to be on the same circuit (same leg/phase of 220v service). I figured $40 to give it a try was worth a shot, and it worked:

Limited-time deal: TP-Link Powerline Ethernet Adapter Starter Kit - AV1000 Gigabit Port, Plug&Play, Ethernet Over Power, Nano Size, Ideal for Smart TV, Online Gaming, Wired Connection Only (TL-PA7017 KIT)

I was using a powerline adapter before granted it was probably 10 years old but it failed on me and was abit slow accessing the hub and for dashboards, so I ran an ethernet that was in plan sight and not compatible with SWMBO.
So moved to WiFi which is not a choice I would normally go for but it was a easy fix but it's becoming VERY annoying now I'll probably take the hit on my next free day and rip the kitchen apart to run a ethernet cable as much as I know a powerline adapter will work and would be a 10 min job I just don't like them.

The other option is move the hub atm it's located in the middle of my bungalow on top of the kitchen cupboard, if i moved it to the loft it would be easy to get ethernet to it but it's then got to deal with 100mm of celotex and not sure how it would deal with that. My head tells me that it wouldn't like it?

I have google wifi and one thing i did for a while was use one of my google wifi nodes to be a wifi ethernet bridge. It worked great actually. I was able to took up a switch to one of the two ports and then all my other devices to that switchm the google wifi was attached via wireless to the other goofle wifi nodes. Everything worked well. Ofcourse i was limited to the speed of the wifi for everything attached to it but for what i was doing it wasn't a issue.


Check out my logs, I get multiple reboots per hour every hour due to "wifiDisconnect." After a number of reboots, the C7/TP-Link Nano fails to re-connect to the wireless network requiring a forced reboot. I have two separate wireless networks (main and IoT) with separate VLANs; the C7 is 15 feet from the wireless AP. I have the problem on both networks. Router logs show very few connection issues with the other 30+ devices (range related for the few that are logged)

My point: I believe others (including myself) are having Wi-Fi related issues as well.

Location and Hub Event Logs:

I've given up with wifi and gone back to ethernet to many problems with wifi.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.