Recieved a Wyze Lock, pairs but not working

I received my early access Wyze Locks and they work great... and now I'm trying to get one of them into HE.

I was able to easily pair the lock but it does not find a device type and "Generic Zigbee Lock" does not work.

Here is the device details:

  • endpointId: 01
  • application: 01
  • softwareBuild: 1.0.0.0
  • inClusters: 0000,0001,0003,0020,0101,0B05,FC00
  • outClusters: 000A,0019,FC00
  • model: Ford
  • manufacturer: Yunding

How did you get it to pair as I try and couldn't get my to pair???

You just press the little button at the top (under the magnetic plate)

Hey I try that and the green light was flashing but no luck but I will try again. Thanks

Just tried one (after first setting it up in Wyze), and it sort of works: the "lock" and "unlock" commands work most of the time, but the lock seems to end up in the opposite state as what it should. I still don't think it works fully with this lock, but did you click "Configure" after switching to the Generic ZigBee Lock driver?

Hopefully it's possible to add support--this is a neat device at a good price point. The fact that it pairs and kinda responds is promising. I'm assuming we'll have to wait for Mike to get his hands on one (and hopefully there's nothing weird about them). :slight_smile:

FWIW, the fingerprint for this lock is really close to the zigbee Schlage BE468GBAK. If there's a SmartThings DTH for the zigbee Schlage, it might be worth a shot trying a ported DTH with the Wyze lock.

Thanks for the idea! I didn't see one specifically for that lock, but found ZigBee Lock without Codes in their public repo, and it...also doesn't work, but does show debug logs on phyiscal locks and unlocks, so it might be workable. I'll see if I can manage anything. :slight_smile:

1 Like

Maybe this one?

The Schlage BE468GBAK fingerprint is:

Inclusters: "0000, 0001, 0003, 0009, 0020, 0101, 0B05, FC00"
OutClusters: "000A, 0019"

Saw that one too! Wasn't sure which one would be better to start with since the Wyze doesn't have a keypad (I'm guessing the biggest difference is just that one doesn't include the "Lock Code" capability).

This isn't advertised as zigbee, but obviously it is.
Anyway, maybe folks interested in this lock can poke Wyze directly requesting Hubitat support. Point them in my direction. This can be more effective than me bugging them.

3 Likes

I emailed support. Used your name as HE person to contact. It looks good for the price, but I'm not going to mess with it without in-box drivers.

I will email support also and give them your name also @mike.maxwell as a contact for Hubitat. I will also have to say that the lock is going to get the keypad to work the lock. So far I like the lock.

Not following this...

When they announced it they said that moving forward they would try to use "established" smart home protocols instead of their proprietary stuff (Like their sensors).

Unfortunately I doubt they would be open to any form off official support, they said in their Youtube AMA that Wyze Lock would not be compatible with any other Zigbee hub.

Lame...
If this is indeed the case, this lock goes on the do not buy list, and a sample won't be of any use as I wont be spending any time trying to reverse engineer their proprietary implementation.
There's just to many products we could work on that actually follow standard protocol implementations.

2 Likes

Yeah, I was hoping that the lock would be a generic zigbee lock and that all the Wyze stuff would live in the Wyze Gateway. Looks like their might be something else going on.

@mike.maxwell Sorry, what I was trying to say was that the keypad for the lock is coming in February 2020 and you will be able to assign codes etc. I brought one to see if it would work with Hubitat but I really don't think that it will. I like the concept of keeping your key that work with the lock that you have without having to re keying etc. I also like how easy it was to install and set up.

August let's you do all that. And is Hubitat-compatible.

2 Likes

The August Pro is. Unfortunately, they are dropping z-wave and the new model will be wifi. No more August for me!

2 Likes

That's a real shame.

2 Likes

Download the Hubitat app