Problem hub rebooting on its own after cloud backup in 2.2.6

can someone take a look at my logs and see what is going on.. the hub is rebooting on its own .. since last upgrade.. if it happens again i will try rolling back.. has anyone else noticed this

Did you roll back to confirm that 2.2.6 is acting as a switch for that reboot "feature" :smiley: ??

not yet.. will give it another few hours and then rollback if needed to test. the earlier 2.2.6 was not doing it for sure.. just the latest.

but the first cloud backup didn't happen till the lastest build either.

I have 7 hubs, all on 2.2.6, I should be more susceptible to this.. none of mine are rebooting.

it seems to be related to the schduled cloud backup.. one at night was just before the reboot. and the one at noon was also around 5 minutes before it rebooted.

my other hub is not doing it.

Subscription backup? Yea, I don't have that yet on any of mine.

I'm seeing this as well and reported it in another thread. [2.2.6.129 C7] Hub Crashing

@gopher.ny said they were adding some tracing in the next HF (>.130) to see what's triggering it.

given this graph it appears to be memory related as well

2 Likes

I’m not 100% sure that graph indicates it’s a memory problem. There’s still a lot of free memory and it’s pretty normal for a drop off like that right after reboot.

1 Like

not that it is out of memory.. could just be a coincidence like you say as they have been up and memory reducing about the same amount of time for each reboot. but i was looking at the level of memory at the reboot time and they are very similiar.

if it stays up till past the 12 hours or so i will fire off a manual cloud backup like i did at noon today and see if that triggers it.

Would be curious to see how the CPU load is changing to see if that ties into anything.

(I recently had an issue with my C5 where within an hour of startup it would report a constant load of 1 and would lock up the hub, soft reset fixed it)

No, subscription reboot.

@kahn-hubitat, If you don’t schedule cloud backup, does it still reboot?

it hasnt so far.. still scheduled but not supposed to run till tomorrow.. will let it go and see if it reboots right after the backup.. or maybe i will try a manual cloud back tomorrow.. it rebooted after i ran one today.. My other hub that also has cloud backups scheduled has not rebooted.. But i will modify the startup rule on that hub to alert me if it does. i want to give it a good 24 hours straight up without a reboot before i run the test.. we are at 12 hours now. i see the database being pruned every hour or two.,, I was wondering why i saw cpu jumps when i was graphing and also temp rises.. It seems to be around the time the db is pruned.. I stopped graphing it as the temp graph was all over the place and really didn't tell me anything.

confirmed.. @gopher.ny

stayed up for over 24 hours.. did a cloud backup.. finished and immedately crashed and rebooted.

for now i will disable cloud backups.. can someone look at the logs

nothing too relavent in the logs.. the error shown is the hub information app (refresh on dashboard window).
on startup data not there yet i guess

bump anyone from support comment on this @support-agent

Are you expecting someone to respond to you within 20 minutes on a weekend?

no.. but no one in support has commented at all on this thread..

ie is a fix in the works.. are they looking at it.. known issue. etc. etc.

also now that i have confirmed it definately is the cloud backup casusing the issue. i want to bring i tto their attention.

1 Like

any update .. i opened a support ticket.. if i cannot do cloud backups i may as well not have subscription..

1 Like

Download the Hubitat app