Porting VLCthing

Yes. I did get it working. I didn't have to do anything special, but the player is not on the same computer, so the IP is different but the port is 8080 for both.

[Edit] Not sure how you're trying to get it to work, but I did find that Airplay does not work from within the MacOS system settings on an old Airport Express. AppleTV 4 it did work. Workaround was to use AirParrot for the Airplay connection between mac and the Airport Express.

After submitting this I realized I could just install VLC on another PC. I worked right off the bat. It must be an issue with it being hosted on the same computer. I thought if I changed the port that would be enough. I'll keep tinkering. Maybe the port has to be 8080, or the device driver only looks at the IP address portion of the network ID. Back to playing.

Thanks SHP for confirming.


Hmm, there seems to be an issue using any TCP port other than 8080. If I change a working VLC Thing or setup a new one with a non-8080 port it does not work. I looked at the code and I don't see 8080 hard coded anywhere. It's only mentioned as a default if nothing is specified.

The firewall blocks at the application level not network so that shouldn't be a problem.

Is 8080 the only port that HE allows?

I should probably take this to the dev forum...

Can you explain how you got VLC (on your laptop) connecting to your Hubitat.
I'm just seeing "No Connection" in the logs.
I can copy the http string (containing the mp3) from the driver VLCThing driver, directly into VLC or from a browser and it plays but I cant get it to play from Hubitat.
Any help would be appreciated. Oh and I'm using port8080

See this post. There's and additional trick necessary to get it working with Google Cast. If you want to do that too, click the work "trick" in that post.

If you continue to have trouble, delete the preferences file from VLC Player on the laptop and set it up again. I did have trouble recently getting it reconnected and that was what I needed to do. Worked fine after that. Honestly, right from the computer speakers is easiest, so try to get that working first before you try to do anything like casting.

1 Like

I had not considered this. Vlc does support casting now. Could I just cast directly to google homes from vlcthing? Then could get rid of the cast web node server.


1 Like

You can. It has it's associated flakiness. I use it to cast to mine for door open notifications. But the connection sleeps every five minutes of non-use. My understanding is this is just the way the cast function works, but I've not casted any other way, so that might not be correct. Could just be a VLC Player thing.

Anyway, the IP connected does automatically "wake up" and re-establish the connection when something else is cast (with the annoying tone before the cast which cannot be disabled).

Yeah the tone is a bit annoying for sure.

1 Like

Thanks @SmartHomePrimer, I've now narrowed it down to my kitchen, All-In-One PC not allowing inbound connections :frowning:
I've been able to prove that what I was doing was correct, it's just not working on THAT PC.

Is this PC running Windows? If so, did you create a Windows Firewall rule to allow inbound traffic on the correct port? Or, are you running some other AV package with its own firewall?

1 Like

Cheers, Yes, Win10.
I did create an inbound rule, which didn’t help. It shouldn’t be necessary as normally Vlc asks for network access when being installed but on this PC it doesn’t!

I shut down most of the running programs like AV etc but never got it working on this All In One. Sending From the AIO works fine. It looks like something blocking inbounds on the WiFi driver !?!
I proved what I wanted to on another PC so I’ll come back to this issue later.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.