Porting VLCthing

I can get a track to play with TTS in a rule. It's nice to have a tone go with "door (x) open" and "laundry machine (x) is finished", but I can't seem to get any of the choices in RM to play only the track I specify. If I have two tracks in my VLC player media library, both are played, even though I specify a specific track in RM.

If I ask for TTS only, then that works, I won't get the track, but if I have more than one track in VLC Player, it seems to be an all or nothing deal. Any ideas how to resolve this?

[Edit] Plays the MP3 no matter whether to not it is selected in the Rule. If it's in VLC Player media library, it plays, even if the RM rule does not have it selected. :rat: :rat: !

I've been using Big Talker with it. Set up commands based on your device. So far, it's been working really good. Go through the steps, pick vlcthing as your audio device. Been really happy

@rayzurbock Hasn't released for Hubitat yet. Are you using it on ST?

No ported over an older version. Seems to work good.

Original BigTalker author here. Good job porting if it’s working for you.
I have a 2.0 port in beta that I was ready to release until it hit a brick wall with the Sonos driver. Hopefully that will be addressed. I’m contemplating releasing without Sonos support until (and if) the driver supports the needed commands.

What speaker drivers are you using? Just VlcThing?

Yes, I just use Vlcthing. Bluetooth that over to my Alexa. I can't say that Big Talker is fully working. But it seams to be for what I am doing with it for now. It won't let me post the code, to many lines. But I included some ss of it. Been using Big Talker for about a year between here and st. Great job on it and thank you for your work.

1 Like

I'm trying to get VLCThing working, with no luck. I've installed the 2.0 version of VLCThing from below as user supplied code. I created a device by making a virtual device and using the user supplied code. I use the same IP, Port, and password that works via the VLC players web interface. When I look at the status on the HE portal it says disconnected and commands do nothing. I turned off the firewall and made the one edit shown in this thread. What vital step am I missing? The code in this thread is ported right?

Reboot the hub is what has worked for me.

Reboot the hub, that was a painfully obvious option. Worked for me too. Thanks. For those who come after me, the status showed disconnected and inactive until I sent a command.

1 Like

Getting error in VLC Thing log under
However, it does not seem to be affecting the driver performance. I just don't like seeing something generating constant errors that might slow performance or cause other issues.

This device is pshcitzo, really doesn't need so many abstracted methods. It's damned confusing.

[dev:627](http://REDACTED/logs#dev627)2018-08-10 19:18:34.163:errorjava.net.ConnectException: Connection refused (Connection refused) (pollingTask)

[dev:627](http://REDACTED/logs#dev627)2018-08-10 19:18:18.612:errorjava.net.ConnectException: Connection refused (Connection refused) (testTTS)

I've used the VLC remote setup tool. Double checked the Lua settings, I've enabled the remote meta data and the web interface.

Did you get it working? It needs a hub reboot after the first load of the app for some reason.

So, ya. A little strange that it's using the 8080 port rather than the port setup for Lua.
But ya, I got it working.

Shouldn't be more needed than this, with your VLC Player's IP and then a hub reboot...

Then this in the VLC Player with the matching password used in the driver...


And lastly choose Add interface:Web in VLC Player


You can also Cast to a Google Home to get voice or play sounds, but it disconnects every 5 minutes, so you have to put up with a delay, a tone, then the finally a reconnect and the sound or speech with that method. There's a trick to getting that working too.

If you have Google Home devices, the Google Assistant relay is great for TTS if you don't mind the tone before speech (which cannot be disabled). Even if you don't have a Google Home, the Assistant Relay is a cool way to be able to control devices that are not supported by Hubitat yet, but are supported by Google Assistant.


1 Like

Need help playing specific tracks please.

I've decided to challenge myself and replace my 20 year old halloween automations with Hubitat. Need to be able to play a specific track on VLC media player via VLCThing, but I cannot figure out what is necessary to do that.

I can play the last track with play or all the tracks with play next, but when I specify play track from RM, I get the message on VLCPlayer "VLC in unable to open the MRL 'file:////scarysound.wav'. Check the log for details."

I get nothing in the log file I asked it to create. Anyone know what settings I need to adjust to get this setup so I can play specific tracks in HE? Do I need to change the way I'm specifying the track for it to play from RM? Here's my test rule action.


Where are the sounds located,? If you happen to have a webserver setup put it there and use that url.

just tried this format as well


that is the path on the local pi the music lives on and that vlc is playing from

1 Like

Thanks Chris. They're local on the computer hosting the VLC Player. I'll try setting up a web server in the next few days. , but I'm a little baffled as to why this doesn't just work. It's a Mac. Maybe there's an issue with the Mac VLC Player and VLC Thing?

I think it is just a matter of how you tell it. I could not make the format you posted work either. I saw errors as well. When I just used the direct path as posted there it worked.

1 Like

Thanks Chris. I can access the specific file directly on the computer that's hosting the VLC Player, but I needed to specify the complete path as you pointed out, including %20 for any spaces in the file name.

I found an easy way to get the correct Media Resource Locator that VLC Player is looking for by going to File > Advanced Open FIle... > Browse... then at the bottom of the window you can see the MRL that VLCThing needs, and I can play the specific track I need from RM.

I think I might just be able to pull this off. It's coming together much quicker than expected.

1 Like

I have a single instance of VLC Thing working great. Thank you again, this community has been very helpful.

Does anyone have a 2nd instance of VLC Thing working?

I have the 2nd VLC install working, it's on the same machine, with a different listening port. I created a virtual device, applied the VLC Thing device and configured it with the new port and I can't get it to connect. I've rebooted my hub twice and even tried a full shut down and restart. I've sent TTS, play, and poll commands and nothing. They have different network IDs so being hosted on the same machine shouldn't matter, but maybe it does.

So anyways my original question stands, does anyone have more than two VLC Things on Hubitat?