Porting VLCthing

Reboot the hub, that was a painfully obvious option. Worked for me too. Thanks. For those who come after me, the status showed disconnected and inactive until I sent a command.

1 Like

Getting error in VLC Thing log under
However, it does not seem to be affecting the driver performance. I just don't like seeing something generating constant errors that might slow performance or cause other issues.

This device is pshcitzo, really doesn't need so many abstracted methods. It's damned confusing.

[dev:627](http://REDACTED/logs#dev627)2018-08-10 19:18:34.163:errorjava.net.ConnectException: Connection refused (Connection refused) (pollingTask)

[dev:627](http://REDACTED/logs#dev627)2018-08-10 19:18:18.612:errorjava.net.ConnectException: Connection refused (Connection refused) (testTTS)

I've used the VLC remote setup tool. Double checked the Lua settings, I've enabled the remote meta data and the web interface.

Did you get it working? It needs a hub reboot after the first load of the app for some reason.

So, ya. A little strange that it's using the 8080 port rather than the port setup for Lua.
But ya, I got it working.

Shouldn't be more needed than this, with your VLC Player's IP and then a hub reboot...

Then this in the VLC Player with the matching password used in the driver...


And lastly choose Add interface:Web in VLC Player


You can also Cast to a Google Home to get voice or play sounds, but it disconnects every 5 minutes, so you have to put up with a delay, a tone, then the finally a reconnect and the sound or speech with that method. There's a trick to getting that working too.

If you have Google Home devices, the Google Assistant relay is great for TTS if you don't mind the tone before speech (which cannot be disabled). Even if you don't have a Google Home, the Assistant Relay is a cool way to be able to control devices that are not supported by Hubitat yet, but are supported by Google Assistant.


1 Like

Need help playing specific tracks please.

I've decided to challenge myself and replace my 20 year old halloween automations with Hubitat. Need to be able to play a specific track on VLC media player via VLCThing, but I cannot figure out what is necessary to do that.

I can play the last track with play or all the tracks with play next, but when I specify play track from RM, I get the message on VLCPlayer "VLC in unable to open the MRL 'file:////scarysound.wav'. Check the log for details."

I get nothing in the log file I asked it to create. Anyone know what settings I need to adjust to get this setup so I can play specific tracks in HE? Do I need to change the way I'm specifying the track for it to play from RM? Here's my test rule action.


Where are the sounds located,? If you happen to have a webserver setup put it there and use that url.

just tried this format as well


that is the path on the local pi the music lives on and that vlc is playing from

1 Like

Thanks Chris. They're local on the computer hosting the VLC Player. I'll try setting up a web server in the next few days. , but I'm a little baffled as to why this doesn't just work. It's a Mac. Maybe there's an issue with the Mac VLC Player and VLC Thing?

I think it is just a matter of how you tell it. I could not make the format you posted work either. I saw errors as well. When I just used the direct path as posted there it worked.

1 Like

Thanks Chris. I can access the specific file directly on the computer that's hosting the VLC Player, but I needed to specify the complete path as you pointed out, including %20 for any spaces in the file name.

I found an easy way to get the correct Media Resource Locator that VLC Player is looking for by going to File > Advanced Open FIle... > Browse... then at the bottom of the window you can see the MRL that VLCThing needs, and I can play the specific track I need from RM.

I think I might just be able to pull this off. It's coming together much quicker than expected.

1 Like

I have a single instance of VLC Thing working great. Thank you again, this community has been very helpful.

Does anyone have a 2nd instance of VLC Thing working?

I have the 2nd VLC install working, it's on the same machine, with a different listening port. I created a virtual device, applied the VLC Thing device and configured it with the new port and I can't get it to connect. I've rebooted my hub twice and even tried a full shut down and restart. I've sent TTS, play, and poll commands and nothing. They have different network IDs so being hosted on the same machine shouldn't matter, but maybe it does.

So anyways my original question stands, does anyone have more than two VLC Things on Hubitat?


Yes. I did get it working. I didn't have to do anything special, but the player is not on the same computer, so the IP is different but the port is 8080 for both.

[Edit] Not sure how you're trying to get it to work, but I did find that Airplay does not work from within the MacOS system settings on an old Airport Express. AppleTV 4 it did work. Workaround was to use AirParrot for the Airplay connection between mac and the Airport Express.

After submitting this I realized I could just install VLC on another PC. I worked right off the bat. It must be an issue with it being hosted on the same computer. I thought if I changed the port that would be enough. I'll keep tinkering. Maybe the port has to be 8080, or the device driver only looks at the IP address portion of the network ID. Back to playing.

Thanks SHP for confirming.


Hmm, there seems to be an issue using any TCP port other than 8080. If I change a working VLC Thing or setup a new one with a non-8080 port it does not work. I looked at the code and I don't see 8080 hard coded anywhere. It's only mentioned as a default if nothing is specified.

The firewall blocks at the application level not network so that shouldn't be a problem.

Is 8080 the only port that HE allows?

I should probably take this to the dev forum...

Can you explain how you got VLC (on your laptop) connecting to your Hubitat.
I'm just seeing "No Connection" in the logs.
I can copy the http string (containing the mp3) from the driver VLCThing driver, directly into VLC or from a browser and it plays but I cant get it to play from Hubitat.
Any help would be appreciated. Oh and I'm using port8080

See this post. There's and additional trick necessary to get it working with Google Cast. If you want to do that too, click the work "trick" in that post.

If you continue to have trouble, delete the preferences file from VLC Player on the laptop and set it up again. I did have trouble recently getting it reconnected and that was what I needed to do. Worked fine after that. Honestly, right from the computer speakers is easiest, so try to get that working first before you try to do anything like casting.

1 Like

I had not considered this. Vlc does support casting now. Could I just cast directly to google homes from vlcthing? Then could get rid of the cast web node server.


1 Like

You can. It has it's associated flakiness. I use it to cast to mine for door open notifications. But the connection sleeps every five minutes of non-use. My understanding is this is just the way the cast function works, but I've not casted any other way, so that might not be correct. Could just be a VLC Player thing.

Anyway, the IP connected does automatically "wake up" and re-establish the connection when something else is cast (with the annoying tone before the cast which cannot be disabled).

Yeah the tone is a bit annoying for sure.

1 Like