Popp Radiator Thermostat with short wakeup interval

I moved some Popp z-wave thermostats (compatible with Danfoss living connect) from VERA, which need 10 min wakeup intervals.
On HB I started with several drivers and can't get long term stable operation. Sporadically, the wakeup interval resets to the default 1800s.
So I took the program structure of the driver of Marc Cockcroft and I thank him for that!
The main changes are:

  1. At each wakeup the wakeup interval is providently set to my preference value.
    Disadvantage: The device skips one each wakeup (a preference of 5 min leads to a real wakeup interval of 10 min). But this is ok for me.
    (I've tested to correct the wakeup interval conditionally (when receiving the sporadic 1800s interval report). But this correction takes up to 2* 1800s to come into effect. This is not sufficient for me.)
  2. The handling of the setpoint and temperature values is based on state variables to make the process more reliable for short wakeup and switching intervals.
    URL: GitHub - kunPet/hubitat

did you (assuming you are aware of it) find your method described a better solution than using this-

You point to the driver of Marc Cockcroft I used as base. This driver basically worked for me, but with two problems:

  1. Sporadically reset of the wakeup interval to the TRV default of 1800s.
  2. Sporadically the change of the setpoint was not successful.

My Refinements:

  1. Always set the preferred wakeup interval at each TRV wakeup.
  2. Introduce state variables to support the handling of setpoint changes. (The update of state variables happens synchron in the database, whereas the processing of the events is asynchron).

If you want to switch to the modified driver, it's better to delete the existing state variables of the previous driver: Assign the system driver "Device" and click "delete all settings".

i have the same popp (danfoss clone) radiator TRV and found the driver (mentioned above) worked, albeit with a bit of nursing. Originally it took a bit of homework on my part as i was completely new to hubitat (i came here after my ten year old Vera died) and the default thermostat driver done everything except set the wake-up interval, which as you know, is essential in maintaining communication with the TRV

However, i had to set the wake-up interval (otherwise the device goes offline, as you know) by configuring in Hubitat then immediately forcing the TRV to wake-up by pressing the middle button on the TRV upon which it forces a "wake up" and collects the new configuration data awaiting.

Perhaps waiting for it to wake up on its own doesn't somehow collect the new wake-up parameter trying to be set by hubitat. Or maybe mine is also resetting to 1800 seconds wake-up?
BTW- 30min/1800seconds is my desired wake-up time.

There may be variations in these "danfoss clones" that cause issues, i dont know.

I have had a few issues following FW updates where hubitat loses the ability to deal with the device owing to a driver problem.
Have you experienced that yourself?
read about that here:

Your experience is similar to mine. Sporadically, I had communication errors that brought the TRV into an error state. So I made my above-mentioned driver modification. Now the TRV works for stable for me.

If you want, you can try that modification. If you want to switch to the modified driver, it's better to delete the existing state variables of the previous driver: Assign the system driver "Device" and click "delete all settings".
Then assign the new driver and press configure. The configuration process starts with the next wakeup. Thereafter, you can change your preferences, setpoint etc.. The wakeup changes take up to 2 (old) cycles to take effect.

If you want to accelerate the wakeup of the TRV you have to remove and replace the batteries. To press the middle button doesn't help: This only starts communication.

If you want to switch back to your old driver, the old state variables are rebuilt with "configure".

if the middle button doesn't work for you, adjusting the temperature up or down on the TRV initiates a "wake-up" to/from the hubitat controller