Patched webCoRE for Hubitat (2018/09/09)

Having trouble getting Push notifications to the HE app on Android, from Webcore...example below:

Which of these is the "right" notification option to choose to get push notifications on my phone? As far as I can tell the "Send device notification" option seems to work, sort of.

If I open the app and go to the Notification section of the Hubitat app, and refresh the list, it will show the notification. But there is no visible indication outside the HE app that a notification occurred...no sound, vibration, or notification message in the Android notification pull down. I can't believe this is how HE app push notifications are supposed to work. What am I doing wrong?

You can use a notification device directly by selecting the device (I assume that is what you are doing? I don't see the entire piston)

send push can work, but you need to setup a notification device in the main webcore app which will be the device used for send Push ....

If you post your piston (or test) can further comment / investigate

Thanks for your reply... below is the piston, and I do select a notification device, my phone "SM-...." and expected to get notifications in the HE app. Any suggestions on how to get this work?

Can you post the entire piston (green snapshot) so someone else can try it? Either here or in the webcore forum.

1 Like

Here you go! Thanks for asking.

I've come to this party late but looking at your piston there is no condition/trigger to start the notification.
e.g.
IF
Switch AAA turns On. (Missing in your piston above).
THEN
WITH
Your stuff.

Like I say if I missed the reason for this, sorry.

@bobbles & @nh.schottfam

Oops, I'm sorry, I did that in a hurry and forgot to note that I had deleted the trigger temporarily when I finished testing. The trigger was toggling a lamp on I use all the time, and didn't want to keep firing the piston for no reason, as that generated the voice notifications. :slight_smile:

I can see the notifications in the app, if I go to the Notifications section to look for them. However, they only appear in the app notification section, and otherwise are completely stealth, I never see any notification notice in the Android Notification shade, and never get any vibration or sound (as with all my other notifications).

Put the trigger back in and ran below several times right now - I get the spoken notifications as expected. I dont' get any normal Android notification from the HE app - no vibration, sound, etc. If I open the app and got to the Notification section I do see them there (below):

Notifications only appear in the app:

Not in the Android notification shade/pull-down:

Notifications are enabled for the app:

Not sure why this doesn't work...

I noticed this yesterday, with my phone too. i think there is a bug with the latest release @moncho1138
mine is a Samsung S9 what is yours @danabw ?

Samsung S10, thanks, @BorrisTheCat.

if you send a event from the device driver page, does it also only appear in the app.

Is it possible to add the webcore android app as a presence device like you could do in ST ?

Specifically has anyone modified https://raw.githubusercontent.com/ady624/webCoRE/master/devicetypes/ady624/webcore-presence-sensor.src/webcore-presence-sensor.groovy
to work with hubitat ?

Does reselecting Hub>Device from the settings menu fix this?

tried last night and just tried again, no it doesn't.

works on my wife's phone Nokia 6.1 both on Android 10 (stupid Samsung :poop: :rage:)

1 Like

I think it should work. I have not played with it lately, but on the HE side everything should be fine.

So I cannot comment on the HE mobile app.

I do see when I test using pushover that the notifications do go out. I also read these notes as webcore is sending the notifications, and you are more asking questions about how notifications are displayed in the HE mobile app (vs. if webcore sends them).

I'm actually mostly concerned that notifications sent to the HE mobile app don't get any "airtime" on my phone. No vibration, sound, or and don't appear in the android notification pull-down. The only way I can see them is by opening the app and looking for them....kind of the antithesis of a notification... :wink:

UPDATE: Uninstall/reinstall of the app fixed my notifications issues...some bytes must have gotte crossed up somewhere in the initial install. Notifcations now working.

This isn't a WC bug because it doesn't work in the driver page, so any further debugging needs to be on the mobile app thread to get fixed.

1 Like

Got it all working now. Ended up buying a pi to use instead of a vm running on my nas. I think, however, that it would run on any Linux based system with the changes I made to the setup. Basically I used https://github.com/imnotbob/webCoRE as the source. I also needed to amend the app.js file so that it would accept plain http instead of https. Now works perfectly. I always like to be as self efficient as I can and remove any external dependencies.

1 Like

Pi's rule the world...I use them for running UNMS and Unify controllers for my Ubiquiti setup, and also GAR. :slight_smile:

@danabw you were able to get the Webcore push notifications to work through HE?

Download the Hubitat app