Patched webCoRE for Hubitat (2018/09/09)

Thank you for your continued work on this, @nh.schottfam! You are a rockstar.

2 Likes

Please note that if you have updated to the newer webcore I posted, that there are some platform changes happening in Hubitat that you should ensure you have the latest to avoid issues.

See: webCoRE for Hubitat Updates

for the latest version.

1 Like

Did you sort this out? i just installed webcore and have the same error about "Failed to send IFTTT event", i know i've set it up correctly.

You know you can just input the webhooks link that you get from IFTTT in the make a web request action, correct?

That's what I ended up doing.

Also, it should be noted, if you are using Maker Webhooks to send a request TO hubitat via webCoRE, via the IFTTT virtual device, the link you will get in the piston dashboard will be correct now. They used to be incorrect but they must have gotten fixed at some point because I just checked them and they are right now. So, that's a bonus.

I have the latest webcore installed from ady624 (1st August 2020) and am trying to get a local version of the dashboard installed. I have followed the instructions found here https://community.hubitat.com/t/patched-webcore-for-hubitat-2018-09-09/1165 but I get a message stating A newer UI version is available. Does anyonbe know where I can get this newer version from as the installed version doesn't seem to be compatible.
Thanks in advance.

While you want to follow the instructions from the earlier notes, you want to take the dashboard files from the current repo of webCoRE for HE (ie this thread, note 1).

Thanks but that is what I've done and it is out dated. I am asking where I can download a more recent version of the server side dashboard for local install.

You can go to the original webcore site, but I think it is same.

Got it sorted now.
Basically use the dashboard from ady625 github https://github.com/ady624/webCoRE.git and use the webCoRE/dist/dashboard for the web document root. Ignore the git checkout hubitat-patches instruction. Follow the instructions here https://hoke.org/john/2018/05/the-hubitat-journey-continues-webcore/ but using the information in this post.
Just don't use the link in the Hubitat Webcore app to open the dashboard as this doesn't seem to work. Instead open a web browser, enter the IP address of the local installation of the dashboard and login when prompted.
Works perfectly. :slightly_smiling_face:

EDIT:
Well it did work well and then for absolutely no reason it just stopped working.
I didn't change anything at all. I went to bed and when I got up it just didn't work.
No idea what is going off but it seems that the only way for now is the web based version of the dashboard. The instructions are based on a pi and I'm using a virtual machine on a NAS so maybe I'll treat myself to a pi and see if that makes any difference but I can't really see how it will.

EDIT:
So all I'm getting is a blank dashboard when using the local dashboard option. I think the problem is something to do with authentication as I'm not getting prompted to enter a password any more.
I have to enter the code generated by the webcore app but then the actual password I configured under the security options isn't being asked for so that I presume is the reason for the blank dashboard. I've tried fiddling with the security settings but nothing seems to work.
Anyone any ideas?
Thanks in advance.

Have you tried installing using Hubitat Package Manager?
If you use HPM you are sure to get the latest files and can also be notified if there are any updates.

Thats not going to give me the local server dashboard installation though. That will only give me the hubitat apps that run on the hub. The dashboard is required for creating and editing pistons. I have installed the webcore hubitat apps via the package manager so they are the current versions.
I've given up on getting a local dashboard server for now. After a while it completely screws things up and it ends up where the pistons are still running but neither the local nor the cloud version of the dashboard will load the pistons. So then you have to remove the webcore instance, create a new one and then import all the pistons from a backup file. I've gone around in this loop several times now so it seems I cannot get the local dashboard working reliably for more than a few minutes. I'll stick with the cloud until someone can tell me what I'm doing wrong.

Didn't realise you were using the local method.

When I was running local to an RPi I would copy the files from my HE app file and paste them into my RPi file.
Never had any issues.
I gave up the local integration as I needed my RPi for something else and to be honest couldn't see the point unless the webCoRE server was pulled.

If you haven't tried this already, go to the WebCoRE app settings, click on 'Security'. You'll see the note "If your dashboard fails to load and no log messages appear in Hubitat console 'Logs' when you refresh the dashboard, resetting the access token may restore access to webCoRE"; click on 'Reset access token' and 'Clear all Security Tokens'. This page is also where you set your WebCoRE password.

Go back to WebCoRE settings and click on 'Register a browser'; make note of the code. Go to your dashboard server's IP; you should be prompted for your WebCoRE password, and then registration code. Those steps usually get me going when I have issues getting to my dashboard.

I did try that but didn't make any difference unfortunately. It seems I can swap back and forth between local and cloud versions a few times whilst testing but then both stop displaying and the only way I've found of getting it all back is to remove the webcore app, reinstall and then restore all pistons from a backup file.

You don't have to use the local dashboard for Piston editing. You can use the cloud dashboard to edit your pistons just fine. All the code is still stored on your hub for piston execution, just like if you used the local editor dashboard. So, running the local dashboard only gets your something if your internet is down or the webcore Dashboard is shut down.

1 Like

That's my approach as well...keeps things very simple while providing local execution, which is really the main point for me.

2 Likes

I thought we had to have the local dashboard because of the changes made to webcore for Hubitat (HSM vs SHM for example). But all of that info is controlled via the Groovy code on your hub, not the editor. So, the cloud works just fine.

Download the Hubitat app