Notifications in Hubitat mobile app not working

Several of us were talking in the Webcore thread, and have noticed that notifications in the Hubitat mobile app aren't working consistently on Android. Some phones working, some not. Anyone else notice this?

The notifications appear in the Notifications section in the Hubitat mobile app, if you go there to look for them. However, they only appear in the app notification section, and otherwise are completely stealth, and make no sound or vibration, and we don't see any notification notice in the Android Notification shade.

The notifications appear in the Hubitat app Notification section:

But notifications only appear in the HE app, not in the Android notification pull down:

Notifications (to appear and to vibrate/make noise) are enabled for the app:

We're not sure why this doesn't work...we were talking about this in the Webcore thread but it seems like an HE app issue that needs to be looked into, as it doesn't work from the driver page either.

1 Like

@danabw , @moncho1138 is the mobile app guy :+1:.

@moncho1138 have you managed to replicate it? By the looks of it, it's a Samsung phone issue so far.

A few things to check are:

  • Does notification show if the app is in the foreground?
  • Does notification show if the app is in the background?
  • Is the app set to work normally or is battery saved? (naming for this can be different from phone to phone.

I haven't been able to replicate my self, no Samsung phone handy.

Thanks for the questions. All battery saving and others restrictive actions are disabled for the app.

Notifications do not show or make any sound if the app is in the background. I have not tested it with the app in the foreground and the phone turned on, because that just doesn't work for me anyway. But I get that we should check that to see if it works in that case from a troubleshooting perspective. I'm in the road and probably won't r be able to test today.

Oops, I had forgotten I had uninstalled and reinstalled the app recently. When I reinstalled it I evidently forgot to go back in and turn off all battery optimizations. So on my most recent testing battery optimization was on. @BorrisTheCat, did you test with battery optimizations disabled?

Nope. Not for me

Nope not for me

Yes it's set to work normally not battery save.

Edit:

Just tested this again and also tried with the notification page open and that DIDN'T change dynamically, is that correct? Then went to the dashboard page and back and the 2 notifications I send where then there.

2 Likes

@moncho1138, any updates on this issue, based on the additional information that @BorrisTheCat provided?

Thanks!

Not yet, asked around for Samsung devices, but no failing on the push notification side. Hard to determinate it without being able to replicate.

Another thing that came to my mind was if creating a new device with the same actual device changes something, just for testing purposes.

Thanks.

So you're saying no one in the office w/Samsung phones can replicate the notification failure on their phones? That's interesting...would help if you can confirm if they include S9 and S10 devices, which I believe are what @BorrisTheCat and I have, respectively.

Regarding your suggestion for testing - I'm not sure exactly what you mean when you say "...creating a new device with the same actual device changes something..."

Can you provide more detail on what you're suggesting?

Yeah, when you select a hub, then it show a list of mobile devices, on that screen you can either select existing one or create a new one. Then with that one send a push notification from the Hub WebUI devices interface.

This may have possibility caused my issue? You said I had to have a device per hub inorder to get to the tools menu so I'm wondering if that's when it started :thinking:

I uninstalled the mobile app, reinstalled it and allowed all permissions (I had turned off Geofencing and location access.

Notifications to the mobile app work.

Turned off geofence, turned off location access and set to "Do not ask again" about location access, and notifications still worked.

So something got crossed up in the mobile app that uninstalling/reinstalling cleaned up. Issue closed. :slight_smile:

Nope this made it worse for me now the notification page just has a spinning wheel and never loads.

@moncho1138 any other ideas

@moncho1138 I fixed it but had to go nuclear (or clever version of it). I changed my network I'd and changed the driver. Then clicked the hub and now my old device was gone ( tried creating a new one with it there before and it didn't work maybe a bug?) . Then created a new one and got a event sent. In the new device page in HE, I copied the network ID and added a X to the beginning of it. I then pasted this ID (without the X) In my old device ( with all the rules and apps attached) and saved it. Tested it and it worked. Then deleted the "new" device place holder and then reselected my hub and device in the app and tested again. All good. So so thing went out if wack with that network ID on HE side.

1 Like

Funny, I was going to ask you if you had ever worked it out, and there was your post.

Ye gods...that is pretty nuclear. I'm glad you worked it out. Now that I have the built-in notifications working I'm pretty pleased w/it. I may try Pushover, but I went to Hubitat in part to avoid cloud connections, and don't like adding another 3rd party to all of my notifications...

1 Like

This is the 1st time anything like this has happened and on my phone. My wife's had a geo issue for a while but was fixed on a few updates ago. It's a new app and has come on leaps and bounds since release, the best thing about it is your location doesn't leave your phone :grinning:. That is unheard of with location apps and makes it extremely reliable for me.

2 Likes

Hoping it's not problematic to tag onto this thread. I've been having this problem for some time as well. The problem:

Notifications stop working. Notification screen shows notifications but they don't buzz/popup (etc) on the phone.

The solution:

Remove and reinstall the app (log in, reset permissions, etc.).

The problem:

It keeps happening. It works for a week or three and then suddenly the notifications stop again.

Phone: Galaxy S10.

Any further ideas???

V-

Just got a S22 ultra and notifications don't work at all. No amount of uninstalling reinstalling makes any difference.

App verson 1.6.7 build 126

Same app still also has the geo location issue too (where location won't update until you touch the slider bar)

These are 2 of the most basic functionality requirements and Hubitat seems to be failing catastrophically on both counts.

Obvs battery optimization off, location on all the time, always in use in background etc.

Download the Hubitat app