Patched webCoRE for Hubitat (2018/09/09)

Ugg a linux newbie

1 Like

Type in root bash and hopefully you will see this.
image

100% :joy:

if i type sudo bash in terminal i get this

image

Great that means you are in root. Or a root user I think. This has more permissions to do things.
Try editing the file now.

still get the same but im probably doing something completely wrong.

I open up the file explorer and find the file.
image

i then open the file and replace the contents with the new then try and save it?

should I somehow be doing all this using the terminal?

Yes

to this?

Or this

image

BTW. This is all being dragged up from memory. I'm self taught with this stuff. :blush:

1 Like

perfect then you know where i'm coming from :slight_smile: always trying to learn new stuff :+1:

done this and I have the same?

Great. Now amend the file.
This is what my file looks like.

how do i amend it through the bash window?

vi 000-default.conf
When you have made your amendments, type
:wq!
This saves your changes.
Then type
cat 000-default.conf
This displays the file.
Check it to make sure its OK.
OR
I can try and send you a copy of mine via PM and just replace yours. (I hope).
EDIT: If you do somrthing wrong and dont want to save your changes, type :q! and your changes will not be saved.

1 Like

going to try and do it myself if i can as that's the only way i will learn.

unfortunately when i put in vi 000-default.conf


I'm assuming this isn't what I want.
I tried to delete the file but it day i don't have the permission.

Not sure if this is right or not, but try putting in
kill PID=3802
This will kill the process that is running the swp file, I think.
Then try again.

Linux Newbies and VI... "You will never find a more wretched hive of scum and villainy. We must be cautious." :rofl:

vi is a magnificent editor that seems to have as it's primary goal to do more with a single keystroke than anyone thought possible. It succeeds and thereby demand that you memorize half the alphabet. :smiley:

Please try nano - anytime you read "just do a vi ...." replace those two letters with 'nano'
It's a more screen oriented editor and has the benefit of displaying a lot of it's commands along the bottom edge.

The alternative is of course, to Google vi and make a post-it note for your monitor. :smiley:

1 Like

Couldn't agree more. As a complete novice it seems to take me 20 attempts to amend a file. :rage:

Never seen this before. I like it.
Why oh why haven't I seen this before.
Thankyou @csteele for furthering an old retired gits education.

1 Like

BTW pico can be used as well. The PI guys created a symlink for pico to nano.

does this work with NANO?
how do you save the edits

^x

control and the x key

<press and hole the control key, tap the X>

in vi, the : means "here's a command" the w means write, the q means quit and the ! (exclamation) - I don't remember what that means, don't ask for confirmation perhaps. Very powerful to be able to do it all in one.

ctrl+x

Download the Hubitat app