Package Manager Error

While installing package manager, I am getting the following error. Tried the raw link, along with copy/paste.

Any idea what this could be?

errorjava.lang.NullPointerException: Cannot get property 'repositories' on null object on line 3542 (prefSettings)


Line 3542:

def oldListOfRepositorioldListOfRepositorieses = state.repositoryListingJSON.repositories

Not sure why this error has occurred. You will likely get the best support by posting this question in the app author's original post:

2 Likes

I think you have an outdated version of the code. That doesn't match up with the line numbers in the newest version. Can you make sure you have the newest code from github?

1 Like

1.8.0 is the version I have. Looking at github, that matches. Bit of a noob so I may be looking in the wrong place...

My bad, I was looking at the wrong branch. Could you provide the logs when this occurs? Seeing what appears before/after it in the logs will help figure out what's going on.

Sorry if this badd etiquette to paste screenshots, but plain text looked messy

Do you have pihole or something running? Something is blocking the GitHub dns from resolving.

Edit: FYI screenshots are the preferred method for that exact reason!

3 Likes

Screenshots are actually the requested method to display the logs as it is harder to read otherwise. :slight_smile:

3 Likes

Thanks for the tip. And no, not running pihole at all.

Something is preventing raw.githubusercontent.com from resolving to an IP. It’s working for me so I suspect something with the DNS server your network is using. I’d start looking there. Can you resolve that domain from your pc for example or do you get the same error?

1 Like

https://raw.githubusercontent.com/dcmeglio/hubitat-packagerepositories/master/repositories.json

Resolves fine for me ^^^

raw.githubusercontent.com --- Takes me to Github homepage

It needs to be reachable from the HE hub. Do you have a firewall or other network config that might be blocking outbound connections from the hub?

1 Like

II don't think my hub is allowing outgoing traffic.. I tried to setup a firewall rule with the mac address.. No luck.

Anyone with Unifi willing to help me out?

Willing yes. Able no. I have a UniFi, but I’m not skilled enough to help :pensive:

1 Like

I am having the same message after deleting and reinstalling Package Manager,
ava.lang.NullPointerException: Cannot get property 'repositories' on null object on line 3546 (method prefSettings)

Downloaded the latest version from https://raw.githubusercontent.com/dcmeglio/hubitat-packagemanager/master/apps/Package_Manager.groovy

Has anyone else managed to resolve this please?
thanks
Paul

Probably should post on the new thread ([RELEASE] Hubitat Package Manager -- HubitatCommunity), but if you do a repair on it, it should correct this.

1 Like

First, that's an expired repository. It will give you an OLD version (1.8.3) Dominic has left the Community and I volunteered to continue HPM maintenance using a new repository. However, you can get to the goal line from 1.8.3 IF you're willing to do all the steps. Begin by doing as @thebearmay suggests and a Repair of HPM. That will upgrade you to the latest (1.8.7) and solve most issues. You will probably see the cosmetic issue of two HPM entries, which is solved by following this:

If you look at the end of the topic @thebearmay suggested, you'll find the same advice offered to someone else:

2 Likes

Download the Hubitat app