Old user coming back to update all ,having problems...HELP(UPDATE) Pretty much SOLVED

Yes, I have used search, and yes I have done a lot of reading before making this post.
Been off hubitat for a couple of years, and forums have changed a LOT from my last visit.

My HUB has been working flawlessly for over 3 years unattended. With the exception of updating the firmware every now and then after I set the hub, it has been working without a problem.
I have been buying and collecting other equipment to add to the house but time has not been on my side. Recently I had a slowdown at work leaving me the chance to do all those projects that were on hold and BOY has Hubitat been busy during all that time.
Anyhow started by doing maintenance on the hubitat and trying to update all the apps I have just to find that some of the apps are now abandoned by their makers like Cobra and others.
Had a bunch of rules that were working intermittently but found out I had to recreate them again and now they working again for the most part.

First. The package manager has stopped working I guess because after so long I can't believe there have been no updates to some of those apps, every time I search for updates it always comes back with nothing to update. Updated HPM to v1.9.0 but still no updates. I did have to delete a bunch of duplicates as I read in a post that happened from upgrading to platform 2. something.

Second. I have rule machine and to be honest, is the one app I use the most for its simplicity. It just WORKS. Just keep seeing references to RM 5 but can't find where to install the app. Tried using built-in apps but it does not upgrade to anything, am I missing something here?

Any help with the package manager and RM will be appreciated. Every time I create a rule it says it's version 1.1 or 1.2 I think, I also have a RM that says legacy but I am afraid that if I delete the app I will lose some rules I have created.

After almost 5 years with my C8 I LOVE Hubitat and I will stay with it, just have to get up to date with the maintenance of it but when something is working without a problem you just forget about it because it is working LOL

Should I upgrade to the latest hub or is the C8 still going strong?


I accepted the continued maintenance of HPM (Hubitat Package Manager) in May of 2022, so it's been 18 months and yea, several HPM released have occurred. The latest is 1.9.0 and you have the latest. One minor change that has a big value is adding HPM's version to the pages:

Screenshot 2023-11-02 at 10.05.02 PM
so I'd suggest you verify the latest is running, not just added to the Apps Code page. :slight_smile:

Suggested reading:

As usual, the first post of a Community Code Release gets an update with each release too. HPM follows that convention:

1 Like

It would be relativly safe to just delete HPM at this point, from the apps list, and reinstall it. You could even fully remove the code and install fresh from the bundle download. Then clean up your apps and driver code, any duplictaes or things you are not using anymore. After that, and installing HPM again do a matchup which will pair any installed code to the repositories and then you can update it all from there.

Whats in your current apps list for Rule Manager? There could be Rule Manager Legacy, Rule Manger, or both. If you already have the plain Rule Manager that is the current version. If you do not see Rule Manager anywhere, you may just need to reboot again and give it a few minutes to build the apps list. The apps list (when you add a new app) is cached and after a large update sometimes it takes it a few minutes to refresh it.

C8 is the current model, I think you may have a C5 based on the age of it?

Yes, DO NOT delete that, if you have rules attached to it (as child apps) they would all be deleted if you remove the main app. It will keep working, but new rules should be created in the new app.

1 Like

It is a C7. I got it just when it was released or right after.

The C8 has an upgraded Zigbee chip which has helped somethings but made some other devices not play nice. Upgraded Zwave chip and external antennas for both which helps A LOT with range, and built in Wifi. Just about all the other hardware is the same.

For the C7 one of the things you will want to check is to update the zwave firmware (separate from hub firmware). This post explains how to do it: C7 2.3.1 and Z-Wave Firmware 7.17.1 . The post is a little dated and the current version is 7.18.1 but otherwise the update steps are the same.

1 Like

Apparently, I did this as I don't get the update firmware button on the details page. I did check and I got this response back from the HUB ,from a comment on the post to upgrade matches.

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7, zWaveProtocolSubVersion:18, firmware0Version:7, firmware0SubVersion:18, hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1, version:7, subVersion:15]])

1 Like

Tagging @csteele just in case.
After installing the new one, do a match first, then run update.

Any new rules you do will be in RM 5.1. You will see your old rules in RM Legacy

Edit: While writing this, I see @csteele saw it

Well did just that. Deleted it Installed it back asked me about hub security that I don't have enabled, went to the match packages, and then this error.

Error logging in to hub

An error occurred logging into the hub. Please verify your Hub Security username and password.

If I enable hub security and set up the password and username I still get the same error.

HPM isn't good at mind reading yet. :smiley:

If you have no security, then just leave it and click Done. If you have Security enabled, of course you must make them match. HPM must be given your login credentials accurately.

It's best to imagine HPM just clicks the UI the same as you... because mostly that's true. :slight_smile: IF you have security, it's going to paste in what you tell it. If that's incorrect, you get the message you displayed.

1 Like

I didn't have hub security enabled so I didn't check it, clicked done, and got that error. So I went back again to settings and enabled hub security back to HPM entered the information clicked done and the same error.
BUT figured out I was installing from the app menu and after following the first suggestion on this thread I followed the bundle install and that worked with no problem. Updating a bunch of apps that before it said they were up to date.

I think it's related to the giant step between what you had and the latest, both platform and HPM. Updating the Platform first then HPM, is going to cause a known problem. Once you have that problem, recovering is easy, if the recipe is followed. You should look in your Apps Code and Driver Code for duplicates. That's one of the symptoms of v2.3.6 and HPM before 1.9.0.

Updating Platform first is what I expect because who'd go searching for a Topic on HPM first ? :smiley: However, in this case every effort was made. The Release Notes for 2.3.6 have a breaking change notice, pointing to the same Topic. But again, who reads Release Notes first? :slight_smile:


I have to say, there was a lot of outdated stuff on my HUB. I deleted a bunch of duplicate app code and driver code in it.
There are also a bunch of apps that I guess have been abandoned by their makers and haven't been updated in years but at the moment they still work and until they fail or I find a replacement for them I will keep using them.
I thank all of you who helped because I now have an updated HUB that apparently is working 99% as I don't want to jinx it by saying it's at 100% LOL


Well we're here to help you work your way through things!


I agree and have the same notion.

If the code is adequate, and no updates are needed, then even if the developer hadn't 'abandoned them' the code would be old. I think of HubConnect as a good example of that.. I'm still maintaining it but haven't touched it in a year at least... because it hasn't needed touching :smiley: It got "Done" and that's where it remains. There's a tiny niche to still utilize it, plus I continue to use it :slight_smile:

1 Like