Okay I am about to give up

Huh? You cannot pass Z-Wave certification if your hub cannot take on the role of secondary controller.

So they've said. I don't think Z-Wave "certification" means squat.

Why would there be so many issues if all z-wave devices had to pass some sort of test suite in order to be "certified"? I think it's nothing more than marketing BS, or the bar for certification is so low that it's meaningless in the real world. And I'm not talking about HE specifically, but z-wave devices in general.

In any case, I keep hoping things will get better with each firmware release, but they don't (in this regard).

1 Like

Not sure which issues you are referring to. There were certainly issues with the 700 series firmware from SIL, but that’s nothing to do with the certification.

I can tell you for a fact that joining the HE hub as a secondary controller works, because I’ve done it. So I’m curious if you have a C7, followed the Hubitat Z-wave user manual for using Learn Mode with an S2 compatible controller, and still found that it didn’t work?

There's plenty of threads here and in other ha forums about issues with zwave devices. If device A is certified to work correctly and device B is also certified to work correctly, then it stands to reason that devices A and B should work correctly together. Otherwise, what exactly is being "certified"?

I'm assuming that for a zwave device to be certified, it has to be able to listen for, parse and correctly respond to certain commands, and has to transmit well formed messages with correct content at the appropriate time.

I used to work for a company that designed wireless devices. I was in charge of the software group and we had a whole suite of automated tests we would run on the devices when the firmware team had a new release. Everything had to work according to the published API, and all the different device types had to interoperate correctly. If not, it was fixed and new tests were added to prevent regressions. Maybe I'm all wrong about what the zwave certification process is though.

In any case, I'm not talking about HE being the primary and including another controller as a secondary. I'm talking about HE being a secondary to another primary controller. Supposedly a 700-series controller must work as a secondary in order to pass certification, it isn't optional.

Yes, C7. I understand how secondary controllers work and their limitations and I don't expect any special functionality beyond that. SmartThings (v3) works fine as a secondary to two different alarm panels that I have (Simon XTi and Qolsys IQ2+). Even the older Nvidia Shield ST Link worked fine with both.

Maybe its HE's code, maybe it's Silabs firmware, I don't know. But if HE passed certification then it ought to work, right? Unless the bar for certification is so low that in real world situations it is meaningless.

I’m not talking about HE being the primary either. Learn Mode is so HE can join as the secondary. HE must allow other hubs to join as the secondary, but that is done by putting HE into inclusion mode and then activating learn mode (or whatever the other manufacturers call it in their hub).

I joined an HE C7 (the Secondary) to a Wink hub (the Primary) and it worked just as expected.

Well, maybe there's hope but it doesn't work correctly for me and I've tried repeatedly.

I have a brand new QolSys IQ2+ not in service yet. I did get it to join to that, but the results were wierd. I've posted fairly detailed info here: 2.2.4: HE as secondary z-wave controller not working - #12 by dcaton1220

I've gotten it to pair a few times with the alarm panel installed in my house (same brand, Qolsys IQ2+) which has about 20 zwave devices and ST paired as a secondary. But with that one, HE didn't create any devices and in a few cases the zwave system seemed to lock up as I couldn't even access the zwave configuration page. Several reboots and zwave radio resets eventually cleaned things up. A few times it got as far as the alarm panel asking for the security key, sometimes it doesn't even get that far. But the end result is always that I have to reset the zwave radio in HE and reboot at least once.

I see from the other threads you have communicated with @bcopeland about this. I cannot speak to why you don’t get the expected results with the alarm panels. I’ve only tried this with a Wink hub. Didn’t have a Smartthings hub to try it with. That was sold two years ago

Maybe it's because we're both in Toronto @SmartHomePrimer but I successfully joined a new C7 as a secondary controller to a SmartThings V1 hub last week. :slight_smile:


Lol. I think that parallel has little to nothing to do with it, but that’s good to hear it works there too. Thanks for the feedback!

I think that it's indisputable that Hubitat had a number of issues with the release of the C7 and in particular with 2.2.4.X. Weather it was the new zwave stack, or something from SILabs, or something else, I don't know, but "pulling a release" was a first (I Think) for Hubitat.
I'm sure that they don't want to relive the events of the past few months.
I hope that I'm not being an apologist for the company, but I hope that they have learned a lot of lessons from these last few months, and they have improved their abilities and approach.
I still feel that they have come a long way in a very short period of time. I also think that they have a great concept, and a good attitude. I'm sure that even they would admit that they've made a lot of mistakes over the past few months.
Nonetheless, I'm sticking with them because I think they are still getting better, and they are still in the process of perfecting their product. I'm sticking with them because I think they listen to their customers.
Oh, there were times in the last few weeks when I was very frustrated - but I gave myself the same advice I give clients - "have patience, things will work out". I definitely think that things have gotten better.

1 Like

OKAY. So I added a ring Gen 2 extender and this is the $%&T that happened. Before adding this extender all devices were communicating and the extender is literally 5 foot rom the HUB. WTH

Only thing I see is some routes are updating... What are you trying to show?


Are your devices/automations working normally? Just want to clarify if you are concerned because things aren't working properly, or because of how the Z-Wave Details page looks.

Did the Z-Wave page look like this as soon as you paired the Ring?

Can we assume you've done basics like shut down the hub from Settings menu (LED goes red) pull power, wait 30s, reboot?

Did all that. No devices are taking commands except for zigbee. The ring doesnt even appear to be connected to the hub.

How long has it been since you added the Ring?

Did it add w/out routing from the start?

Try removing and rejoining the ring. Do you see busy messages in the past logs?

added it about an hour ago and was routing just to the hub at first . Thats when I did the shutdown and pulled power hoping that other devices would route through it. When it rebooted I lost the 2 devices and the ring doesnt route.

Devices are only going to route through it when they want to. Only thing that may pursuade them to change their route would be a device repair. Even then they may not choose the ring. As for why devices stopped responding may be due to an incomplete pairing. Can you check the setting zwave details again and post a screenshot?

Okay after 5 reboots and removing the Zwave stick on pc commander the ring appears to have connection but the pump house power strip is in the same room as the ring and even doing a repair the power strip wot do anything . Just dont understand why the zwave just is so unstable

Any devices with nothing in the clusters column?