Odd Zigbee Behavior on the C-8

Excellent news, thank you.


Credit to @scunny for helping out with the V1 unit for Mike!

And thanks for offering, @liquidskin.


@Tony, just discovered this thread. Your detailed description matches my experience perfectly. My Zigbee table contains the Null children. In my case I was trying to join a basic Zigbee 3.0 Tuya motion sensor. This sensor was joined to my other C7 with no issues.
No amount removing the battery, of joins or rejoins, to the C8 ended in success. Seems to get stuck in the join process according to the logs. However it appears to join in the UI. The device does not work, there is never any motion events.
I only tried joining near the hub. I gave up and joined the sensor back to the C7 with no issue.


Yes, these devices (I used LoraTap Zigbee 3.0 4- and 6-buttons) join/work normally on C-7 (and C-3, for whatever that's worth). Try this on the C-8, and a sniffer trace shows the C-8 responds immediately to the association request with 'association successful' and assigns it a device ID, however after several seconds of data exchange between the device and hub, the device ID stops appearing in the trace and it apparently leaves the network. I was able to produce a successful join (once) after resetting the C-8's Zigbee radio. Not sure why (note it was a 'nuclear option' reset, not a mere radio reboot).

Having watched how the C-7 handles rejoins, it now mimics the C-8's unusual join behavior in most respects, with a new oddity of its own-- 'disappeared' devices never get aged out of its child table. I'll put my observations in a separate thread.

1 Like

Please do.
I can confirm the C-7 issue as well.

1 Like

Here's what i'm seeing with the C-7:
C-7 Zigbee behavior on - :bellhop_bell: Get Help - Hubitat

FWIW, I just saw this on another thread....

Just want to say I am pretty sure I am seeing the same thing. Right after migrating I noticed a Third Realty Switch I have was no longer working. I could not get it to pair. Thought maybe it was just a coincidence that it went bad just after migration. I have another Third reality that migrated and seems to work fine. That one that doesn't work will pair but only briefly. As soon as I send a command to turn the switch on or off it goes back into pairing mode. I tried deleting device, resetting and re-paring. No dice. After reading this thread I decided to try it on my C7, which is at the other end of the house and it will pair and is again working. I thought maybe because it paired though a router.

I now also have two Iris V1 buttons and neither will pair to any of my hubs, C5, C7, or C8. They were working fine, prior to updating to C8 firmware. There are some V1 motion sensors that are working however on the new C8 hub, they migrated over with no issues apparently. All hubs currently have the latest firmware. I think I am going to take my C5 that I migrated to a C8 and reset and bring it back up with a old firmware prior to the C8 migration firmware and see it they will pair. Is it confirmed there is a issue with the V1 devices? Will this prove anything. I do see the null child devices, see below

Child Data
child:[null, 0C90, type:UNKNOWN]
child:[null, ECFD, type:UNKNOWN]
child:[null, 24B3, type:UNKNOWN]
child:[null, 4A48, type:UNKNOWN]

i still see no child data for device 0, but all devices appear to be working including the one outdoor hue motion that did drop off 2 days ago..

I don't have any Iris V1's but similar issues have been reported; I see child data similar to what you're seeing on the C-8. You'll probably find that what would normally be the device ID (short ID) of a child device is now the 16 least significant bits of its MAC address. Pretty sure the null shown there is a symptom of some process failing to completely match up a joined device with its instance in the device database (its name should be there, instead of 'null').


Was hoping one of the weekend updates would fix my Zigbee issue, but I still have the null devices and my Zigbee V1 devices will not pair.

Did you use the new "rebuild network" option?

Can't fix everything at once. :slightly_smiling_face:

Work on other issues is ongoing and additional releases are coming.

1 Like

I was just hoping.

I had not tried the rebuild but I just did. Mainly was just looking to try and get my 2 V1 devices to add back in. It did clear up 3 of the of the 4 null devices, still one left though.

I will just move my Z-wave devices to the C8 and wait a bit before I add any new Zigbee.

1 Like

Just updated to latest build and my Third Reality switch that would not stay connected has stayed now for 20 minutes or so. We will see how it does over night. Before it would drop as soon as I sent it a command.

The V1 still will not pair, and I thought maybe it was me. I realized this time when I tried to pair that I was using the normal Zigbee pairing. It had been so long since I had done a Iris V1 I forgot it has a separate pairing button. Still didn't work though, but it does pair to my C7. So apparently it is something in the C8 and not the firmware.

1 Like

Fixes for Iris V1 on the C8 are not in the .113 release. Expected in an upcoming FW.

I didn't think it was, probably should have mentioned I was just reporting my findings.

Also my zigbee routing table is a bit more complete but I still have two Null entries for child data.

AFAIK C8 child data is still WIP.

Yup - just clarifying for anyone happening into this thread. :slight_smile:


(Hmm, accidentally deleted a post I tried to edit...)

I'm having a slightly different issue with Zigbee on a C8 - I've topped out at 51 devices total and can't add any more. Joins time out after displaying "Found a Zigbee device, initializing...". The C8 in question is in my office along with three other working Zigbee plugs.

getChildAndRouteInfo only shows 16 in the neighbor table and 10 in the router table. I've reset the Zigbee radio, tried both new and factory reset devices, rebooted, etc. My other C8 only has 5 Zigbee devices so no issues there. No issues with the C7 or C5. I'm running Hub Mesh with both C8s and the C7 if that's a clue. All are running

I've pulled a number of devices that were migrated from a C7 to see if that would make room for new things but no luck.

The route table is dynamic it does not represent a limitation.