[NOT SOLVED] Corrupt database

Ok, today my hub's dashboard was unresponsive.
tried rebooting it, but no luck.
Then restarted in safe mode, and after a while the default page cam up, stating the database was corrupt.

The settings menu was also unavalible, so no way to restore the database from there.
So from de emergency page, I did a soft reset.
The welcome page came up, and I could get into the settings page again.

Did a restore from a backup from last night, as the hub came unresponsive this morning.

Now it seems to be in a boot-loop. Starting up, going to about 70%, then restarting again.

Any ideas as to how I can restore the hub?

Also, if someone knows why the database could be corrupted, that would be welcome.
Last change I made to the hub, was over a week ago, and that was only an update from the hub-info app.

What hub and version?

I ran into same situation a week or so ago. It fortunately restored correctly. Zero interaction with the hub for days prior to the corruption. Obviously a problem that needs resolution, since it’s never happened in the many years I’ve had Hubitat through multi hub versions.

1 Like

My C-7 on .128 has done it twice in the last week. The reason I was asking what hub and version that @fanmanrules was on.

There are so many moving parts that are literally making changes on your behalf every second. A user may not need to make physical changes, but an brief power outage at the wrong time, an app, a device, a lan or cloud connection can spin out of control for a week and that would be enough to put stress on the live database.

With that being said, a Soft Reset will restore a functional database. But it is critical for the user to screen the logs after the reset to make sure that what caused the problem in the first place, it doesn't continue to cause problems.


Was on the last version.
I did a soft reset again, restored the database again.
Still boot-loop.
Then I hard restarted the hub, and now I can login again.

All devices seem present, and I see device reactions, but the logging throws java errors with every device:

My hub version:

Ok, new problem.
When I try to access a app, I get java errors.
When I try to uninstall an app, also java errors:

Restored to a backup from two days ago (only a few kb diference from last backup) and that one seems to be correct.
The java errors seem to be gone.

1 Like

Just came here to say the same thing happened to me twice following two power outages.

My hub is behind a UPS, so no powerloss in my case.

Well yeah, that would be ideal and I have full intentions of doing that now that I've got most of my home migrated but I'd still like to get to the bottom of the problem. My internet is also on a UPS and I'm thinking about running a simulated power outage with both.

C7 / 128 also. Never happened before. Def something wrong if it’s happened to others too.

Mine also. Almost everything in my home is on a battery backup except my garage which has no wired HA / Network devices combined with a whole home generator that then takes over.

All of mine are also on battery backup so that is not the cause. I also have a ghost that I have not been able to remove to this day. Supports answer was to wait for the next release that they are working on. I assume from that answer that it is an ongoing problem that HE support knows about and is trying to come up with a fix. The ghost actually locks up multiple Aeotec gen 5 Z-sticks all of which cause the light on the stick to light up solid blue only when working with the ghost node. I can work with all the other devices except the ghost.

And here we go again.
No changes to any driver, app or code..

For the ClassFormatErrors, please run this endpoint:

This should only be happening with user apps/drivers. The error definitely points to some sort of a file system corruption. I can check more once hub is up and running.


Hub is back online after two restore attempts

Found anything gopher?

Nothing definite yet...

And again, hub down, interface: 500 Internal Server Error
This is getting ridiculous...

This time created a support request to Hubitat support.
Hope they can find something.