Node-RED - after update cannot select any devices in command/device nodes [solved with v1.7.2 release]

@fblackburn

So I upgraded Node-RED to 1.3.3 now I can no longer select devices from the dropdown in Device/Command nodes. The cache is not being built/rebuilt for some reason. The devices already set in my sequences still appear to be working - events fire as usual.

  • rebooted the NR server.
  • I redid the token
  • I rebooted the hub and have "rebuild cache on systemStart" checked.
  • webhook appears to be working, got the green check and events are received fire.
  • I tried Websockets
  • I checked the logs, no errors.
  • This is happening on all my 3 hubs.. not just the C-5 I posted here.
  • I accessed NR on a different machine/different browser - still no go.
  • Hubs are on latest firmware 2.2.6.140
  • Am on HE Nodes v1.7.0

Is there a way to manually reset the cache? edit: from the docs I created an inject sequence.. still no go.

1 Like

To report back - I downgraded to Node-RED version 2.9 by doing this in the Node-RED users directory

sudo npm install -g --unsafe-perm node-red@1.2.9

That did not work, then reverted HE Nodes to 2.6.2 and that worked!!!!

npm install --unsafe-perm node-red-contrib-hubitat@1.6.2

Able to select devices!!!

Then updated NR back to 1.3.3 using the Raspberry PI script.

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

Note: probably should have tried to rollback the HE nodes first (doh!!!)... ah well like to do things the hard way apparently..

1 Like

There was a post about this yesterday as well
https://community.hubitat.com/t/node-red-nodes-for-hubitat/34386/4728

Looks like it’s a good thing I did not upgrade :flushed:

1 Like

Thanks, totally missed that! So it's just the HE Nodes not Node-RED version.

Although I am getting some weird MQTT closed errors in the MQTT nodes so I might just revert NR back to 1.2.9 anyway.

Looks like that may be the issue. Hopefully @fblackburn will figure it out.

1 Like

Oh thank you for reporting, I'll look at this tonight
My guess: the issue is only on the UI part (not from the flow/cache/etc..).
Can you give me the setup you use to access NR? (which browser, version and OS)

I cannot reproduce, so I'll re-read the code and some JS concept to be sure everything is fine.

Did you try to hard refresh browser (or access in private mode) after the upgrade?
Did you have the same thing with:

  • command node
  • mode-setter
  • new created node
  • edit already deployed node

edit: Did you have an error in the browser debug console (F12) when you open the menu?

Okay cool! I went ahead and updated to the latest version again and got the same behavior. I tested it on several different browsers and computers to be sure..

Google Chrome v90.0.4430.85 (Official Build) (64-bit) / Windows 10 (latest)
Firefox v86.0 (64 bit) / Windows 10 (latest)
Google Chrome v90.0.4430.85 (Official Build) (64-bit) / Fedora Linux
Safari v14.0.3 (16610.4.3.1.7)/ MacOS (M1 - latest)
Chrome v90.0.4430.85 (Official Build) (arm64)/

Cool thanks!

Yes to both..

Command Node - yes
mode-setter - Works, sees the various hub configurations.
newly created node - yes
edit already deployed node - yes

The hub config list shows up fine in all nodes. Also the deployed nodes still work fine even though nothing is showing in the "Device" box.

I am running Node-RED on a Raspberry PI 4 with 4 GB memory and Ubuntu Server 20.04.2 LTS 64 bit.

If there is anything else you need me to test or other information let me know. Also @samgann seems to be experiencing the same problem. Thank you for all your help!

Nice thank you

Now can you tell me if you have any error message in the browser debug console (F12) when you double click on a node to edit?

Here's what I'm getting from Chrome on Windows 10:

Ok now, if you look at the network tab and hit F5. Can you paste me on which resource the 404 occurs?

If you prefer, we can continue in PM, to avoid any info leak :wink:

1 Like

It's okay :grinning_face_with_smiling_eyes: - my internal ip addresses aren't that secret.. just don't want it out there in an image forever if I can help it. Also this debugging might help others!

1 Like

Thank you, it's clear about the issue :+1:

I'll search how it can happen. If tomorrow I still found nothing, I'll revert this change to fix it

1 Like

If you need anything else let me know!!!

I reinstalled Ubuntu 20 server and installed Node Red and everything worked.
Then I created a password to login to Node Red webpage. After creating the login credentials under settings,js I had the same problem above and what i reported 2 days ago. Remarked out the credentials in settings.js and everything worked again as far as the being able to select devices in node red.

1 Like

Nice catch, I can confirm, I'll fix it

But @erktrek has 404 and this one is 401 (unauthorized) ... :slightly_frowning_face:

@erktrek do you have NR login enabled?

no not right now. I can enable it though if you need me too.

I do not.

I cant remember if I had 401 or 404 2 days ago. I updated my node red and the problem above happened. I did have login credentials in the settings.js All i had to do was restore from backup and my system was working again.
I'm running Proxmox virtual server so its pretty easy to fire up another machine.

I was running Centos 8 with Node Red.
Switched to Ubuntu 20 and reinstalled Node Red.

Also my NodeJS Version is 14.16.1 and npm is 6.14.12

I have been having this issue with both Node-RED v1.2.9 & v1.3.3

I have reverted back to 1.2.9 due to other NR issues..

1 Like

I don't have this issue:

node v15.14.0
Node-RED v1.3.2
node-red-contrib-hubitat v1.70

I don't have NR login enabled.

1 Like

Download the Hubitat app