New Tuya Zigbee Wall Switches

Hi all Hubitants!

Tuya has realeased some new Zigbee wall switches that fail to work with the old drivers (Generic Zigbee Multiendpoint / Generic Zigbee Switch With Presence (this one is the one from Markus, the one I’ve been using in these last 2 years) and Aurora drivers

Hubitat finds the parent device, but fails to detect / control the child ones. (Switching the parent device on/off does nothing.

I’ve tried switching MultiEndpoint discovery On/Off several times, removed/reinstalled, repaired while still installed… Nothing works…

Anyone with new drivers out there?

This is the Switch:

You might want to check with @kkossev if he has any drivers that might work.


Have a try with the system 'Nue Zigbee Switch'.
It may work.


As suggested by @bobbles , the 'Nue Zigbee Switch' is the driver to try (if not done yet).
This smart socket combined with 2 x Zigbee switches is specially made for Brazil, so I don't know the details.

@gusthepenguin please copy and paste the device 'Data' section (even if it does not work with the driver you are testing), if we know the Model and the Manufacturer IDs we can have some more clues.

1 Like

@gusthepenguin for the smart socket you can try this driver. Pres the 'Initialize' button after switching to this diver. It may control the plug on/off, but for sure will not handle the additional two switches.

Hi @kkossev !
Thanks for the help!

Neu driver did not work.

Using your Metering Plug Driver I was able to turn both switches on and off at the same time, but not one at a time. But even when initiatilized / refreshed the child devices were not found.

Here is my data section:

  • endpointId: 01
  • application: 51
  • softwareBuild:
  • inClusters: 0003,0004,0005,0006,E000,E001,0000
  • outClusters: 0019,000A
  • model: TS0003
  • manufacturer: _TZ3000_vjhcenzo
1 Like

Thanks @bobbles, but Neu did not work…

The power outlet does not turn work, even when I turn the entire parent device on..

That's a very new device, Google search on the manufacturer code it shows 0 results.. :frowning:

Currently, this driver does not support any multi-endpoint devices. '

Obviously with the first exposed EP is the one that controls the switches, that why both switches are turned on/off at the same time, but the outlet is not controlled.

With the Tuya Metering Plug driver, enable the debug logging.

  • unplug the device from the mains, wait a couple of seconds, and plug it back on.

  • Then manually press switch 1, then switch 2

  • Then manually switch the outlet On / Off (from the button on the side ).
    EDIT: seems like your device does not have a manual on/off switch?

  • While on, connect some device that consumes power > 5 Watts.

Please send me the debug logs as a PM (Private Message), I will check them in the next days

Before going into debug logs, you can lastly try Muxa's driver, it is written for TS0003 :

1 Like


This one worked perfectly!

Problem solved!

Thanks so much!!!


@gusthepenguin please use the modified Muxa's driver code :

It turned out that these new devices require a special initialization sequence to be sent during the Zigbee pairing process in order to be able to control the 3 child devices independently.

In your case the unmodified Muxa's driver worked just because your device was first initialized 'a-la-Tuya-way' by the Tuya ZIgbee metering plug driver..

After updating the driver, please re-pair the device again to Hubitat zigbee network. You don't need to delete it, just go to Devices->AddDevice->Zigbee->Start Zigbee Pairing and pair the device again. After this, you should be able to control the child devices independently.

1 Like