New hub will not connect

Got my new hub and cannot get it to connect. Firewall off, internet connection good with all other devices, correct user name and password, tried manual IP address and DHCP. Followed some advice from support but have lost contact. Spent hours today trying to get this to work. Frustrated and a bit disappointed.

Does the manual ip address on port 8081 show anything?

Does the hub have a default Ip address?

You said you set DHCP, did you create a reservation for it?? The MAC address is on a sticker on the bottom.

You have a router (ISP Modem?) thats doing DHCP and issuing "random" addresses. You don't want that for the Hub, you need a static (never changing) IP address. You do that via DHCP Reservation within the GUI of your Router.

Do that and then reboot the hub, so it uses the DHCP reservation address you picked.

Silly question but only cause it happened to one other person. Are there any lights on the hub or usb stick?

I was under the impression that this was plug and play. I set my Mac IP address manually and by DHCP. I did not set anything for the hub, I did not think it necessary. I am completely lost now because I have a very limited knowledge of these matters

Blue light is on. It is the new hub so no stick

What type of home router do you have? Can you please log into your home router and find a section that lists all of the current DHCP leases? You should see one that matches the MAC address on the bottom of your new HE hub. Write down that IP address that is shown, and the attempt to connect to the hub by using the following URL

http://ip-address-you-found

If that doesn’t work try the same url as above but with :8081 added to s the end of it.

Blue light.. excellent! :slight_smile:

when you visit http://portal.hubitat.com, do you see the words in this Image?:

Below those words are boxes, one for each hub you own. Location Name. You should have one. ( I own three, so I have three boxes. )

I get to the list page but my hub is not there. The MAC address does not show up in my routers list of leases

Does the hub have a default IP agrees or is it dynamic?

The hub always uses DHCP to obtain an address. Have you tried a different Cat5 Ethernet cable, connected directly between the HE hub and your router?

What brand of router are you using...?

It is a Motorola gateway. I have switched out the ethernet cable

Randy. Is your hub a new c-5 model? Can you try unplugging the power, make sure the Ethernet cable is properly seated and plug in the power.

Is there a red light on in the front or what color is it?

It is possible you may have a bad power supply so let's start with the basics and make sure things are powering up.

It is a c-5. Have unplugged and replugged numerous times. Ethernet cable is seated, green light at router. Blue light on front

Ok. Sending you a pm. May need to manually register it.

I couldn't get mine to register with my computer, but was able to do it with my phone in Chrome.

I also am seeing this same thing. Brand new hub just arrived in the mail today. Wired directly to my core switch and has link on the switch, solid blue light on the hub, but I find no DHCP requests and it, obviously, does not show up in the portal dashboard.

Using the MAC address on the bottom, are you able to create a DHCP reservation?

Then reboot the hub to get it to use the reserved address.

I've read that the Hubs come with no Hubitat Code installed, In other words, they must download code the first time. That obviously requires an IP Address and Reservation success. I Mention this because that means the factory fresh Hub only has the Hubitat specific image of Linux they deploy.

After a reboot, you can also try browsing to: http://{your reserved IP}:8081
There's nothing useful there, just the knowledge that it booted to a working webserver, etc.

I powered off the device. Set up a DHCP reservation for it, then powered it back up.

Once again, the light almost immediately became solid blue (power on and blue status is 5-ish seconds, which I find to be an awfully fast boot time...), and nothing. Navigating to the IP:8081 .

Checking on Wireshark, I do see multiple ARP broadcast requests from IeeeRegi_80:00:f2 (the last 3 hex of the Hubitat MAC) all of them asking for who has 8.8.8.8 and to tell 169.254.9.190.

Yeah. No idea why it's trying for an outside DNS service, while having an invalid IP for my network.

7723 380.617780 IeeeRegi_80:00:f2 Broadcast ARP 60 Who has 8.8.8.8? Tell 169.254.9.190

Download the Hubitat app