New Caséta fan controller!


#101

Today's response from Lutron Support:

Integration support for the fan control is being rolled out over the next few days in a bridge firmware update. Please keep the bridge connected to the internet and online so that it receives this update.

We expect that all active and online bridges will be able to get the new firmware revision by March 1st.


#102

FYI. My Caseta Fan Controllers were just updated. I don’t have them on HE, they’re on homekit. They weren’t working a while ago but are working now. I can set speeds in 25% increments using Siri.


#103

Was this a homekit update or a Lutron update?


#104

Lutron. I emailed them yesterday and they told me the update was coming but didn’t give an exact date. Just happened a while ago. Works awesomely. I figured someone here could check HE functionality changes.


#105

Does homekit integrate via telnet as well? If so, can you send back-to-back 50% commands and see if the physical switch toggles between speeds or stays on Medium speed?


#106

No just connects through the wired network but it’s very well integrated. Whatever you have on Caseta except for Pico appears in Homekit instantly with either shared or unique name. My picos still work but are on the Lutron network. I use voice and motion sensors for literally 99% of my automations. I’m not on telnet but any speed I command works fine in 25% increments. Have you tried your back-to-back commands in the last hour? Maybe they work now.


#107

I just tried them when I saw your first post, still does the same thing. Not sure how to check my firmware version to see if it's been updated.


#108

I’d call or email. They were brilliantly helpful when I contacted them by email. Few hour turn around which surprised me considering their size.


#109

Just called, the guy I talked to wasn't super helpful. He said the update was starting March 1, the support email I received earlier said everyone should have it completed by March 1. I also asked how to check firmware version, he pointed me to the app version and said it's the same thing as the firmware version? 6.5.0? That doesn't seem right to me.


#110

That sucks. I guess I just lucked out in support call roulette. Sorry.


#111

No worries, I might try to call again tomorrow. What's your app "firmware" version? 6.5.0 also?


#112

Yes 6.5.0. That’s not what made it work today though. That update occurred a week ago. My controllers appeared in homekit but said unsupported until this afternoon. There must have been something pushed out by Lutron today. There was no apple update today.


#113

Yeah what the guy said about the app and firmware being the same thing didn't make any sense. Figured I'd ask anyway just in case.


#114

Hopefully it will be sorted soon.


#115

I was just on the ST site. It seems the fan switch is not supported on ST yet with no scheduled ETA but there’s a guy showing his fan switch working in Apple Homekit and his post was 23 hours ago. I don’t know what’s going on. I couldn’t tell his location and didn’t want to ask. Just mentioning this. Sorry to divert/clutter the thread.


#116

If it is a firmware update it may have started rolling out yesterday or something. Who knows. Will keep an eye on things and see what happens. I wish there was a way to see firmware version or do a manual update check.


#117

You are right of course. Nothing else makes sense as to what happened.


#118

Per Lutron support today, app version will be updated when the firmware update rolls out.


#119

I cannot reproduce the problem you mentioned regarding fan speeds changing when sending the same dim command multiple times in a row.

I am using the Hubitat device details page for my new Caseta Fan controller. I use SetLevel to 25 (Caseta App shows Low). Then SetLevel to 50 (Caseta App shows Medium), then 50 again, then 55, 50, etc... The speed stays at Medium the whole time. Maybe they've already pushed the SmartBridge firmware out?


#120

What do the LEDs on the fan controller itself do? My app shows the correct commanded speed, but the fan control and the fan do something different.

I just tried again, started with my fan at 25%. Sent 75 then immediately another 75. App shows medium-high and does not change. Fan controller initially went to the second highest LED (correct), then dropped one (not correct). Fan was at medium speed (even though I sent med-high and app showed med-high), until I sent a 3rd 75 command, then the fan controller went back to second highest LED and the physical fan speed went to med-high.

For description below, I'll call the lowest LED position 1, and the highest position 4:

  1. Fan initially at 25%. LED position 1. Fan physical speed low. App shows low.
  2. Sent 75% command. LED position 3. Fan starts to accelerate. App shows med-high.
  3. Immediately send another 75%. LED position 2. Fan physical speed medium. App shows med-high.
  4. Sent another 75%. LED position 3. Fan physical speed med-high. App shows med-high.

All 8 of my fan controls do this same thing. App and Hubitat stay in sync. Fan and Controller stay in sync. App/Hubitat and Fan/Controller are not always in sync.