New C7 hub, Aeotec Dual Nano & Multisensor6 issue... Australia

New Hubitat C7 user here... newbie to the C7 but not to Z-Wave, which I've used for years with Home-Assistant.

I've set up the C7 (ver and started moving some ZWave devices across. I note these are all Australian Z-Wave devices on the AU frequency. All devices were working in a home mesh with Home Assistant previously (as in, until I excluded them / factory reset them).

First I moved three Aeotec Nano Dimmers ZW111 (with Wallswipe units) over. No issues connecting them, once I got the light configuration details input again.

At this point, I did shutdown the hub (to physical move it) and removed all my config and devices for no reason. Fortunately with only 3 devices, I simply re-did them. PITA but :man_shrugging:

Then I added a Fibaro FGS-212 (the 2.5kW switch) ... after swearing at it a lot to reset it ("hold B button for 3 sec just after but not while inserting the power, then release, then power cycle again" seem to do it in the end) I was able to add it fine. However it doesn't have a built-in driver, so I selected "Fibaro Switch" and it works fine. This is the most important device in the house... it lets me turn on the espresso machine from bed. :sunglasses: Simply 'on/off' on dashboard is fine and seems to work.

Now... to the problem... I added an Aeotec Dual Nano Switch ZW132 and it didn't recognise the device. I selected it from the list and it added the 2 component devices. The problem is these do nothing - the on/off does not work.
I have excluded it (that works fine from the menu - no need to reset the device) and re-added it. Fails to work as a switch.
I have excluded it again, updated the firmware (using a Z-stick and Aeotec's software) just to make sure it was on the latest firmware... excluded from stick, re-added. It shows up on the C7 but I can't get current state or anything.

The Dual Nano Switch throws the following errors in the log when you press a button (change a light state):

groovy.lang.MissingMethodException: No signature of method: aeotecDualNano.parse() is applicable for argument types: (hubitat.zwave.commands.hailv1.Hail, java.lang.Short) values: [Hail(), 2]
Possible solutions: parse(java.lang.String), wait(), run(), run(), grep(), any() (parse)

(I spotted another user having a similar log event - First Device Fail - Switching from Indigo - #29 by mattias)

I then though "maybe it's me" (kinda like "it's always DNS...") and thought I'd try another device - the Aeotec Multisensor 6 - ZW100-B... no dice. It includes fine, can exclude again (and updated to v1.13 firmware) and re-included... but no temp/humidity/lux was showing... until over 45mins later when it finally updated! (USB-powered so should have updated more regularly!)

All devices are nearby (the switches within 3m of the C7, the multisensor about 1m away in the same room).

I have a Zniffer and sat there with my laptop, watching the traffic pass between the nodes... nothing I can see that is an issue... devices hail when something changes, etc. At this range all at 100kbps by the looks of things.

As a Hubitat newbie... any ideas what I can do to make the C7 work with the Dual Nano Switch?
Thanks :slight_smile:

For reference, my Z-Wave devices & details, as the details often matter!

Aeotec Nano Dimmer (ZW111 - AU version)
For reference:

  • deviceType: 515
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x86,0x72,0x5A,0x73,0x98,0x85,0x59,0x25,0x26,0x27,0x32,0x70,0x81,0x71,0x2C,0x2B,0x7A
  • zwNodeInfo: D3 9C 80 04 11 01 5E 86 72 5A 73 98 85 5C 59 25 26 27 32 70 81 71 2C 2B 7A EF 82 68 23 F1 00 85 5C 59 25 26 27 32 70 73 81 71 2C 2B 7A 5A
  • outClusters: 0x82
  • secureInClusters: 0x85,0x59,0x25,0x26,0x27,0x32,0x70,0x73,0x81,0x71,0x2C,0x2B,0x7A,0x5A
  • deviceId: 111
  • S2: 128
  • manufacturer: 134

Fibaro FGS-212 (AU version)

  • deviceType: 1026
  • inClusters: 0x72,0x86,0x70,0x85,0x8E,0x60,0x25,0x27,0x7A,0x73
  • zwNodeInfo: 9C 00 04 10 01 72 86 70 85 5C 8E 60 25 27 7A 73 EF 25 60 68 23
  • outClusters: 0x25,0x60
  • deviceId: 12290
  • manufacturer: 271

Aeotec Dual Nano Dimmer ZW132 (AU version)

  • deviceType: 515
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x25,0x27,0x32,0x81,0x71,0x60,0x8E,0x2C,0x2B,0x70,0x86,0x72,0x73,0x85,0x59,0x98,0x7A,0x5A
  • zwNodeInfo: 9C 80 04 10 01 5E 25 27 32 81 71 60 8E 2C 2B 70 86 72 73 85 5C 59 98 7A 5A EF 82 68 23 F1 00 86 72 25 27 32 81 71 60 8E 2C 2B 70 73 85 5C 59 7A
  • outClusters: 0x82
  • secureInClusters: 0x86,0x72,0x25,0x27,0x32,0x81,0x71,0x60,0x8E,0x2C,0x2B,0x70,0x73,0x85,0x59,0x7A
  • deviceId: 132
  • S2: 128
  • manufacturer: 134

Aeotec Multisensor 6 - ZW100-B (AU version)

  • deviceType: 514
  • configured: true
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x98,0x84,0x5A
  • zwNodeInfo: 9C 80 04 21 01 5E 98 84 5A EF 68 23 F1 00 5E 86 72 84 59 85 5C 73 71 80 30 31 70 98 7A
  • secureInClusters: 0x5E,0x86,0x72,0x84,0x59,0x85,0x73,0x71,0x80,0x30,0x31,0x70,0x98,0x7A
  • deviceId: 100
  • S2: 128
  • manufacturer: 134

I'm assuming it's to do with that they are joined securely, @bcopeland can confirm if the driver would work.

Are any of theses devices got S2 security? I actually have them all I think but I would need to look at the manuals. As I understand it if they are S2 then you should connect them securely, but if they are S1 then you shouldn't as that would big down your network.

Also did note when you joined you multi sensor was it plugged in or on battery?

The Aeotec devices are all S2 'zwave plus' and I double clicked to join them securely - they flash blue when doing that, rather than green when in S1 mode. (Under my 'for reference' in the original post you can see they all have S2: 128 noted, including the troublesome Dual Nano Switch.)

The multisensors have never had batteries - they were joined on USB power.

I've just attempted the really challenging one... the Aeotec LED Strip ZQ121... great piece of kit but doesn't seem like Hubitat has it on the list of drivers... and 'ZQ121' doesn't appear in any search here either!

I'll probably have to figure out how to modify a RGBW bulb - I'm hoping they're similar.

Edit - the strip responds to basic on/off/level/colour-temp commands using the "Aeotec LED Bulb 6 Multi-White" but, when using the colour picker as a 'colour LED bulb' on a dashboard, it does not change from a shade of white... so I suspect I'm either using the wrong driver (maybe that bulb doesn't do colour) or I'll need to do some editing.

I want to include the rainbow party modes too!

Edit 2 - I should have selected the "Aeotec LED Bulb 6 Multi-Color" driver, as that seems to have all the functions. I am not able to test the special colour modes (like rainbow) at this time as the kids are in bed and that would set them off :crazy_face: but everything else seems to work for now.

[Edit] It seems like Aeotec ZQ121 [does not quite equal] "Aeotec LED Bulb 6 Multi-Color" driver. It functions with most of the commands, like colour temp and colours but doesn't behave quite right. I will have to investigate...
For reference, the ZQ121 product link is: Z-Wave LED strip • Aeotec
[Edit] Also the ZQ121 manual seems to be online LED Strip user guide. : Aeotec Group

I've now also tried your 'clean driver' with the Aeotec Dual Nano Switch (including removal of child components) before re-adding the Dual Nano driver. No luck.

Turning on the lights still generates a 'hail' that the C7 'sees' and flags as the noted error.

The current dual nano driver does not support security, when including it you will need to uncheck all the security grants options in the S2 security dialog.

We will look into updating the driver with S2 support.

1 Like

Oh. That'll mean I have half my mesh on S2 and half not... I have Nano Dimmers with Wallswipes in the bedrooms and a few other rooms and these are supported by Dual Nano Switches to do non-dimmable lights and things like bathroom fans (on/off only). Not sure how good my mesh will be after the migration now :neutral_face:

Also having the Dual Nanos on S0 has seemed to drag the mesh down to 9.6kbps too, from 40-100 which it was at with everything (bar the single Fibaro switch) meshed at S2.

Hopefully the S2 driver will happen pretty quickly, as the Dual Nanos have been around a while and do seem to be deployed in a lot of places. I look forward to updating to the new driver when it is available! (Ping me if you want a tester.)

Is No Encryption not an option, until the S2 drivers get sorted, seeing as you must have been using them that way originally ?
You’d then at least not have the bandwidth penalty that using S0 has.

For now I've added all the Dual Nanos with just S0 (the single join click, flashes green until it is included) and the Nano Dimmers in S2 (double click to include, flashes blue until done rather than green; I did these first, else I'd probably have just gone S0 everywhere).

If there's any way of adding the Dual Nanos that is S2 but without encryption, I'd be happy to hear how and try it. But for now they seem happy enough as old S0 devices. It's just me wanting to get this new mesh as perfect as possible that isn't 100% happy with that.

when joining untick all the boxes.

We must be including them differently... I have not gotten any boxes to check/uncheck with the C7. I only get a 'name' to fill in (that is pre-populated with the device type as the name, if it knows what it is).


Have you checked that your on the latest firmware?

As part of my mesh migration, I've been ensuring all the Aeotec devices are on the latest firmware. (This is one reason it's taking me quite some time to migration... but worth it - firmware is always one of those 'must get around to it' jobs when you have to unscrew a wall plate!)

Best to factory reset them once you have done a firmware update, as your migrating you may aswell. I have had some odd things happen before and a factory reset fixed it. But I ment the firmware of the hub? As the C-7 has some changes for z-wave so you should have a option to select what security level you want per device.

Thanks for the clarifications:

  • As part of the Aeotec firmware update process, I'd manually hold in the button to 'hard reset' the units after I'd done all the updates and excluded them from the (update) controller. Some units more than once, given I was stuffing around trying to get that Dual Nano working.
  • The C7 prompted me for an update to which I've done. If there are any other updates I should be doing, please let me know - I haven't found anywhere else that asks for updates.

This is it, now when you go to Z-wave pairing and the device pairs, do you get a option with tick boxes?

I’ve paired over a dozen Z-Wave devices this weekend, both ‘secure’ and ‘non secure’ modes. Never had any pop ups.

All I get under device discovery, under z-wave inclusion is the box that lets you see the node number and some details and lets you give it a name. No selections, check boxes or anything else. Sorry!

I'm going on what others have said as I haven't gotten round to joining a z-wave device yet so @bcopeland might be able to confirm here?

1 Like

The C-7 can, for the first time, join devices with S2.

The C-3, C-4, and C-5 can all join devices with no security or S0.

S0 is the 'chatty', single Key per hub, Security profile. S2 is not as chatty and offers a Key per device.

For the C-3, C-4, and C-5, the recommendation was to join devices with No Security, unless required for Locks and Garage Door Openers, and there was one choice for Secure Join --> S0

Today the recommendation is much the same with one minor enhancement. Join devices either with no-security OR S2. For Locks and GDO, join using the security it supports, which means historically, probably still S0.

S2 capable devices are new'ish and therefore much of our existing kit will still want to be joined using no-security, because S0 is still not advised due to it's chatty nature. (3x packets)

A single click to join is probably 'no-security' while a double click is probably S0. Most S2 capable devices will offer the Security popup on the C-7. If you remove all the selections, you're joining the device as no-security.

To repeat, for most of our ZWave devices that have been installed in our homes for more than 6-8 months, they probably support only no-security or S0 and you should continue to lean towards no-security. For many, the S2 devices we have are installed already and pulling them just to get the S2 code needed during join is a burden, so join them with no-security, as always :slight_smile:

[[This was my attempt to make it LESS confusing :smiley: but now that I see the number of words, I'm wondering if I need to go back and simplify my simplification :smiley: ]]


Thanks @csteele for your detailed reply - it certainly does make things clearer, at least for me! :+1: :nerd_face:

I can't speak for other devices, since I'm mostly Aeotec Nanos here... but when I had the Nano Dimmer on the latest firmware, hard reset (the status light was doing the rainbow dance) and I double-clicked to include, it flashed its blue inclusion thing, followed by a green to indicate it was successfully included. (It flashes red if it fails, then goes back to rainbow dancing.)

The C7 just popped up a "name it" dialog with some details (I think an identifier) but that's it. Then I get the following details under device data:

  • deviceType: 515
  • zwaveSecurePairingComplete: true
  • inClusters: 0x5E,0x86,0x72,0x5A,0x73,0x98,0x85,0x59,0x25,0x26,0x27,0x32,0x70,0x81,0x71,0x2C,0x2B,0x7A
  • zwNodeInfo: D3 9C 80 04 11 01 5E 86 72 5A 73 98 85 5C 59 25 26 27 32 70 81 71 2C 2B 7A EF 82 68 23 F1 00 85 5C 59 25 26 27 32 70 73 81 71 2C 2B 7A 5A
  • outClusters: 0x82
  • secureInClusters: 0x85,0x59,0x25,0x26,0x27,0x32,0x70,0x73,0x81,0x71,0x2C,0x2B,0x7A,0x5A
  • deviceId: 111
  • S2: 128
  • manufacturer: 134

Now to me, that S2 seems to suggest it has been included in S2 mode... but I'm making an assumption here, based on the obvious... which isn't always a good assumption! However the 6x Nano Dimmers all show this in their inclusion and work just fine. Setting pass to them; they can respond instantly to requests (on/off/level/transitions).

I can include the Dual Nano Switches in the same way. They show similar data (with the S2 field) and are identified either as "Aeotec Dual Nano Switch" or just "Device" depending on how far the discovery process has gone.

However the Dual Nanos will not work when included in S2 mode (the blue flashy light method). If I use the single click include (green flashy lights, the whole way) then they do not show an S2 field at all. Example Dual Nano data field:

  • deviceType: 515
  • inClusters: 0x5E,0x25,0x27,0x32,0x81,0x71,0x60,0x8E,0x2C,0x2B,0x70,0x86,0x72,0x73,0x85,0x59,0x7A,0x5A
  • zwNodeInfo: 9C 00 04 10 01 5E 25 27 32 81 71 60 8E 2C 2B 70 86 72 73 85 5C 59 7A 5A EF 82 68 23
  • outClusters: 0x82
  • deviceId: 132
  • manufacturer: 134

It seems the Aeotec Nano range are 'gen 5' and 'Z-Wave Plus' (again - my assumption this means the 500 series or 'S2' capable devices). I have a fair few of both dimmer and dual switches in my house already and was waiting for my C7 before adding about another dozen... so getting me getting the inclusions correct now is better than redoing it when they're all in the wall again!

Thanks everyone for your help so far. I'm trying to document my issues with enough detail that it helps with troubleshooting but also if others have similar issues... I hope that helps a bit too!

1 Like