NEO ZigBee Siren Alarm Device Driver

For some reason I am unable to get my Neo Zigbee Siren to work with the Tuya driver in HPM (which is the same as what is linked in this thread). Pairing works fine to Hubitat and I change the device to 'Zigbee - Tuya Alarm', and click Configure a few times but nothing really works. I do get some Current States and some State Variables:

But that is it. I have this alarm (which I'm pretty sure others have purchased and are getting to work):

Anybody have any ideas on how to get this thing to work? I have deleted and added to Hubitat a few times...


this is what ive been using

1 Like

Correct, yes, I saw that one and that is the one I mentioned is also in the HPM that I am trying to use but it just isn't working. I hoped there would be some errors in the log but not the case. Even stranger, when I add it to Hubitat, it shows the device being a TS0601, which is definitely in that driver....

Have you pressed configure on the driver page

Yes, quite a few times. I have also pressed the Initialize button a few times. One thing I am noticing is my manufacturer is different than what is in the driver, but I'm unsure if that makes a difference. My device gives a model of TS0601 and a manufacturer of _TZE200_tlbl02bj and the driver shows a model of TS0601 and a manufacturer of _TZE200_d0yu2xgi. I tried messing with that within the driver but didn't make a difference for me so not sure if that is a red herring...

Did you have any success? I have exactly the same model and the same problems. I have tried the driver in HPM and the others recommended by the Heiman owner. No go...

1 Like

No, I tried for three days; tried simply changing around the names and models in the driver, even reached out to the creator of the driver/package and they said he was no longer maintaining the package of drivers because of some issue with Hubitat. Probably clusters changed or something but that goes over my head a bit. So...tossed it in a cabinet, uttered the words "maybe one day....", went out to Amazon and bought another Aeotec siren for much more $$ but at least I knew for a fact they work with Hubitat...

I want to stay with Zigbee only so I decided to toss it in a drawer and use a 120v siren with a Zigbee outlet and simple rules for the intrusion devices. A much more simple solution, although not as elegant. Thanks


I hear ya, my preference is Zigbee, as well. I only have a few Z-Wave devices but I can say in my home I don't see much difference between Zigbee and Z-Wave but I still prefer Zigbee for some! Oddly enough, the Aeotec is what I should have gone with from the start in my application. I had the doorbell kit (button and siren) for years and have the siren downstairs for the doorbell and I was able to configure/pair the new siren to the button as well and put that upstairs. We don't get a lot of visitors but sometimes it happens that somebody rings the doorbell while we are sleeping in and we never know. But, also, I spent some time with it to get it just right so both sirens will act as alarms for the new security application I am building with very little trouble so, for me, I probably should have just started with the Aeotec. However, if the NEO ever makes it into Hubitat, I will still have a purpose for it :slight_smile:

Neo produces also a z-wave siren, I have it working in HE using the built-in 'Dome Siren' driver

Does your zigbee siren work?
Is it a repeater (when plugged in via usb)?
Does it have those 18 different sounds?

Hi All,

So I have a NEO Zigbee Siren Alarm (just arrived today) and I'm using the above mentioned driver which shows up as a "Zigbee - Tuya Alarm", when I discover the device it all works perfectly (I can manually select the volume, and the 18 sounds - perfect).

What I'm struggling with is using it in a Rules Engine context. When I select Action to run it needs to know the action type to add - the only one I can choose it would seem is "Control Music Player, Volume, Sounds" and then when I select which action the only one that then subsequently presents my sire is the "Control siren" option - the others such as "Set Volume" don't then go on to give me the option of using my siren??

What am I doing wrong here? I'm a relative newbee so please be gentle.

Thanks in advance.


1 Like

I guess what I'm asking is how do I programmatically set the siren volume and number?

A sample rule screenshot would be hugely appreciated.


You may need to look under Custom Actions

Tried that - tried Music Device, Sound, Tone, none of them then present me my device??

So - I've just gone through EVERY available device and I found it, it's showing up under Humidity Device (!!). I can run all the relevant custom actions fine. Thanks


Volume is a config/setting/preference it isn't designed to be changed frequently , dont know if you can change a preference and issue a config commed via RM

HE custom driver for these Tuya models (without temperature and humidity sensors) is now available: [RELEASE] Tuya Smart Siren Zigbee driver

1 Like

Thank you so much! I just loaded this up and it works perfectly!