Need some Wyze words of advice


#61

Probably not going to do one. Just because it requires installing TinyCam Pro and setting up all the cameras in there (which are all different). Then you have to install Tasker and I'm not even going to get into how annoying that program can be. If you have both of them already it's actually really easy to do. Just gotta go into tasker and look for it.


#62

#63

Come on, help your dumb fellow


#64

I'm obviously missing something critical here. The way I understood @Ryan780's setup was, we could send a httpget request with the message in the params to the local IP of the android device (with autoremote installed). Then through Tasker I could act on the message received. If I know the android devices local ip, how do I format this GET request?


#65

I just looked again and I was using the local for something else. This is using the standard cloud link in AutoRemote. You can only use autoremote locally from another android device. I was using that to do it from a function on my phone, since tinycam is the the "home android server" (old phone that won't hold a charge anymore).

Also, in TinyCam you have to enable tasker support in the developer settings.


#66

Looking at what I was playing with I think the format is more or less this

http://192.168.0.101:1817/?message=hello


#67

Where do you find what port to use because I just tried that and it doesn't work for a message that does work with a cloud link. (I substituted my own ip, obviously)


#68
* on the device you want to receive messages via local wifi add a new tasker profile with the "Wifi Connected" condition and choose your wifi network
* in the task add an "AutoRemote Wifi" action to start the AutoRemote Wifi service that allows you to receive messages through your local network
* in the same task add an "AutoRemote Devices" action and set it up to send your information to the other device. This will make AutoRemote send your most up to date IP address to the other device, so it knows where to send messages to

Perhaps the last step wont work so well. I believe the port for these autoremote messages is always 1817.


#69

So, you can't just enable it, you have to enable it with another tasker profile? See, this is why i avoid tasker like the plague.

That worked. I remember doing this before on my phone and finding it was just using too much juice.


#70

LOL yeah I refused to do anything with tasker for years for this reason. It seemed like the simplest things got so convoluted. I guess that is the problem with being able to do so much. You have to know how to tell it to do what your after.


#71

Switching to the LAN url doesn't actually make it appear any faster. Most of the delay is in Tinycam + GHH rendering the video.

Another cool thing with TinyCam Pro...there's now a version that supports android auto so you can check your cam from your car's in-dash infotainment system. :slight_smile:


#72

Oh android... How I envy thee.
Sounds horribly distracting, but the fact that you can.


#73

Well, i wouldn't want to do it while driving, that's for sure. But it would be nice to check on the kids or if your alarm goes off rather than pulling your phone out.

You do have to sideload that version. The developer wasn't sure that Google would like something like that up in the play store. hehe


#74

I need this now...I don't know why, I just do. Installed and waiting to test on my drive home.

If this is the last time you see me post, it was because I was looking at video of my empty sofa while driving. Please tell my family that it was death by @Ryan780.


#75

I would say death by TinyCam....I was just a facilitator. :smiley: :smiling_imp:


#76

Accomplice. You'd better be sure Stephan always makes it home from now on. :wink:


#77

You don't need to use a tasker profile. That's just so that it enables and disables itself automatically when you enter/leave a wifi connection. I plan to use this on my wall tablet that's always plugged in and on my wifi. I simply created 2 tasks. One that enables the wifi server and the other that disables it. If I get this working the way I want, I'll probably just have the server start on boot.


#78

No, I think you need a tasker profile to enable the local wifi. I tried it without and it wouldn't accept the local link, only the cloud one.


#79

Worked for me.


#80

Exactly...in Tasker. That's exactly my point. Why do you have to set it up in tasker to enable something rather than via a system setting like every other app in the known universe except for tasker.