My Z-wave is very sick. I can't nurse it back to health

your asking it to refresh 2 times in less than a second then a further 2 times 1 second apart. Your asking it to do that every time the trigger events happen. I would just get rid of the repeat and add a elapse time of a few seconds above the 1st refresh.

1 Like

Yea, I toned it down to just a single poll -- no repeat. But don't understand how it got "stuck" repeating constantly. But, as of now 8ish hours -- with this change -- we're still "happy" in Z-wave land....

New simple rule -- based on a new "vibration/accelleration" sensor I put on the incoming well 1" pipe. Works great to detect the inrush of water from the well.

Can you re-post your Z-Wave details page? You had several potential ghost devices in the original and not all of them looked to be plugs.

1 Like

Will do this PM. Checked it briefly again this morning, and it's looking so much better. But, not perfect.

1 Like

Here's the latest Z-wave details. Last full shutdown, pull power, reboot - was about 24 hours ago.

(This cut/paste is from the earlier-in-this-thread-recommended ShareX "scrolling capture' tool -- it looks darned small to me - not sure how to make it pretty)

Same info, using an Excel parser I wrote.

If you click it, then click on the pop-up, it gets to the right size.

That looks way better than before. I'd honestly leave it where it's at and give it a day or two to settle.

1 Like

Yup. I plan to stay hands-off for now and see how it goes. My live Z-wave logs look pretty sane now as well -- a nice slow scroll, not constant flooding....

I'm assuming some values, like "route" are the latest route.

As an aside -- not clear on Neighbors, RTT, RSSI, etc -- are they representing the "most recent" value (and would go up/down?) -- or instead, are they the "max/worse".

RTT am pretty sure is the "max seen" based on empirical observations.

PER, I get, by definition is an incrementing value. So is route-changes.

0x16 is definitely a ghost..... It's also got a large amount of hops. Seems a very far edge device

I'm going to differ by just a little bit.. your device #16 looks like a half joined device and that you had to try 5 more times to get it to join as "WATER - Well..."

Both rows show the same type of device, that Discover button means the join cycle took too long and it only partially completed. Ideally, you'd see that, click discover then wake the ZWave device to allow the exchange to finish... but I'm guessing you gave up and tried a few more times. :slight_smile:

I'd treat it like a Ghost and get rid of it. Click Repair and confirm it can't find the device, then slowly click Refresh til the Remove button appears. Click Remove and then come back to this page in 15 mins... allowing the internal processes of the hub/radio to settle.


Followed those steps slowly.

Repair. Then Refresh (only took once). Click Remove. WAIT WAIT WAIT WAIT. Reload web browser page. No joy. #16 still there.

Did it again, this time waited 35 minutes, reloaded web page, no joy. Still there.

The remove may fail because the real device can still be reached by the radio. Remove power from the device and then run Remove.


Or it may just fail anyway, just because ??? nobody knows why, thanks Si Labs.


I'll try that when I get home this PM. (Pull power to the Well Pump device, remove ghost, power back up Well Pump device)

I have two of these 40-amp direct-wire 220v Z-wave switches. One is the "WATER - Well Pump Power Control" -- the other is " SYSTEM - Laundry - Dryer Plug"

  • The Dryer Plug is paired with S2 Authentication
  • The Well Pump is paired with "None"

Should I attempt to get the Well Pump re-paired with S2? Honestly don't understand S2 vs "none" -- I thought that was a "door lock" thing.

I know I had a bear of a time getting it paired the first time -- which is why I think we have #16 as a Ghost-ish device -- part of that original failed pairing process

Shouldn't matter either way.

Ok, turned off the "WATER - Well Pump" device. Left it down for 30 minutes. Tried the "refresh / remove / wait / reload browser" process. Twice.

No Joy. #16 is still there.

1 Like

Bummer. You'll have to use PC Controller to get rid of that sucker.

1 Like

Yup, figured. I'll work on that next. But, for now, the larger issue of a "sick Z-wave" is likely resolved.

FOR THOSE WHO FIND THIS THREAD LATER: Root-cause, self-inflicted-wound by having a rule get "stuck" causing fast polling of a 40-amp switch to get power readings.


It would still improve things further if you had a way to poll only the power value instead of refreshing everything. If you are interested let me know.

Crazy idea if you don't mind some creative wiring.

You might be able to put a 220v relay wired to the well pump motor in parallel so that the relay "closes" when there's power to the well pump motor. Then, use something like one of the Zooz gizmos that will detect when the relay is closed (and, thus, the pump is running).