Mode Manager - Didn't change modes

This is probably related to my system time issue. However I have a mode set to enable at midnight. I watched and waited and it didn’t change to that mode.

There is no time displayed in settings.

Yes the time in the logs is correct.

dev:122018-02-04 00:50:32.618:debugParsed MultiChannelCmdEncap(bitAddress:false, command:3, commandClass:37, destinationEndPoint:1, parameter:[0], res01:false, sourceEndPoint:1) to [[‘name’:switch1, ‘value’:‘off’]]

dev:122018-02-04 00:50:32.611:debugParsing 'zw device: 08, command: 600D, payload: 01 01 25 03 00 ’

dev:122018-02-04 00:50:32.544:debugExecuting ‘off1’

Any progress on the time issue? I installed my new hub last night, set up modes, set up some “sunrise” events, and noticed this morning that the mode had not change from night…

I also experienced this. I’ve switched to Rule Machine instead to see if it happens there as well.

So I have experienced that mode is not changing correctly based on times I setup in Mode Manger.

I have Day start at 4am
Evening start at 7pm
Night start at 10pm

Evening and Night changed just fine, but at 410am still no change over to Day mode?

mode Home is now in Night mode Night LOCATION_MODE_CHANGE 03/14/2018 10:00 PM
mode Home is now in Evening mode Evening LOCATION_MODE_CHANGE 03/14/2018 7:00 PM

My modes are changing 8 hours behind. I uninstalled Mode Manager and setup my modes change in Rule machine.

The mode should’ve changed to morning over an hour ago, but it has not.

There has been a problem with some new hubs having the wrong internal time. Check your timezone setting on the Location page, and reboot your hub. That should clear up the issue.

It’s set for Arizona time and it did change day at 6am, just not 4am that I had set. Performed the update tonuught and rebooted will monitor. Thanks

Seriously, Bruce. This is pretty basic stuff.

Time is time. What is going on with time that Hubitat can’t get it right?

I dropped that basic Mode Manager and went for RM. It’s STILL not working properly.

BTW, my modes are now 4 hrs behind, instead of 8, since switching to RM to manage my modes.

And please note that we are over a month past the OP. So much for moving faster than the behemoth Samsung.

1 Like

I’m fully updated.

Have you tried setting to a timezone only one off from yours? Seems strange this isn’t happening (or being reported) by a bunch of people if it was a more serious bug. My time’s have been spot on in MST.

Mine was off on day one, but a reboot fixed it.

There was a bug that caused boxes to be off when brand new immediately after they started and set the timezone. That bug has been fixed in 704. In any event, the first reboot remedied the issue. There aren't reports of time problems for anyone who has rebooted.

@MEarly, Yes, time is pretty basic stuff. But, we had a bug, which is also a fairly basic thing. We endeavor to be bug free, but no doubt there are more bugs lurking in places.


I would also suggest opening the App info (the little i next to the App in the list page) and checking the times that are scheduled there. If they are off, open the App and click done to update the schedules. Then check again to see if they are fixed. If you are still seeing an issue with the scheduled time, please open a ticket with support if you have not already and we can investigate further.

The "atTime" is correct @2300 for Asleep mode. The "timeHandler" is incorrect: 0 0 3 * * ?.

Opening the rule and saving it fixed this.

Thanks for all the help.

@bravenel, sorry I was a bit testy having to deal with ST issues too. One of those "one more thing..." days.

1 Like

I just encountered the same issue. Installed the Mode Manager last night and had my Hubitat set to night mode. This morning about an hour after sunrise (when MM was supposed to change the mode to Day) I found that the mode was still Night. I didn't have debug logging turned on for MM, so there was nothing in the log about it. I'll keep an eye on it through tomorrow...

Are you on the latest release? 2.0.4?

I had a different issue with mode manager switching to Day mode too early. Only change I made was updating to 2.0.4 yesterday. You can actually see it setting the mode to Day twice, once earlier and once at the correct time.