Mode changing when away

I either don't fully understand how modes work, or I have something set up wrong.
I'm finding that the mode changes from "away" to "day" which is based on sunrise... and from "away" to "night" which is based on a virtual switch which I trigger either from an Alexa routine, when I am at home, or from a dashboard button when I am away from home. I don't want to change from "away" mode when both I, and my wife are not home regardless of time or virtual switches.
what do I have set up wrong?

I guess one of my first steps would be to ensure that your phones are being accurate in regards to presence. Go to your Device tab, and select these phone device's settings page. Look at "Events" at the top left of that page. You will probably see false present or not present events there, see below.

Presence on lots of devices doesn't work properly. At least not by itself. Many phones shut off the Wifi and GPS when they sleep, and that makes Hubitat (or any system really) think you have left, when in reality you have not.

Many get around this by combining presence methods, like Wifi AND GPS, or Wifi AND a presence fob, to get a more accurate picture of what is going on.

Here is one of my posts from earlier today that has a couple helpful links regarding presence.

I was having issues with Presence sensing on my wife's iphone which I seem to have corrected. In the past, she would have to open the app to force her status. I made sure things were set up correctly as far as background app refresh and such on her phone. They all seemed correct, but since I messed with those settings, it seems that the presence is correct and I have yet to have any further problems with the app indicating such. I know this because I have a tile indicating each of our "present" statuses on my dashboard. When the mode is switching from "away" to "day" or "night" mode unexpectedly, the status of our devices are indeed in "Not Present" mode which is why I'm expecting an issue in my Mode App settings, not my Presence.

also you can use modes anyway you want, but that is not the normal way, especially if you are going to use shm (security home)

normally home is for when you are home, ie daytime and everything is disarmed
, night is for when you are still are home, but late at night when you want to secure the house but usually skip motion sensors etc in case of alarms if you walk around etc.

away is usually everything armed for when you are out of the house...

however the rule does look ok

The only thing I can think of, based on the phrasing in the screenshot is that each of those settings are independent triggers that can cause a change in mode, but they are not conditions that all have to be met, e.g. presence wouldn't be considered in the time of day triggers, and the same for the switches. I don't use the app, so can't say that with any confidence...

That would probably explain the mode changing to Night when you are all out of the house, but I would have expected the Away -> Day based on Sunrise would not occur with the setting you have to not apply time of day when mode is Away... That one I can't explain.

In terms of trying to solve it, apart from this post, you may want to track down the Hubitat Live recording where Bruce demonstrated this to see if there is anything he mentions that may help.

1 Like

Okay, maybe I'm using Modes where I should be using another method.

I'm mainly using Modes for my Thermostat settings. I've been doing all of my light automation with time of day and motion. I have a couple of other rules set to only happen in "Away" mode... for example, I have sensors on the doggy door, if the dog triggers it while we are away it sends us each a phone message letting us know that the dog went outside, otherwise we just get an Alexa announcement in our home alerting us. I don't use the Modes for any kind of traditional security set up.

Ultimately, what I want to happen is that when we are away from the house, I want Hubitat to sense that and set the Thermostat to lower the temperature significantly to avoid unneeded use, which it does when we initially leave the house. But, when the time change hits for a time sensitive mode change, it changes from "Away" mode to something else which I'd like to avoid.

Are you speaking of the instructional video on setting up "Modes"?

Edit: Never mind, I see that you said "live". I'll look for that video.

1 Like

Could have even been late last year...

Thinking about it some more... I still think the main thing that you need to work out is how the option in the time of day triggers for ignoring away mode is meant to work. I think the setup of the app seems fine, HSM considerations aside. Hopefully there will be something in the live stream or someone else may be able to guide you through it.

I think that I found the live stream. It's from Oct. 15 2019. I'm watching it now. So, I'll see if there is anything in that video to help me out. Thanks for the direction!

1 Like

One often given piece of advice is that if Mode Manager is working funky, it is often easier to remove the whole app and start again. I am not sure if that would be my first step, but you will probably see that if you search for "Mode Manager problem/issue" on this board.

I do think you are using modes basically the right way, that thermostat is a perfect use case for modes. When home do "X", when away do "Y".

2 Likes

That’s true, except mode manager has an option to ignore time-based mode changes while in certain modes, typically away mode, and it appears as though @BrandonT has that option enabled. So I’m also uncertain why this is happening, but agree with @neonturbo that perhaps removing and reinstalling the instance of mode manager is worth a shot to see if that corrects whatever went wrong.

3 Likes

After watching the video that @sburke781 recommended, one difference I had from Bruce's settings was that I didn't have "use time settings for Return from Away" checked. Everything else was set the same except for my virtual "sleepy time" switch... which bruce did with a pico remote "button", basically the same idea. I'm not sure if toggling this switch will change from "Away" mode or not. I've been playing around with setting the device settings for presence and everything seems to be working as expected so far... I guess I'll wait to see if changing occurs when we are both "away" again which is hard to test unless I catch it right at sunset or sunrise.

1 Like

Turn the phones off for a couple minutes to see if it triggers away?

The night mode doesn't work the way that I want it to through the virtual switch... That's not my biggest concern right now, I can just change how I use and set up that virtual switch. The Phone presence seems to be working fine. Now, I just need to test if it comes out of Away mode at sunrise or sunset when we are both away.

Early morning stroll.... :grin:

1 Like

Waking up before sunrise is unlikely at best. I'll check it out tomorrow evening. Then again... maybe I'll stay up until sunrise... that is not uncommon.

1 Like

Okay, well... the mode is still changing to day mode when we are both away. So something is broken. I guess the next step is to remove and reinstall the mode app?

Without seeing everything that you have set up to change mode it’s a little hard to answer, but the investigation would need to look at Mode Manager, any apps that you have installed that may change mode, and any rules that you have set up to change mode. I’ve seen a lot of people try to use presence to turn off Away mode, so that would be the first thing I’d look at - compare your presence events to the mode changes.

1 Like

Well, I have uninstalled and reinstalled the Mode Manager app and I'm still having this issue. When I leave, Mode Manager changes it's mode to "Away" but when the time changes for "Evening" or "Day" Mode, Mode Manager ignores the fact that we are away and changes the Mode. In the settings, I have "Away" as a mode to "ignore time changes".
The only thing I'm using mode manager for is the Thermostats. I'm pretty frustrated at this point. It's either user error or a bug.