Mobile app has wrong IP address

I can access the hub on my computer at the correct IP address, but suddenly the IP address on my phone app is not correct. I logged out and back in. I tried to get it to discover the hub but it never did. I can't find a place to input the correct IP address in the phone app. Hub diagnostics will not run either. The new address is which is completely unknown to me. Every time I logout and back in, it creates another phone device in my device list. Any suggestions are appreciated.

The same thing has happened to a bunch of us – especially during initial setup – though I don't know the exact cause. I'm not even sure what made mine grab the correct network IP, but I recall restarting the dang controller a few times in panic.

Unable to connect to New Hub with IP Address
How to Discover Hub using UPnP
Hub Disappeared

Thanks for those links, I read those and some others. Even though my hub is correct at, I did a power cycle on it just to make sure, and after that the phone app was able to find the hub. I was expecting to find a place in the app to just input the correct IP address but no luck. So, yes that solved the problem although I'm not sure what caused it in the first place. Thanks again.

1 Like

You get that address range when the hub tries to get an IP address from DHCP, but the DHCP server is either down, or still booting up if it was rebooted. Rebooting the hub when the DHCP server is back up will get the address back within the correct subnet for your network.

1 Like

I had the same issue and rebooting the hub worked for me.

1 Like

Rebooting has not worked for me. App says hub found at IP Bogus address. Actual address is static at Have force stopped app, clear apps cache, and power cycled the hub.

C7 hub.

My Hubitat just began showing this instead of the static IP I had it reserved to and I even updated the IP on the Hubitat to my local that was default. Rebooted Hubitat. I can access the hub via browser but the Hubitat mobile app is the issue with the wrong IP. Also Google home integration broke with the mobile app not displaying correct IP.

Also noticed this notification began sending to my phone. I've never seen it before the last few weeks I've had this.

Update I kept rebooting it and my network equipment and it finally updated the IP address with Hubitat mobile app.

1 Like