Unable to connect to New Hub with IP Address 169.254.10.234

Have tried porting the new Hub IP Address with 8081 but no luck. This is what I keep getting :point_down: :point_down:

Question has been put up to Support who had asked some questions but after that no further response. My responses were as follows :point_down:

LED color that hub is currently displaying. : GREEN

  • Device type that is being used (E.G. mobile phone, tablet, computer). : COMPUTER
  • Operating system. : WINDOWS 10
  • Internet browser. : GOOGLE CHROME
  • Email address used to log into portal.hubitat.com (if different than the one used for this ticket). : SAME AS THIS ONE (
  • MAC address (there is a sticker on the hub). : 34E1D180F06E
  • Local assigned hub IP address (assigned by your router or DHCP server). 192.168.1.10

If any one has faced exact similar problem, was it solved? And how?

Same exact thing happened to me right out of the box. Can't say I "solved" it myself. Came to complain in the forum and was warned, "Don't pull the USB end of the power cable because it's fragile" (I did it anyway, not having any other handy way to power cycle the hub).

Eventually, my C-7 stopped booting up with that private IP and played dice with my router. I truly don't know what, if anything, I did to make that happen. That was a nerve-racking 30 minutes of my life. Hope yours gets squared away, too!

RELATED READING

Any reason you couldn't just unplug the power supply from the wall outlet?

1 Like

The plug end, in my case, was behind a bunch of other electronics that I had laboriously shoved back in place, blocked by a thicket of wires, LOL.

1 Like

Wild guess. The ip segment (192.168.1) is different from the other hub (192.168.10). On which segment is your Windows device? If not on the same segment as the new hub, try changing that. If that works, there are some sort of firewall/protections between. If this works, check your router's configuration.

Temporarily, try hard-wiring the hub to your router (vice using wifi)

" 169.254. x.x: This is what's called an Automatic Private IP address . An IP in this range means that the computer cannot see the network. A computer using DHCP needs to have an external server tell it what IP address to use. "

Your hub does not "see" the network.

169.254.10.234 is one of the IP address you get when DHCP fails.

4 Likes

The IP 192.168.1.1 is the normal router IP and router allots different IP to different devices. One of these is 192.168.1.10 which has been alloted to the existing Hubitat hub which is working fine.

Now I am trying to add a second HUB to my router - that is what is not successful. Have already tried various suggested ways. I also suspect something to do with the Windows or the AntiVirus firewall which I need advice on how to disable or 'allow' this new router address. Here is my router network map :point_down:

Same here...

Why does my router see one Hub ( the original which I purchased and installed without issues ) and not the second one which I am trying to add...

One very simple example would be: a defective network wire.
Another simple example is: a defective port on your switch/router.
A third would be a defective port on the hub.

4 Likes

Is there any solution to this? My previous Hub is working fine in exactly the same router..

I would try:

  1. Reboot your router (wait for it to completely come back up), and then reboot the Hubitat Hub (yes, you'll need to unplug the power supply from the wall to do so, wait 5-10 seconds, and then plug it back in)
  2. Replace the Ethernet cable, and then reboot the Hubitat Hub
  3. Try a different network port on the router, and then reboot the Hubitat Hub

If you plugged the power into the Hubitat hub, before the Ethernet cable was attached, you could easily end up with the auto-assigned 169.x.x.x IP address. This is caused by the HE hub timing out while waiting for a DHCP assigned address, before the Ethernet cable was attached. Often, if this occurs, the HE hub must be rebooted for it to try DHCP again.

3 Likes

Try a different ethernet cord as a start.

1 Like

Yes had seen that also...so had changed the network wire....changed and tried different ports.....Incidentally I have purchased two new Hubs and both are having the same problem....The new Hub is detected by the existing Hub interface but once detected am not able to connect to that because of the strange IP address as someone suggested it is because of the DHCP failure... I do not know much about that or how to rectify the DHCP..

Thanks for this...
Will again go step by step and revert with results..

1 Like

Just started looking at your responses on the ticket. What happens if you access the hub at the following address?

http://192.168.1.27/

2 Likes

So I did solve the problem just now and I did arrive at the above IP address but before I had seen your message ( So you already knew it would connect at 192.168.1.27 ? And if so, how? ).

Anyway, this is how I proceeded :point_down:

  1. Initially I had already tried all kinds of possibilities - changing router wires, unplugging / plugging back , interchanging router outlets etc etc. but each time the detected second Hub was always showing 169.254.10.234 which could not be connected to.
  2. So I disconnected the existing working hub completely and connected the new Hub to that ethernet port ( as a fresh new installation without previous Hub connected) It was only then that my router allotted 192.168.1.27 as I saw in my list of connected devices and then I connected the new Hub using this allotted IP address. And it worked.
  3. However, in the process I also discovered that the last port of my router appears to be defective. Because when I connected back my old existed Hub, it would not work / connect either.
  4. So I removed one of my existing devices ( a network hard drive ) and connected the existing hub into that port. So now both hubs are connecting and I should soon be able to add devices into the second Hub.

    :slightly_smiling_face:
4 Likes

Consider getting a small unmanaged switch like this one:

3 Likes

It was the IP address that your hub connected to the cloud (see my email for more details).

2 Likes

Oh I see!
Just checked your email...
Yes indeed!
All OK now and I already added my first device. I intend using the second Hub separately to create a watering system for my plants...
Thanks a lot for your help and assistance! :slightly_smiling_face:

1 Like

Download the Hubitat app