Missing fundamentals about Ring Keypad G2 input

nothing shows up at all. i turned off the debug button, saved. turned on debug, saved. went to logs, and pressed the checkmark. nothing shows up.

and when i use the device details page in hubitat to do things, like pressing arm/disarm/etc, the keypad does the appropriate things and the hubitat logs show plenty:

Can you post a screenshot from the Device Details in the table near the bottom of the device page for your keypad, as well as from the zwave settings page, a screenshot of the row for your keypad?

Most of that looks good/same as mine - the RSSI is lower than ideal, but it seems to get by fine.

Only thing I note (not sure if this is the issue) is that my details include secureInClusters - missing from yours.

Have you tried excluding and re-including the keypad? The lack of debug logs definitely indicate that it either isn't sending (or the hub isn't receiving) the majority of the zwave events we would expect... Almost like the communication is mostly 1-way


I just took a quick look through this thread and didn't see this asked/answered...

Did you use SmartStart in the HE app to pair the device? That's the only way mine would pair correctly.

1 Like

no. i guess i'll give it a try.

I didn't-- actually not sure what SmartStart is. I just paired it normally- Devices -> Add Device -> Z-Wave (under add manually) -> Start Z-Wave Inclusion. Hubitat picked up right away when I held down the 1 button on the keypad for 3 seconds -- i entered the 5 digit code and it was all set.

I just searched the forums for SmartStart and found this video -- neat! i'll exclude the keypad and give it a try.

1 Like

SmartStart is weird.

I excluded the keypad. Then i factory reset the keypad just because.

I scanned the QR code and I see the entry with the DSK. But under the DSK it shows "not included, pending". It's sat here for 10 minutes. The ring keypad has the green blinking light in the upper left. Do i just keep waiting?

Nope, now go into HE and do the normal add zwave device (but don't touch the device)

It'll find it right away. Finish adding it and then go back into Smartstart and delete it from the list.

Woah! i now have two way comms, when i press buttons on the keypad, i see it in the debug logs. yay!

I'm not sure if it had to do with smartstart or if it just needed to be re-paired.

thanks all!

1 Like

I couldn't choose two solutions, but either exclude+pair or else smartstart pair fixed it.



Smartstart seems to be the key to any zwave device that you need to use Security (keypads, locks, etc.)

LOL - FWIW I paired mine without SmartStart - but maybe I just got lucky


of note, after re-pair (with smartstart), mine shows it too:

  • secureInClusters: 0x59,0x85,0x80,0x70,0x5A,0x6F,0x7A,0x87,0x72,0x8E,0x71,0x73,0x86

Yep, I have had awful luck with SmartStart and added dozens of Ring devices normally. Sometimes they need an excluse/re-include but in general not too bad (except the damn contact sensors which are brutal to add).

I have done all these methods to troubleshoot and still have the same one way communication. I’m completely lost here. And additional ideas?
Smart start for some reason randomly adds duplicate items (I have excluded and reincluded over a dozen times using every possible method. Always end up with one way communication)
I’ve powered down the hub after excluding the keypad. factory reset the keypad retired the smart start and nothing. I even went as far as putting the keypad in foil, then inside a metal box, then driving it 10 miles away and remotely restarting hubitat then repairing the zwave and assuring there was no ghost device. I then factory reset the keypad before bringing in any closer than 10 miles and still, after rejoining using the smart start, 1 way communication only!. What the heck? I’m loosing a lot of hair over this one.

I have all the same symptoms @jkister had. Except, his solution clearly doesn’t work for me.

I was having the same issue as jkister. I had originally started in smart start. So, I tried this again, and now I can't even get it to add at all. I literally just reset my entire zwave network. I only had three devices so not a huge deal. But now for some reason I can't get it reconnected.

i bought a hubitat
i bout a ring keypad g2 and hub
i installed the community app
i could not get the kepad to talk back to hub.
Do i need to put in rules?
i uninstalled the community app.
I installed the unofficial ring virtual app.
I could not get the keypad to talk to the ring hub.
do i need to apply a rules machine?
Both applications allowed the hub to talk to the keypad .
Both applications would not allow the keypad to tale to hubitat or ring Hub.
I will keep trying but if someone can get me to the basic's i will work at it until i understand and win!!!

I had the same problem with the G2 Keypad. Hub did not get any key presses. Tried many times the steps outlined in this thread. I was able to GET IT TO WORK finally! Only thing I had to do was to keep the KEYPAD RIGHT NEXT TO THE HUB. Used Smart start to add (I don't know if that it is even necessary, classic inclusion might work as well). Did not even disable the proximity sensor. After that it worked flawlessly. However when I move the keypad away from the hub where it failed to work (hub is downstairs, keypad upstairs, 30ft apart may be) it failed again. Never got to work as before even if I bring it closer to the hub. i.e no key presses goes to the hub. I had to reset it and add again. I even added a second keypad. Both works perfectly. But the two keypads does not sync with each other. i.e If I arm from one the other does not change states. I can live with one for now!