Migration help needed - C7 to a C8 Pro - ZigBee issues post migration

Hubitat C-8 Pro
Platform version:

Yesterday I migrated ~70 Zwave and ~70 Zigbee devices from my C7 hub to my new C8 Pro by following the migration guide. During the migration there was approximately an hour and 45 minutes between shutting down the C7 and bringing the C8 Pro online.

After the C8 Pro hub came up, I tested the ZWave devices and all were responsive and operating normally. On the ZigBee side of things I am seeing some strange behavior and I don't know if it's because of the long amount of time where the two hubs were offline, the migration or something else.

What I have observed so far (prior to the upgrade I had not experienced any issues with my ZigBee network):

  • From the Settings > ZigBee page I can see that for most devices I am seeing at least 1 message received in the past 12 hours
  • When I look at individual device pages I can see events being generated and attributes being updated. When I attempt to execute commands via the Hub for those same devices, the commands are not received by the devices.
  • Events are intermittently being received by the Hub from devices (i.e. this morning for about 10 minutes motion events were being received by the Hub and then an hour later the events were no longer showing up on the Hub)

Steps I've taken to resolve the issue so far:

  • Rebooted a couple of times, but have not performed a soft reset, etc.

Before I start making changes on the C8 Pro that would make it impossible to move back to the C7 I wanted to make sure that what I am seeing above is due to me leaving the two hubs off for an extended time vs the migration failing vs something else. Any help or advice would be greatly appreciated.

On the hub can you go to the logging page and then select the option across the top for Scheduled jobs and wait a moment for them to appear. Look at the jobs that are present there. Do you have any scheduled jobs that have a time/date in the past?

Just checked. All jobs are for future date/times.

I think the general view is to give the hub some time to settle in with the new radio's and external antenna's. Some of the wireless connectivity could take a little bit of time to settle in to good paths. That said that advice may be focused primarily to the Zwave side instead of Zigbee.

ZigBee on the C8 and C8 Pro also got a radio upgrade to Zigbee 3.0. That upgrade has been found to be related to some compatibility with older Zigbee devices. Especially if they didn't follow the spec very well, so it may be a good idea to list the devices you are having issues with.

Some users have also found that because of the improved antenna and Zigbee radio that adjusting the Zigbee power settings could help.

You may also want to check your Zigbee band used.

For both settings I have not made any changes:

Channel: 20 (this is the same as the C7)
Power: 8 (I believe this is equivalent to the C7 power level)

Are the compatibility issues related to repeaters or non-repeaters? For powered devices/repeaters I have the following:

  • Third Reality 3RSP019BZ (Zigbee 3.0)
  • Third Reality 3RSP02028BZ (Zigbee 3.0)
  • Samsung SmartThings GP-U999SJVLDAA Smart Outlet (Zigbee 3.0)
  • Inovelli VZM35-SN (Zigbee 3.0)
  • Halo smoke alarms (Zigbee ??)

For my non-repeaters I have a mix of Smarthings, NYCE, Philips, Sinope, Iris (only 3) and Tuya devices. I don't have any Aquara or Ikea devices.

I believe 16 or 20 is equiv. Power to c7 not 8

I thought the Zigbee power level compared to the C7 was 8 as well. It may not hurt to bump it up though and see if that helps.

The only thing I see that my give me a bit of concern is Iris.

The problem is I don't have that many Zigbee devices myself though so I may not be the best person to analyze that.

I recall they bumped the default zigbee power on the C8 down to 8 shortly after release because they found that was the closest to the C7 fixed power level. So yes, 8 is correct to be similar to C7.


That is my memory as well about the C7 Zigbee power.

1 Like

Yes they did but it came out at 16 .. not sure they really did specific power tests to determine that was the case or just guessed. Mine is still at 16.

The problem could also be the zibee 3.0 as mentioned I had to add some 3.0 repeaters to get my system reliable after upgrading.

1 Like

Does anyone know why I would be unable to send commands from the hub post migration?

I am seeing new events being generated for most of the devices now. Additionally for those that have a physical button I am able to press them and see the update immediately, however I am not able to send the same button press (i.e. on/off) from the Hubitat web UI.

You're correct, 16 was the original Zigbee power setting on the C8 hubs when they first shipped, changed to a default setting of 8 after a bit.

First I would try shutting down the hub and unplug for 30 seconds then boot back up.

Also, what devices are having this issue, Z-Wave or Zigbee?


I'm having issues with my Zigbee devices only post migration.

I just shut the hub down, left for about 5 minutes and then booted back up. After the reboot I'm still seeing the same behavior where I'm unable to send a command to a device that is generating events on the hub.

Pick one device thats easy to get at and reset and then pair it back to the hub. See if that fixes it by chance. There is no harm in trying this, it will drop back into the same device entry.

I am unable to pair the device back to the hub. I put the hub in pairing mode, reset the Third Reality 3RSP019BZ plug and it will not pair with the hub. I then tried rebooting the hub and performing the same steps and it still would not pair.

When i reset a device with my c8 it doesnt seem to be able to pair again till i fully delete the device in hubitat as well.

Thats not normal, I have no problem doing this on either of my C8 hubs.

Couple of things you could try.

  • Power down hub and swap antennas (to rule out bad antenna as issue)

  • Reset just the Zigbee radio and then try paring a device back (should connect to same device still). This would rule out defective zigbee radio if it works.

  • Reset the hub, both radios and soft reset and then try the migration again.
    *Could also do a full reset if you do not have any subscriptions.

Might not be.normal but it.is.for.me and worth a try.

I tried to pair two new devices this evening and neither one would pair to the device. One was a Centralite 4200 plug and the other was a SmartThings multipurpose sensor (both were factory reset).

@jtp10181 Thanks for the suggestions. I will go through this list and report back here with what I find.