Migration help needed - C7 to a C8 Pro - ZigBee issues post migration

  1. I swapped the antennas and after hub rebooted, I attempted to pair an existing device and a new device and both would not pair.
  2. I reset the Zigbee radio and after the hub rebooted, I attempted to pair an existing device and a new device. Neither device paired with the hub. I shut the hub down, unplugged it for a couple of minutes and powered it back up. I then tried to pair devices back to the hub and they refused to pair.
  3. I haven't done step 3 yet as I'm not sure it's worth the effort if step 2 is failing

Hoping that @support_team or @bobbyD can help out to see if there is something going on with my new hub.

You should either PM @support_team directly, or create a warranty case here:
Warranty – Hubitat Support

Direct them to this thread were you have already done all the troubleshooting.

One other thing you could try, which might make a difference actually, is to reset the radio and do a soft reset (or just do a full reset) and then set it up as a new hub. Then try pairing a device to a fully clean hub. There is a slight chance your existing apps are causing issues and locking up the radio but it seems unlikely with a Pro.

1 Like

I just did a full reset on the hub (had to execute it twice get the hub back to factory settings). After the full reset I am able to pair Zigbee devices and control them via the Hub.

I guess the next step would be to retry the migration again - correct? Would it be good to coordinate that with someone from the Hubitat side of things to help in troubleshooting any migrated related issues?

Yes I would try the migration again. If something goes wrong support should be able to look at the engineering logs afterwards.


Just migrated and the hub it experiencing the same issue with the ZigBee network.

I also sent a DM to the @support_team for help. Thanks everyone for offering suggestions...I'm hoping that the Hubitat team can help in figuring out what the issue is.

Depending on how many zigbee devices you have, you could reset again to where your radio is working, then migrate WITHOUT the zigbee radio. From there you hopefully can pair Zigbee devices which will drop back into the same spot on the hub. So you would need to pair every device again, so if you do not have that many this may not be a bad workaround.

Unfortunately I have ~70 Zigbee devices. I was hoping to avoid that step if possible...

1 Like

This is my first time DMing support. How long does it typically take to get a response?

Not sure exactly, but may be delayed over the weekend.

Since it is not a hardware issue, even if they do find something that is causing the migration to fail not sure if they will be able to fix anything quickly.

It is odd that even with migration + radio reset it did not work, but it worked on a clean hub. This actually leads me to believe that something else you have running on the hub is bogging it down and making the zigbee fail.

When you migrated, did you disable all your LAN/Wifi integration apps so they could be re-enabled and checked one by one after migration? If you have a bunch of apps failing to make TCP connections because they need to be logged back in or something it could cause enough load for Zigbee to start acting up.

One other thing to check, what if your Wifi Channel? Just had someone yesterday who had Wifi on 8 and Zigbee on 20 which are right on top of each other. Maybe the full reset changed the channel to something else making it work (I don't know what the default is)?

1 Like

I went through and disabled all of my WAN/LAN apps/devices before taking the migration backup. Post migration I have been going through and re-enabling/validating them right after migration. Maybe worth disabling again and/or re-migrating and then leaving those off for a bit?

I double checked my Wifi channels again. APs are using 1, 6 and 11. Zigbee is on channel 20 (power 8).

Some of the local apps/devices I have are:

  • Unifi controller/protect
  • Kasa
  • Govee
  • Rainmachine

The rest are all Cloud/internet based.

As long as the logs are not being flooded with connection errors they should not really be a problem, was just a thought. If you migrate with all the apps enabled and they are all getting connection errors that's where you get performance issues.

Only other thing I can come up with right now is maybe try changing the channel / power to something else and then back again? Or maybe try a higher power. Maybe the settings are mucked up from the migration somehow.

I don't think anyone asked this either, it usually only effect Z-Wave, but are you using the supplied power supply and cord? Some PoE splitters have been found to supply unstable voltages and the hub does not like it.

Changing the power level now to see if that makes a difference. If that doesn't produce results I will try cycling the channel.

I have been using a USB power hub to power the C8. It's the same one that I used with C7 without issue. I can try swapping it out with the original power plug.

I was also trying to the Zigbee Channel Scan from the Settings > Zigbee screen and it is returning all zeros for all channels/columns. Is this normal?

The 8/8Pro is much more sensitive to incoming power stuff, so I bet moving to the original power block & cable will help.

I'd say it can be normal... I haven't used that tool since it was first launched, but my experience then was that it was ~50/50 on seeing something in those results vs seeing nothing. I wouldn't trust it as a primary scanning resource, that's for certain.

I just swapped the power supply to the one that came with the hub (was already using the USB cable) and tried to pair a new Zigbee device after rebooting. Still unable to pair a new device.

Going to test changing channels next.

I changed the channel to 26, left it for ~30 seconds and then changed back to 20. Still unable to pair an existing or new device to the hub.

I might have just fixed my issue. I changed to Zigbee channel 26 and was able to pair the existing device that I was originally testing with along with a new device. Control from the hub is working for both devices.

I am going to wait for the network to re-build itself and hopefully things continue to work.

1 Like

You may want to try 25 instead. Supposedly 26 is power limited so may have decreased range.

Thanks for the heads up on that. Just changed to 25 and still able to control attached devices and receiving messages from those that have switched channels.