Migrating a Z-Wave Network

After trying to re-add the GoControl, I can not longer add z-wave devices to my network. I see some failed devices in the z-wave details but cannot remove them. I have spend hours trying to figure this out. I verified with another controller that I could include and excluded to garage door. My z-wave is a mess now. Any ideas on what to do. I have also tried excluding and reseting on the C-7 and nothing. I cannot remove any of the failed devices in the z-wave details.

I've experienced this as well. As soon an inclusion failure occurs with a mains powered device, you're in trouble. I have only been able to successfully remove failed include devices if they are the last device in the table. Sometimes a reboot helps. Alternatively, the Discover button seems to work pretty well, but this depends upon the device not having been reset or externally excluded. Either way, you want to resolve the failed include before you include any other devices.

My Z-Wave is all screwed up as well. I have DNI's talking away in the Z-Wave logs and those DNI's don't exist in Z-Wave Details as I have deleted the device.

My Z-Wave details is clean - no failed devices - I managed to get rid of them. I've powered off/on the C7. I've done a soft reset.

Z-Wave devices will successfully include, but there is no communication between device and C7 that I can see.

I can't think of what else to do now. Tagging @bobbyD

So here is what I have done so far and what my findings are.

I completely reset the z-wave radio. I did not delete the devices. I started by doing what I did the last time and attach repeaters first with the exception of the garage openers which are 10 feet from the hub.

First I added 2 repeaters by excluding them from the z-wave screen (general exclude) and then included them back in. My first device was a living room wall outlet (GE) and it came back on inclusion as a Kitchen Pantry Lights. Ok something is not right here.

So I allow the inclusion, went to the device and excluded it from there. Screws all my automation but so be it I can move stuff to the other hub anyway. But here is what is interesting, this exclude, pair, and exclude cycle happens several times each time pointing to another z-wave device. I kept the same procedures of exclude, pair, device exclude, exclude, pair, device exclude until the pairing was correct, like Generic Z-Wave Dimmer. Then I verified the device worked.

My first 2 device paired had several cycles like this. And BTW it never pickup a previously deleted device. So it seem like this is a way of cleaning out the database. After the first 2 repeaters I tried the garage openers and those paired. Starting to feel a bit better I worked my way out adding a few more repeaters and then a z-wave build. If I had pairing problems I stopped and went to the z-wave details to see if the device was stuck. I had one or 2 of those instances on powered devices. This time around I was able to remove them from the radio, before the reset I could not.

I am doing my last build right now and I see a failed node. 'Z-Wave Node 3B: Repair failed, the maximum retries have been exceeded', this appears to be a closet light that I recall having issues with early on in my conversion. I also had an issue with a previous closet light as well, literal the previous device I tried, my wifes closet. I replaced that device today as well. I could not remove the node from z-wave details. But I am going to remove the other failed closet node and leave it off the network. I believe the combination of back to back failures for these 2 devices early on caused issues. I don't recall stopping and performing a z-wave repair or not but I believe I would have. So I am one to removing the failed device node, repair the network and then add battery devices.

Found some clues over here for this discussion. C-7 Z-Wave Repair - #35 by csteele

EDIT: And after removing the failed device I can no longer get into my hub. Trying safe mode now. @bobbyD. Tried a z-wave repair and it only ran for that failed device here is the z-wave log:
3B2020-08-06 13:37:24.981 seqNo: 228, routeChanged: false, transmissionTime: 9ms, repeaters: [0f], speed: 9.6 kbs, rssi: [-81 dBm, N/A, N/A, N/A, N/A], Ack channel: 1, Transmit channel: 1

3B2020-08-06 13:37:24.780 seqNo: 227, routeChanged: false, transmissionTime: 10ms, repeaters: [0f], speed: 9.6 kbs, rssi: [-81 dBm, N/A, N/A, N/A, N/A], Ack channel: 1, Transmit channel: 1

3B2020-08-06 13:37:24.578 seqNo: 226, routeChanged: false, transmissionTime: 10ms, repeaters: [0f], speed: 9.6 kbs, rssi: [-81 dBm, N/A, N/A, N/A, N/A], Ack channel: 1, Transmit channel: 1

3B2020-08-06 13:37:24.385 seqNo: 225, routeChanged: true, transmissionTime: 4ms, repeaters: [0f], speed: 9.6 kbs, rssi: [-81 dBm, N/A, N/A, N/A, N/A], Ack channel: 1, Transmit channel: 1

and log:
sys:12020-08-06 01:37:36.632 pm infoFinished Z-Wave Network Repair

sys:12020-08-06 01:37:25.839 pm traceZ-Wave Node 3B: Repair is done.

sys:12020-08-06 01:37:25.548 pm traceZ-Wave Node 3B: Repair is adding return routes

sys:12020-08-06 01:37:25.044 pm traceZ-Wave Node 3B: Repair is deleting routes

sys:12020-08-06 01:37:24.282 pm traceZ-Wave Node 3B: Repair is requesting device routeList

sys:12020-08-06 01:37:21.897 pm traceZ-Wave Node 3B: Repair is updating neighbors

sys:12020-08-06 01:37:21.892 pm traceZ-Wave Node 3B: Repair starting

sys:12020-08-06 01:37:21.784 pm infoStarting Z-Wave Network Repair

And now having these exact problems here

I had to soft reset and restore a backup. I was once again able to get into the hub and move around without it locking up. The problem device was still in the z-wave details without an option to remove. Ran another z-wave repair and the node was changed back to the closet switch. Had no problems control it either. Will leave it for now and keep my fingers crossed.

Was and still am concerned. Hope it stays stable.

I've noticed that my z-wave repairs omit most of the more recent devices I configured onto the C7

I am right back to the point I started. Some where along the way devices are failing on the repair. This is really disappointing and the remove button does nothing. I have 5 devices that need to be removed. Repair is taking hours to run.

With the C3 I never had issues with my z-wave network and nothing changed in the terms of distance or powered devices, those were all one for one on conversion. So I cannot understand how this newer z-wave technology is worst. At this point I wish I had not switched. I know that will probably not be the case later but right I don't where to turn.

I know this post is somewhat old, however I just ordered my C7 (was going to wait but the Hubitat announcement email arrived and I broke down).

Question. I have an Aeon S2 stick which I can use to exclude devices from my C4. In your post you mentioned you were able to see "ghosts" using the Aeon stick. I'm assuming some software is needed. What did you use?

Thanks
John

Most of what you need is here:

I'm in the same spot, C7 still in box, waiting to deploy.
The instructions say to use NWI, which never worked for me. I always used classic learn and always put HE in include mode first before clicking classic learn.
Look for devices that are listed in pc controller 5.x, but are not listed in HE, click "is failed", it will turn red if failed, then click remove failed.
You'll need a silicon labs account to download, it's free
link to pc controller(they have a very confusing array of software)
https://siliconlabs.force.com/s/validatezwsdk?ContentId=0681M000006WUzV+&ContentType=SDK&rURL=https%3A%2F%2Fwww.silabs.com%2Fproducts%2Fdevelopment-tools%2Fsoftware%2Fz-wave%2Fembedded-sdk.html

1 Like

NWE and NWI worked with my UZB-7. Classic depends on a direct connection whereas NWI can use hops. It doesn't really matter though when it comes down to it. Just use whatever works.

1 Like

Awesome, thanks for the info. Just got my UZB-7, now just need the z-wave issues on C7 resolved and I can proceed with immigrating my devices

2 Likes

this worked like a charm to migrate almost all my z-wave devices over. the only one I’m having trouble with is a zooz power strip. As noted, it cannot be moved over with the above procedure, so I just excluded and added to the hub. This created two copies of it on my hub - one that was restored from the old hub, and a new freshly paired copy that actually works. So I moved over all my automations and everything is working great... except now I can’t delete the old version of the device.

I click remove, then wait for “force remove” to appear, then click force remove — then I get a 500 error.

Can't be certain, of course, but when I see a 500 in that sort of circumstance it's because it's Gone.

It still appears in my device list. It doesn’t do anything and isn’t associated with any automations, just junks up my list.

Did you look in the ZWave Details list?? Is it removable from there, yet?

Screen Shot 2020-09-13 at 6.34.31 PM

No, it was never actually connected to this hub. It was restored from my C4 onto the C7.

I figured it out. I changed the DNI of the parent device when I did the migration. After I changed the DNI back, it allowed to delete it.

1 Like

Half way through my c5 to c7 migration.
Thank you @bravenel for the instructions.

2 Likes

@bravenel May I ask a question re: your note. Actually two.

  1. I was able to pull my Schlage 469 over using this method. It joined using S0 because I assume that all the FW 8 can handle and I thought, what the hell, let’s try it. The method worked and it seems to be functioning ok. I still have more work to do on it because my driver has lost the names of the lock codes but maybe I need to just punch the lock codes into the door and see if they are sent, but I doubt it. Is there anything wrong with leaving it like this or should I exclude and rejoin?

  2. I have two Zooz zen25 double plugs and a zen31 rgb. All three have child devices. So you are right, o couldn’t use this method and had to manual stitch the new devices in. Somehow I was able to remove one of the old orphaned zen25s from my device list. The other zen25 and zen31 ‘used in’ list are empty but I can not remove them. The remove button is greyed out on the child devices and when I click remove on the parents, I wait, then click force remove and I get an error 500. Shutdown/unplug for 30 sec/boot and retry produces the same results. Do you have any suggestions for me?

Aside from this I am good. Only one device out of 30+ is using my new three pack of ring extenders that I included first and waited a day before proceeding (grrr) but I’ll play with that too.

My Schlage came over just fine with the method of renaming the DNI and it's been working fine for over 4 weeks now. I was even able to preserve the names and use the lock manager to add a few codes as a test. And finally got around to giving the wife a new code since she didn't like her old one.

1 Like