Maker API - "No response from hub" (cloud)

I was having this issue before, and "solved" it by vastly reducing the number of devices in the Maker API instance, when I went back and added more devices back, I got "no response from hub" on the cloud "Get All Devices with Full Details" the "Get All Devices" almost always works.

Rebooted the hub
Deleted the Maker API instance and recreated it
yes, cloud access is enabled

yes, local access works


I've tried going though and adding 1 device, then adding all of its type (e.g. lutron switches) then moving on to a new device type, but then I'll add something new and it will break, and removing that thing won't unbreak it. I've tried this a few times, and what breaks it doesn't seem to have any pattern.

I also tried only adding devices with core system integrations rather than any 3P drivers and still breaks at some seemingly random point in adding new devices.

How many devices are we talking about?

Seems like a good one to email support on.

That said, 'get all devices with details' really pounds the hub hard, and should be avoided whenever possible. Most integrations that use Maker API heavily have gone to doing multiple calls and pulling the details for used devices directly instead of using 'get all devices with details'.

But I do agree that if the command is going to be in the system then it should work and not (presumably) timeout.

Not sure, but maybe @bravenel has insight on 'get all devices with details' not returning any data in some cases when doing form the cloud?


As a workaround, why don't you break them up into multiple Maker-API instances?

I probably should, but seeing as they never emailed me back from the last 2 support issues I had for other unrelated issues, I'm not holding my breath.

Thats a good idea, but I just ran a test with just "sensor" type devices ~20 and I still get "No response from hub" with a narrow list. sometime shift-refresh on the page willl cause the data to load, then the next refresh it doesn't its very flaky. I made another sub-list with about 24 Lights and switches (Hue, lutron, one zigbee) and it gets an error 100% of the time, but yesterday when i was trying to build the entire list device type one-by-one, adding lights never caused the error.

I have one list with 147 devices and one with 87. No issue retrieving either over the cloud. I used curl for this test.

Neither of my Hubitats have many apps. Or any cloud integrations.

I'm glad you're not having issues. but unfortunately that isn't my case.

I would contact support. They can look at your hub and give you a better idea of why things aren't working.

Whenever I've had an issue @bobbyD had identified the cause with pinpoint accuracy.

(except the last time, when before he had a chance to respond, I did a factory recovery - luckily that didn't break anything).

Do you have many LAN connected devices, and are any of those hitting your hub frequently? It sounds as though there is a timeout problem, which could be a network caused issue, or it could be coming from the hub. If your hub is getting pounded by some of your devices, it could be that these http requests are timing out. The fact that local works, and cloud doesn't, sort of points at that being the issue. Also, the amount of data sent when you hit the All Devices with Full Details url can be very large.

One other thing I'd be very curious about is whether or not you are seeing errors in your logs, for any reason. And, have you tried making a backup of your hub, and doing a Soft Reset, then restoring from backup. A large db with lots of traffic and timeouts could become corrupted, and this is one way to clear that up. Without seeing the details of your hub, these are all just guesses as to what may be going on.

When you tried the shorter list of sensor devices, and it didn't work, that sounds like a candidate for further testing...

Yes, a few, Lutron switches, Hue, Tesla Powerwall, Netatmo weather station, and some wemo insight outlets. I've tried building a Maker API list that only included built-in drivers and no wifi/lan devices and still had the same issue.

I tried a list with literally only a small number of z-wave devices and sometimes it works and sometimes it doesn't, it seems arbitrary.

My logs don't have any errors right now

I'm not tried a soft/reset/restore yet, but the hub gets rebooted regularly. Does this disassociate devices from the hub or not?

Soft Reset does not affect the device pairings with the hub. Be sure to download a backup first.

That's interesting that its failing with a small number of devices. Something is amiss... Most likely it's not Maker API, even though the problem is revealed by using it.

1 Like

Ok sounds like a weekend project.

Any updates on this? I'm experiencing a similar problem. I'm making http requests via tasker to lock doors and change to away mode on leaving. Sometimes these requests go right through and sometimes they do not. I haven't been able to figure out why, but when they do fail, if I try the same request from a browser right then, I get "no response from hub". Eventually they'll go though, although the time to wait and resubmit seems random.

I am also experiencing the same error and I only have one device

This is a very old thread and the reliabily of the Maker API has greatly improved in recent years. If you are having similar problems, please consider creating a new topic and provide additional details of your current poor experience. I am closing this thread as the original issue is really outdated. Thanks for your feedback. Looking forward hearing more about your issue in a new thread.