Lutron Caseta Setup Tutorial

I get the non-Pro vs. Pro differentiation, but on eBay I'm also seeing bridges that are described with a 2 (e.g. LBDGPRO2 or LBDG2PRO) and some without. Maybe that's just sloppy seller descriptions, but is there a difference in terms of working with Hubitat?

The model number that you need is L-BDGPRO2, anything else is just written improperly.


I'm looking at one that has pictures of the box and device label that is precisely "L-BDGPRO" (no 2 or WH or any other prefix or suffix). Is that model compatible?

EDIT: to add actual pic

Mine is a pro2, but has same model number.

1 Like

Isn't the Pro2 the one that gained "Apple HomeKit" certification?

The Pro is the critical set of letters I believe. That is where they enabled the telnet feature and that's the feature Hubitat needs.


I believe this is correct. 2 means HomeKit compatibility. The WH simply means the product color is White. Mine has a C on the end, which means it is the version for Canada (which I believe is just a French language packaging difference).

If it’s significantly less expensive, then go for it. You don’t need the HomeKit capability just for Hubitat. If not, I’d go with a version that has 2 in the model number. No reason to limit future possibilities if there’s no gain otherwise.


This is a little bit OT, so if I need a new thread, I'll do that; but I think it might have some, hopefully very little, general interest. Got my bridge (L-DBGPRO) but I'm not getting very far. The Lutron app finds it on my network but immediately fails to connect, saying "There was an issue connecting to your Lutron system". I can ping it on my local network, but apparently Lutron can't see it.

My call to Lutron was less than satisfactory. They looked up the MAC address, didn't see it from their side and declared it a router problem, which of course they couldn't help me diagnose. They assume my router has some firewall blocking it. I'm out of my realm with this kind of networking problem. Though, I can say a couple of things: nothing else (e.g.Hubitat, ST, Wink, a TV tuner, Blink, SkyBell) has trouble; AFAIK, I haven't messed with any firewall settings or port forwarding or any "fancy" non-standard router settings.

As I conceded, this is veering OT, but I'm hopeful someone has experienced and solved similar Lutron problems or even that some network guru here could give me a starting point to diagnose. Any help or suggestions are appreciated.

I have the L-BDGPRO2 and an extensive firewalled network. No problem with the initialization.

It seems to go to Lutron

I browsed there from my Computer and got the login screen, as expected. It's not using any odd ports.

Logging in from my computer just takes me to the option of changing my pw or changing my email. I did neither, but the point is, it's a just a website.

On the App on my phone, I went through the menu items and when I got to HomeKit & Siri, it says it's discovering and then barks with some maybe this and maybe that is causing it to fail discovery. I don't need it so I moved on without evaluating...

Advanced was where all the fun is.. Integration, Telnet Support is on, Connections also barks with a message I don't care about. Network settings is exactly what I expect. I have a DHCP reservation for this and that's working.

nothing obvious I'm afraid. :frowning:

1 Like

Thanks for that URL. From my computer, going through the same router as the bridge, I get to that address, no problem, and see the same screen you referenced. Can't see why the Lutron app can't do it.

Did you push the button on the SmartBridge Pro?

No, sir, I had not (documentation is sparse, but it was my understanding the button is for pairing devices). Now, I've tried every approach to timing the button push to no avail. Can you tell me how should the button be used?

I also don't know what the white perimeter LED is supposed to indicate. It's solid white, which is what I told Lutron support when they asked.

The sequence is for the app to discover the Bridge, which takes about 10 seconds. Then it immediately gives me the "... issue connecting ..." error.

I don't remember the sequence exactly, but perhaps I could reproduce it. At some point during the SmartBridge discovery process it instructs you to push the button on the SmartBridge. It sounds like you aren't getting that far.

I would suggest factory reset of the SmartBridge (not sure how that's done, but will investigate), and remove the app from your phone. Start over from scratch. Make sure the SmartBridge is plugged directly into your wifi router, and make sure your phone is on wifi from that router. You can always move the SmartBridge later if needed.

Edited to add

Try resetting the SmartBridge Pro by quickly tapping the button 3 times, then holding a few seconds, then 3 more quick taps.

Those instructions are for a Lutron Connect Bridge, but I suspect they may work for the SmartBridge, as it is a cousin of the Connect Bridge.

Thank you, Bruce. I am doing everything directly to my gateway router.

I'm not quite there, but I feel like I'm getting closer. The first triple-tap gets me to the slow blink but I'm not able to achieve the wick flash that indicates a successful reset. I hope it's just a matter of better dexterity with the button so I'll keep at it.

I just did this procedure on a RA2 Select repeater, which is basically the same hardware as the SmartBridge Pro. It works. Hold third tap at first, led goes to slow blink, then 3 quick taps, led goes to fast blink. That's it.

I spent a couple of hours trying every permutation of triple-tap-hold-wait-tap and there is no acknowledgement of the bridge resetting. I now believe that I previously confused (what I guess to be) a no-network 5 second blink with the first stage reset blink. Dozens of attempts do not get any reset.

I even tried a 30 second hold, which some references indicate does a reset of DHCP (which I probably don't need).

Next up is to try Lutron support on the phone and, this time, keep talking until I have it figured.

Maybe you've tried it already, but have you swapped out the ethernet cable that it shipped with? I've had cables ship with bridges and hubs that tested fine, but when I tried to use them with the device they shipped with, it was a no go.

1 Like

That's an idea, but no joy. I always toss the cheap USB power cables but hadn't thought about the Lutron Ethernet. So, I tried, but no better. Thanks anyway.

1 Like

:rat: :rat:

An update on my Bridge. After exhausting every network resource I could find (if any of you are familiar with the ROOter project, the community there is excellent), I spent some quality time with Lutron support. They were not convinced that it still wasn't a network problem but my thinking is that since I couldn't do a triple-tap-etc reset, that strongly suggested a product problem. After a very helpful session, Lutron agreed to send me a replacement. Here's a vote of confidence for Lutron products - expensive but surely a case of "you get what you pay for". Thanks to everyone for your help.


I have had amazing experiences with Lutron support and they have never let me down

People ask me why I spent extra on Lutron products, and you just discovered the answer - they are amazing and stand behind you (and their products) 100%