Looking or help with Beok Tuya ZigBee Smart Thermostat Heating Thermostat

I have a (Beok Tuya ZigBee Smart Thermostat Heating Thermostat WIFI Temperature Controller for Gas / Water Boiler Floor Heating Compatible with Alexa, Google 3A TGR85-ZB) that i got from amazon got it working but when i connect to hubitat it finds ok but comes up as just device. would love to get this working/
some information

endpointId: 01
application: 44
inClusters: 0004,0005,EF00,0000
outClusters: 0019,000A
model: TS0601
manufacturer: _TZE200_2ekuz3dz

ID: 0523
Manufacturer: _TZE200_2ekuz3dz
Product Name:
Model Number: TS0601
deviceTypeId: 211
manufacturer : _TZE200_2ekuz3dz
idAsInt : 1
inClusters : 0004,0005,EF00,0000
endpointId : 01
profileId : 0104
application : 44
outClusters : 0019,000A
initialized : true
model : TS0601
stage : 4
manufacturer :
idAsInt : 242
inClusters :
endpointId : F2
profileId : A1E0
application :
outClusters : 0021
initialized : true
model :
stage : 4

Have you tried using the “Generic Zigbee Thermostat”?

If you try it, be sure to hit the “Configure” button.

And if that doesn’t work, I fonder if this one would…:


thanks have now got

Current States

  • supportedThermostatFanModes : [auto, on]
  • supportedThermostatModes : [off, heat, cool, auto, emergency heat

Welcome to Hubitat community!

Your thermostat uses Tuya very specific communication protocol, so the generic drivers will not work.

Please follow the link posted above by Sébastien and let us know if you need help with the installation of the custom driver.


Hi installed driver

it found this

  • coolingSetpoint : 20
  • heatingSetpoint : 20
  • supportedThermostatFanModes : [auto]
  • supportedThermostatModes : [off, heat]
  • temperature : 20
  • thermostatFanMode : auto
  • thermostatMode : heat
  • thermostatOperatingState : idle
  • thermostatSetpoint : 20

send set point to change but nothing happening to thermostat controls unable to send any instructions, have tried changing the models no different.

my log shows (have set it to repeat send on fail.)

dev:3292022-01-09 11:07:16.253 am tracesendTuyaCommand = [he cmd 0x0523 0x01 0xEF00 0x00 {002D100200040000000A}, delay 2000]

dev:3292022-01-09 11:07:16.233 am debugboiler changing setpoint to 10

dev:3292022-01-09 11:07:16.230 am debugboiler setHeatingSetpoint(10)

dev:3292022-01-09 11:07:16.226 am debugboiler resending setpoint command :10

dev:3292022-01-09 11:07:16.223 am debugboiler setpointReceiveCheck()

All help is appreciated.

Please first install the development branch version (from the second post in the Tuya Wall Thermostat thread).

Next press the Initialize button. Do not switch on the options to repeat the failed commands, these can be used later, after the basic functions are verified to be working correctly.

Send me the logs that follow immediately the Initialize. I need to know how the model is recognized, this should be visible from the log.

Seems like your model is not recognized correctly, as in the logs I see reported 10 degrees setpoint, while I suppose you send 20 degrees.

Make sure you first update the driver from the link in the second post.


2022-01-09 02:26:06.132 pm infoboiler Initialization finished
version=1.0.0 (Timestamp:2022/01/09 2:12 AM)
dev:3292022-01-09 02:26:06.128 pm infoboiler manufacturer = _TZE200_2ekuz3dz ModelGroup = Unknown
dev:3292022-01-09 02:26:03.104 pm infoUpdate finished
dev:3292022-01-09 02:26:03.090 pm infoDebug logging is true; Description text logging is true
dev:3292022-01-09 02:26:03.087 pm infoForce manual is false; Resend failed is true
dev:3292022-01-09 02:26:03.084 pm infoUpdating boiler (Device) model TS0601 manufacturer _TZE200_2ekuz3dz ModelGroup = Unknown
dev:3292022-01-09 02:26:03.039 pm infoinstalled()

Because of some reason, you have not installed the latest driver version. The version that you are using doesn't include your device manufacturer ID. Please update the driver to the latest version - the link is in this post.

Also, the 'Resend Failed' option is still enabled. Please switch it back to 'off'.

Please try again after you successfully update the driver version.

When you succeed in the driver update procedure, you must see a log line like this:

Updating boiler (device) model TS0601 manufacturer _TZE200_2ekuz3dz modelGroupPreference = Auto detect (MOES)

1 Like

I have updated the 'production' version to the latest development branch version. So now any of the two links will have the latest code that contains the Beok Tuya ZigBee Smart Thermostat fingerprint.

1 Like

Don't no why but I unlinked thermostat Cleared the driver and rebooted the installed latest driver and reconnected the thermostat this is the first log file I got.

dev:3872022-01-10 05:20:36.318 pm warn(duplicate) transid=131 dp_id=2 dp=24 fncmd=221 command=02 data = [00, 83, 18, 02, 00, 04, 00, 00, 00, DD]
dev:3872022-01-10 05:20:36.310 pm debugThermostat parse() descMap = [raw:catchall: 0104 EF00 01 01 0040 00 9333 01 00 0000 02 01 008318020004000000DD, profileId:0104, clusterId:EF00, clusterInt:61184, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:9333, isClusterSpecific:true, isManufacturerSpecific:false, manufacturerId:0000, command:02, direction:01, data:[00, 83, 18, 02, 00, 04, 00, 00, 00, DD]]

New problem for you the thermostat is connected and have connected it to Alexa app no problem and if I ask to turn off the thermostat will turn off but will not turn back on ? .

But the main problem I am having is if I ask to set to 25 it gets set on thermostat to 2.5 if I ask to set to 10 then I get 1.5 Celsius.

Don't no if this is something to do with the Alexa app or me.

Just like to say thanks your doing a excellent job.


if I set the heating setpoint in the driver to 260 I get 26 on thermostat if 250 I get 25 so no idea why Alex would set them at 2.6 and 2.5.. I am still learning so if you can explain why then would be helpful to me

My final update is when connected to the hub my time goes to 26.45 hours when I disconnect and reset time manually it stops the correct time.
if I reconnect the time on the thermostat goes out again I don't want to work a 26 hour day. hope this helps in your development.

Hi @andrewshilton48 ,

Seems like you are still using an old version of the driver where your thermostat model is not recognized correctly.

Have you updated the driver code from https://raw.githubusercontent.com/kkossev/Hubitat-Tuya-Wall-Thermostat/development/Tuya-Wall-Thermostat.groovy ?

After the update, please press the Initialize button from your thermostat device page.

Check Hubitat log page for your device. You should see logs like these:

dev:11322022-01-11 08:05:27.455 infoTS0601 Tuya Thermostat Initialization finished version=1.0.4 (Timestamp:2022/01/11 1:06 AM)

dev:11322022-01-11 08:05:27.452 infoTS0601 Tuya Thermostat manufacturer = _TZE200_ye5jkfsb ModelGroup = AVATTO

dev:11322022-01-11 08:05:24.437 infoUpdate finished

dev:11322022-01-11 08:05:24.433 infoDebug logging is false; Description text logging is true

dev:11322022-01-11 08:05:24.425 infoForce manual is false; Resend failed is false

dev:11322022-01-11 08:05:24.422 infoUpdating TS0601 Tuya Thermostat (Tuya Thermostat) model TS0601 manufacturer _TZE200_ye5jkfsb modelGroupPreference = Auto detect (AVATTO)

dev:11322022-01-11 08:05:24.384 infoinstalled()

In your case, the 'modelGroupPreference' should be MOES.
Also, check the driver version that is shown in the log.

Is your log showing version 1.0.4 as in my example above?

Just noticed your update... Have you set your location timezone correct?
It is on Hubitat 'Settings' menu, 'Localization'. Is your timezone set correctly? This is mine:

Also, it may be good ide to check your hub time setting. From HE 'Settings' menu, check 'Hub Details' :
Make sure the time that is shown here is the correct one.

On the BEOK Controls web page, there are at least 6 (!!!) different thermostat models :

Which one is yours?

I was wrong stating 6 models, these are actually 15 (fifteen) models and variations! :sweat_smile:

1 Like

It is number 4 the black one with no colour if you turn off the screen it looks like a mirror
just says on box TGR85 WPB this is for gas boiler 3Amp.
had my location set to GB changed it to Europe/ London I never thought to check that

1 Like


This should be the manual (uhh... the short leaflet).

nearly this is a mine is ZigBee not Wi-Fi book slightly different from about page 12,

dev:3872022-01-11 19:43:25.941 infoThermostat temperature is: 21.9
dev:3872022-01-11 19:43:25.937 traceprocessTuyaTemperatureReport dp_id=2 dp=24 :
dev:3872022-01-11 19:43:20.711 infoThermostat Initialization finished
version=1.0.4 (Timestamp:2022/01/11 1:06 AM)
dev:3872022-01-11 19:43:20.707 infoThermostat manufacturer = _TZE200_2ekuz3dz ModelGroup = MOES
dev:3872022-01-11 19:43:17.670 infoUpdate finished
dev:3872022-01-11 19:43:17.650 infoDebug logging is false; Description text logging is true
dev:3872022-01-11 19:43:17.646 infoForce manual is false; Resend failed is false
dev:3872022-01-11 19:43:17.642 infoUpdating Thermostat (Device) model TS0601 manufacturer _TZE200_2ekuz3dz modelGroupPreference = MOES (MOES)

the thermostat is still showing 2.5 not 25 ETC

We are getting closer! :slight_smile:
So the room temperature is shown correctly ( 21.9 C)

You mean you are setting up (from the device page 'Set Heating Setpoint' button) temperature 25℃ , but the thermostat shows 2.5℃ on the display ?

yes if i set end point at 25 the display shows 2.5 it seems to be a digit out. its getting so close I can feel the heat.

1 Like

Do the 'heat' and 'off' buttons work?

I will make a new 'modelGroup' BEOK, obviously this model differs from MOES thermostats.

just random set heating set point to 40 and I get 28 on current stats and 2.8 on thermostat..

if set 20 on stats goes to 20 if I set 28 stats goes to 28.
no matter what I set after 28 nothing changes stops at 28

Download the Hubitat app