Linear Garage Door

Going to beat a dead horse here. I've got a Linear Garage Door opener that I can get to pair but never fully. On the Device page under Status, it shows Unknown. It will never report Current States when looking into the Device. State Variables are blank. Commands won't open or close the door. I have factory reset the Linear Garage Door device and repaired the door sensor prior to moving the hub within about 6 inches of the device to pair it. It pairs in seconds but just not fully. Any ideas on what I can try? This is the last device from Smart Things and I would love to get this garage door working properly.

I saved these instructions, which worked for me to get the GD00Z opener paired completely:

  1. Reset the controller to factory:
    -press the pairing button 5 times
  2. Pair the Tilt Sensor if in doubt:
    -install tilt sensor
    -hold controller button for 7 seconds until it beeps
    -open garage door and unit should beep/flash as door opens
  3. Close garage door
  4. Pair controller with hub
  5. Open garage (not with hub)
  6. Close garage (not with hub)
  7. Status should show up in hub
5 Likes

Thank you for the response. I will try this out when I get home this afternoon. I did most of this minus opening and closing the garage door in step 2 and steps 5-6.

1 Like

Just tried this. Unfortunately it still won't show status. Pairs in seconds. But just no status.

Pairing must end up looking like this:

55%20PM

If the "zwaveSecurePairingComplete: true " is not there (or false) then the Opener Device is non-functional. That's a requirement of the ZWave spec for Barrier devices:

4.2.4.1
Command Class Support and Security level 
The Motorized Barrier Device MUST support its Command Classes depending on Security Bootstrapping as 
follows: 

If security bootstrapped, it MUST support its Command Classes only if the highest granted key is S0 
or S2 Access Control Security Class. It MUST NOT support its Command Classes at all if its highest 
granted Security Class is any other class than S0 or S2 Access Control.

If it timed out waiting for security bootstrapping or S0/S2 bootstrapping failed, it MUST NOT support 
its Command Classes non-securely

Sorry it took so long to respond. The zwavesecurepairingcomplete is totally missing. I will try to pair it again later this weekend when I have time to move the hub closer to the opener. Probably won't work but will give it a shot.

It did take me several tries of going through all those steps, before I finally got everything to work. And, I had to take the controller into the garage, I held it pretty close to the opener. Apparently with that secure pairing, you have to be pretty close for it to work, even with door locks and other devices.

Denise -

Thank you so much for your help. I followed your direction about 3 or 4 times and it finally worked!

1 Like

Great to hear! :grinning:

I feel so lucky. I've been reading a couple of threads on this garage door control, and was dreading having issues.

It worked first time! I didn't even have to move my hub, and it's on the other end of the house!

Not gloating, just wanted to give hope to anyone else reading this thread!

I installed one for my mother this past weekend and it was flawless. Not sure if it is due to the updated software in the Hubitat or the newer garage door controller. Either way, it paired on the first go around.

1 Like

I was able to exclude the iRis - Linear GD00Z-4 Garage Door Opener from my SmartThings and include it on the Hubitat Elevation hub in seconds. It was a breeze. However, upon testing I am finding out the door status is acting strange. When I opened the door the first time the devices menu show status correctly reporting Door Opening, then when it got fully open, the status changed to Open. So far so good. It was the closing part that is broken. When I execute a close from the devices menu, again the status is updated and correctly reports Door Closing but the door status show Open even after the door is fully closed. After a long time I will come back to check on the status and it eventually shows the change to Closed but that is much much later.

What is going on with my door tilt sensor and reporting the change so very slowly?

I have a monitoring rule setup to alert me if the garage door is open longer than 5 minutes so I can close it. This monitoring rule is being falsely triggered because it "thinks" the door is still open.

If you have a spare zwave plug I would give it a shot. The radio on the HE hub isn't as strong as ST. I had to add a repeater (iris smart outlet) in my garage to get consistent reporting for my contact sensor, lock and garage opener.

Not saying that is necessarily your issue, but it's worth a shot if you have an outlet laying around...and don't forget to do a zwave repair after adding the repeater. In fact, have you done a repair since adding your garage controller...that might be also worth a shot before adding the repeater. Open your logs before doing the repair so you can see if it generates any errors as well.

Yes that is a good idea. I am going to get a repeater in the garage. Right now I am having a weird issue with the hub not controlling things well, sometimes it does and sometimes it doesn't so I am not sure if this contact issue is related but I will watch.

UPDATE: Also there is no way for me to know the battery status on that Tilt Sensor? It might be the battery needs replacing? I don't remember when I last changed it.

I ran the Z-Wave repair and the it went without any hitches or errors logged. I will also try replacing the battery on the tile sensor to see if there are any changes? Maybe after that resetting the controller and starting from scratch and rejoining the tilt sensor with the controller again. I have lots of little issues that have cropped up with HE right now in my migration and I need to slow down and start tackling them head on one at time to isolate what is going on.

Right now I just need my Hubitat Safety Monitor (HSM) and Simple Lighting Rules (HSL) to work flawlessly. If she flips the bedroom WD100 or voice commands it, the lights need to go on or off immediately as desired. A voice command to set HSM to Arm-Away or Arm-Home needs to be set on immediately as desired. Unfortunately it just ain't happening and the system is either stuck or just slow as molasses.

1 Like

Thanks to this thread I was able to my gd00z-04 to pair. I had to basically put the hub on it to exchange the secure key. Even three feet away was to far.

Coming from Wink, the app showed the total time the garage door was closed and open. Is there any way to get this in Hubitat?