GE Link on Hue bridge problems

I ended up moving all my GE Link bulbs off direct connect to HE to my Hue hub instead and using the Hue integration to HE.

It had been working ok for a few days but now several of the GE bulbs are no longer communicating on the HE hub so I can't control them BUT they work just fine if I operate them via the Hue app.

How do I get control again of the GE bulbs? When I had connection trouble before I moved to the Hue hub I would reset the GE bulb by ON-OFF 5 times and then rescan for new devices and it would reconnect. I think this is a different issue because I still have full control at the Hue app

UPDATE: It wasn't just the GE Link bulbs but all the Hue connected bulbs that were acting up inconsistently. The solution was to remove and readd the Hue Bridge Integration app and then rebuild all automations that Hue bulbs were included in.

Are they still seen by the Hue Integration? Open the app and run bulb discovery to see if they are discovered again.

1 Like

I think you are on to something @SmartHomePrimer They are all discovered in the HUE mobile app but in the HUE Bridge Integration for HE I get this "An unexpected error has occurred trying to load the app. Check Logs for more information" And here is the log

It seems to be random. I discovered the issue with my lights but I think it might be a system wide issue. This morning I am noticing that the same lights that didn't work last night worked this morning and vice versa with lights that did work last night? When I run a RM that essentially is putting things in night mode it is taking literally minutes to run like it is stuck.

I am going to reboot the hub and start watching the logs to see what in the world is going on...

1 Like

I did have this exact same problem when I played with my home network as well. Just open up HE and find your Hue bridge, click on the bulb list, update and click done.

1 Like

As I continue to troubleshoot this issue it appears it is also showing up in my devices (Wall switch status) not changing. Again my GE Bulbs can be controlled just fine from the Hue mobile app, however the Simple Rule is when the wall GE Smart Fan switch is pressed turn on the GE Link Bulbs in the room. The wall switch is not triggering the GE lights. When I look at the driver I see it never updating its status to be switch ON so that is why the Simple Rule is not triggered. And the past logs are not showing activity on this in-wall Ge Smart Fan device or the Simple Rule being activated?

I think I need to resolve the "null object" error showing up for the Hue Bridge Integration I posted above first before I can look at this GE Smart Fan issue.

Any thoughts on how to resolve that Hue Bridge Integration null error? Every time I click on the App link it gives me an error and I can't access any of its settings. What is the right step to take?

I was able to get into the app finally without the error preventing me from opening the Hue Bridge Integration app.

Is it normal to have the selectedHue to have null ?

I am not sure where you are directing me to update. Is this the correct location

I think HE is not seeing your Hue bridge. I believe that null should be your Hue bridge ID. Tagging Bobby but it's Christmas Eve @bobbyD

bridgeHost shows the correct IP?

Was just about to ask this. Ensure your Hue bridge has a reserved ip and that it is actually picking up the reservation you set. I know you recently added an access point. You should also ensure that the access point does not have it's own dhcp service running


We are here, someone needs to make sure the automation runs as expected, so Santa doesn't have to ask Alexa where his cookies and milk are...ho, ho, ho!


OK, I had to get to church with the family and will try a remove and a re-add of the Hue hub. Is this my solution to try? I think the cause of this weird issue is I did change out my router and it caused havoc on all my wifi devices IP being reassigned. I thought the Hue bridge survived that mess but it looks like it did not?

I think that will automatically destroy all my automations on my bulbs and I will have to rebuild them.

You won't have any issue with the Hue bulbs in HE. I changed the Hue bridge once without doing anything to the Hue bulbs in HE. After added the Bridge and discovery. I was able to control the bulbs again.

OK, I had to remove and re-add the Hue Hub and rebuild the automation rules so the good news is I am back up and running. A big shout out for behind the scenes help from @bobbyD on PM and for @Navat604 for reaching out to him.

I don't know if not having a reserved IP is what messed this up but for sure the IP changed when I changed routers. The bridge host shows the changed IP and not the original one that was defined when I first ran Hue Bridge Integration app.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.