Lights come on in middle of the night

I am having an issue with my bedroom lights waking me up in the middle of the night. This morning it happened at 2:20 am. These are Z-wave dimmer bulbs and do come on at full bright (ugh!) after a power outage, but I believe I have eliminated a brief power flicker as the cause because when I intentionally turn one off and back on at the switch, it is not recorded in the logs. The random turning on in the middle of the night is in the logs:

As a side note, I do not at all understand why the last event says physical. These are dimmer bulbs and there is no physical switch. (The aforementioned switch is on the base of the lamp, not part of the bulb.) I just tested turning it on and off with the Dashboard tile, and it was recorded as digital, not physical, as I would expect.

I've read that there may have been issue with Google Assistant randomly turning devices on, but the post I saw regarding this was a while ago, so I hope that's fixed by now if it was true. Removing the lights from Google is absolutely not an acceptable solution for me. And I would think it would be odd that those two lights came on at the same time, but other devices in the house did not come on.

Any other ideas? Is it possible to find more detailed logging that shows the source of the on and off commands?

The best I can offer is:

  • Look at options available on the Device Edit page for additional logging, e.g. debug logging, turn these on for a short period of time, maybe a couple of days...
  • Similarly, look on the Device page for things that use the device (see the table at the bottom of the page), like apps / rules and do the same thing with them, turn on any additional logging

Simon

In terms of the physical / digital part, I can only assume that something outside of HE may have adjusted the bulb (like what you mentioned with GH) and so the bulb is simply reporting its state change to HE, which it reports as a physical change vs a digital one applied through HE apps / drivers. Just a guess...

One other thing worth checking would be whether the bulbs have a power recovery setting, not sure of the correct term there... Essentially whether they have any settings or default behaviour for when power is cut and then re-established. Although, like you said, you tested that with the switch.... Weird...

Thanks, Simon. I will look into additional debug logging for the devices themselves as well as rules and apps they are used in. When I manually turn the bulbs on an off through Google, they are logged as digital. Weird that only that one event is recorded as google.

There are no power recovery settings that I know of for these devices. They come on full bright after a power outage, but I am fairly confident that is not the cause of the issue since a power outage and restore do not get recorded in the logs.

I had a similar experience with a Z-Wave dimmer. It was even reporting the event as "physical". When I contacted the dimmer customer support I told them that I sat up all night watching the switch and was reasonably nobody touched it. I had fallen asleep for a few minutes so I couldn't be 100% sure :slight_smile:

It would come on periodically, never at the same time.

I finally excluded it and re-joined. The issue went away.

Check the inuse by field in the device and investigate each option. I still would suspect google/alexa (alexa hunches are the worst and should entirely be opt in)

1 Like

Sounds like a bonafide zwave ghost...

I tried that. Unfortunately, it didn't resolve the issue.

I really need some help with this one. Originally it was always happening at 2:20am. Not every day, but same time every day that it did happen. I wondered if it had something to do with the hub rebooting via the Rebooter app, which I had set to happen at 2:00am Monday, Wednesday, and Friday. But the last time it happened was on a Friday night/Saturday morning. So no hub reboot that morning. When I went to the backup/restore settings page, I saw that it was set to backup the database at 2:15am every day. The hub doesn't take 20 minutes to reboot, and 2:15 is much closer to 2:20 than 2:00 is. I changed this to 2:15 PM once a week. I also changed the Rebooter app schedule to 2:00 PM only on Monday. The last three days I've come home in the evening and the lights have been on. What. The. Eff. I played around with drivers a bit and they don't automatically refresh or poll currently, so for Monday and Tuesday this week, I don't know what time they came on; there was no entry in the log until I went to the device page and refreshed. Last night I created a rule that refreshes the devices every two minutes. Guess what I see in the logs today? EXACTLY 2:20pm there was an ON command followed by a 99% level command. Something is telling these lights to come on at exactly 2:20pm every day. Today is not a reboot day. Today is not a backup day. There is no backup with today's date in the list of backups. What else could possibly explain this ghost shifting by 12 hours since changing those settings?

I would love to hear from the Hubitat guys here. I am happy to provide any logs needed.

Here's a brief snipped of the hub logs from today at 2:20pm:

image

Please show a screenshot of the In Use By section of the device page. Is this light connected to either Google Home or Alexa, or to any other LAN based integration?

No LAN integration, no Alexa. Google Home integration on Light 2, but Light 1 is the one I removed and re-added, and I did not expose it to Google yet, to make sure that is not the cause of the issue:

Light 1:

Light 2:

I would disable the "in use by" either one by one or all at once. Obviously if it stops you could add two then two more etc.

What about Maker API? Could something control the light through that path? Temporarily remove it from Maker API??

What does Refresh Bedroom Lights do?

Thank you both for the suggestions. I'll try Maker API first. Honestly, I do not at all remember why I added that or what it is used for or by. Hmmm. I've removed both devices from it. We'll see if it breaks anything. Highly doubt it will.

Do you guys have any idea why the time is always the same and why it shifted by 12 hours?

No. But I agree with @JohnRob. It's one of those things where you have to remove all possible things that might be doing it. Suppose there were zero apps controlling it and it still came on. That would be revealing. But, by the same token, if it stopped coming on with zero apps, then you'd know it had to be an app. Etc.

The regularity suggests it's coming from software....

I'd disable GH completely to test.

Welp. We're well past 2:20pm and the lights have not come on. Obviously I need far more than a day to be satisfied the issue is resolved, but hopefully removing them from Maker API did the trick. I'll keep you posted.

1 Like

Do you remember what the reason was for adding the lights to Maker API, was there a purpose or just a general accessibility you were seeking?

What is maker API tying to?

Unfortunately, I don't have a clue why I added it. I was probably playing around with something I no longer use. I don't believe I am currently using any cloud integrations. I can probably just remove the whole thing.

Perhaps worth removing it then. Only suggestion I would make is to only make small changes and make them one at a time. So if you choose to make any changes to Maker API, only make those changes, then assess any impact, then make any additional changes and do he same, assess the impact. I would suggest making any changes suggested by Bruce / HE before any I suggest, they tend to know more than me.... :slight_smile:

Simon

EDIT - probably should have made my suggestion at the beginning...

Agreed. Thanks for the tips. So far there doesn't seem to be an impact by removing these devices from Maker API. Maybe I'll continue to remove a couple devices at a time and see how it goes.

1 Like

Download the Hubitat app