Leviton VRCS4 Device Driver

I have multiple VRCZ4s, multiple VRCZ1s and multiple VRCS4s. With ST I only ever used the VRCZ versions so I'm anxious to help in any way to get these working. Right now I'm simply trying to get the VRCZ1 to be a slave of a VRI06. I've tried the Rule Machine app, the Switch Binding app, all to no avail. I've configured the VRCZ1 as generic zwave central scene dimmer and switch and generic zwave dimmer and a VRCS4 and none have managed to work. So if I can help out getting these to work with the Hubitat I'd be happy to.

I managed to get the VRCZ1 working as a generic zwave dimmer and tied it to the VRI06 using the switch binding app so they track. So I moved on to the VRCZ4. The VRCS4 code "works" except it think only one "button" can be active at a time, whereas the VRCZ4 you can have all 4 buttons on at the same time. So as a VRCS4 when I turn on button 2 it turns off button 3 (if it was on) before it turns on button 2. Any way to get the code for the VRCS4 so that it can be modified for the VRCZ4? Or is there another way to have a multi-switch zwave device? I didn't see any generic zwave device that looked like it would create component/child devices like the VRCS4 driver does.

I'm still living on a hybrid ST/Hubitat network, with all my zwave devices still on the ST hub and reached by Hubitat (and Alexa) via Hub Connect. I've been putting off moving my zwave mesh across, not least because I don't want to have my VRCZ4s stuck on the ST side -- so I'll have to have a go at migrating my SmartApp and DTH shortly. But I believe the links to my ST code are around here, and I certainly wouldn't mind if you wanted to take a first stab at the migration. (There are some pretty detailed instructions here on porting ST code to Hubitat, so I'm hopeful that just following the checklist will do most of the job.)

I’m late to respond, but I figured out that the double button push appears to occur if I do a slow push. If I do it quickly, it reports just the once. I’m wondering if there’s a way to mute the second push if I’m slow. In the grand scheme of things, it may not even matter, though. Since it just a scene controller, launching the same scene twice in rapid succession shouldn’t have any ill effects, right?

As for button 6 behaving as button 5, I’ve had no opportunity to dive deep, but I’m starting to suspect that this is just how it is.

Since this (VRCS4) is a scene controller, I think that only one light on at a time is the design. Only one scene on at a time sort of thing. You wouldn't want the movie scene on at the same time as entertainment. Can that be changed by the DTH and SA to turn it into 4 different light on/off dimmers?

Hi all (and @misko in particular),

I've just completed porting my App and Driver for the Leviton VRCZ4-M04 Zone Controller from SmartThings to Hubitat Elevation. I'll probably do some additional tweaking, but you should find the current versions fully functional -- have a try and let me know?

See my posting to App and driver porting to Hubitat...

I just figured out how to make the VRCZ-M04 driver and switch mapper work (hubitat newbie) It took me a bit to figure out that I needed to "enable child dimmers" and point the switch mapper at the controller's children. Once I did that the 4 on/off paddles work to turn devices on and off using simple automation rules. I created additional rules to turn the child's LED on and off with the controlled device so It does what I need. Thanks!

1 Like

Glad to hear it's working for you!

I don't quite follow why you needed automation rules for your devices, or for the LEDs (on the VRCZ4 paddles, I presume you mean?), but if it's doing what you need then no need to mess with success.

Are you using the dimming function as well?

I'm not using the dimming function.
When I turned on the "enable child dimmers" switch hubitat created 4 children with the same name as the parent (:1 to :4)
The buttons on my controller turn the children on and off so I created the rules to look at the children and operate my devices (on off switches for my outside lights) based on the status of the children.
If I use the paddles to turn the lights on and off the LEDs on the paddles function as expected, but if the devices are controlled by my timer or dashboard the LEDs didn't turn on or off so I wrote the rules to have the LEDs follow the status of the controlled devices. Could I have just made the controlled devices children?

Actually, I'm not even familiar with the "enable child dimmers" switch -- where do you see this?

If you're using my app and driver (Leviton VRCZ4-M0Z Switch Mapper and Leviton VRCZ4-M0Z Zone Controller, respectively) with a VRCZ4, the switch-mapper app should just let you assign the four VRCZ4 switches directly to four devices (or groups of devices), which they will control without the need for any automation rules (and including dimmer functionality).

Does your switch-mapper configuration look something like this?

OK so THIS is embarrassing. But the info might be useful. When I included the VRCZ4 it defaulted to the Hubitat VRSC4 Z-wave controller driver. The "enable child dimmers" switch belongs to that. Once I used your driver, the switch mapper works as I imagine you intended. I tested on some dimming devices and the dim/bright buttons work. The one thing that threw me for a bit was that when I turn off a dimming device the LED on the paddle doesn't turn off until the switch ramps to off. A feature not a bug. BTW Yes my switch-mapper configuration looks like that. Thanks again.

1 Like

No need to be embarrassed -- had a feeling you might be using the VRCS4 driver instead.

Might need to reach out to the experts (@ogiewon, @mike.maxwell, @bcopeland, @bravenel, and @bobbyD) to see whether there's a path to having the hub auto-detect the VRCZ4 and offer my driver instead?

Sorry to ask a basic question. I have down loaded the driver and the switch mapper and I am ready to go for the VRCZ4, but I can not get it included. I have factory reset the VRCZ4, I hold buttons 1 and 3, all the buttons blink Amber, I tried to exclude it first, HE doesn't see the device. Then I tried to include it and it is not discovered. I'm sure it may be something simple, but I'm missing something. Thank you in advance..

Where do we find this switchmapper version, I am having issues with VRCS4 as well, not responding to button presses or anything.

I am new to hubitat and this was one of the first devices I was trying to get to function. Paired fine, but not responding to anything.

Here is the link I used to get the switch mapper for the VRCZ4 zone controller, looks like you need the VRCS4, scene controller, which is built in to HE, you just need to change the driver once you include it. App and driver porting to Hubitat

How did you get the VRCZ4 to include? how close was your HE hub?

It's been a while since I included my four VRCZ4s to my network, but I remember that one of the units closest to the hub gave me a fair bit of trouble (though I don't recall offhand how I finally resolved it).

Just recently I had to move my remaining Leviton Decora Z-Wave switches and Eaton dimmers across from Smartthings to HE, and I couldn't get any of them to include until I unplugged my HE and moved it to within a few feet of the switches -- then they all included effortlessly. (I discovered subsequently that those Levitons have a separate "network inclusion" mode that works well without needing to move the hub nearby, but I'm not sure the VRCx4 units support it.)

I think the unit might be bad, of course its the first one I started with. I was able to exclude it but not include it. I was able to exclude and include 2 other VRCZ4 controllers. I set up the buttons in the button controller, but the are not controlling the lights, and log as an off push. Still need to work with it. Any quick tips would be greatly appreciated.

Are you using both my VRCZ4 app and my VRCZ4 driver (Leviton VRCZ4-M0Z Switch Mapper and Leviton VRCZ4-M0Z Zone Controller , respectively)?

Per above, your hub will (by default) assign the official VRCS4 driver to your VRCZ4s, since it doesn't know about my driver -- but that won't allow my app to function. It sounds like you may be experiencing the same behavior as @etomami.

I mistakenly used the button controller. I was able to control the lights with the buttons using your app without issues, thanks! The dimming isn't working quite right. I set a button with 3 different dimmer switches, When I dim one right responds immediately, up and down without hesitation. The other lights goes full on then off, then they all go off. I tried it with a single light and had the same issue. Then all the z-wave lights in the house go off and I'm left in the dark... but I can turn them right back on again, I'm working out the quirks and my limited experience with the system thus far, the fix may be something simple.

Hm. Not sure what you mean by "mistakenly used the button controller", but maybe you want to share screenshots of your app and driver configurations?

Download the Hubitat app