Keeping lights on with "Motion and Mode Lighting Apps"

Hi all, alright, I am trying to set up some simple set of rules using "Button Controllers" and "Motion and Mode Lighting Apps". I am using Hue Dimmer and set it up pretty much the same way as it would be set up in the Hue app -- works as expected, no problem.

Then I am trying to have a rule in the 'Motion and Mode Lighting Apps' that turns on lounge lights when triggered by a motion sensor. However, I want to be able to keep the lights on 'permanently' when I press the 'on' button (button '1') on the dimmer, regardless of whether there is motion or not. 'Motion and Mode Lighting Apps' has that function, but is asking to indicate what button # to use. However, it's just not storing any inputs -- I enter 1, try to press Done but it just records it as a null.

What am I missing? I am starting to go mad here...

So, in that [DIM] Lounge buttons to disable off field, try entering 1, then click off the field, side of the page should be fine, then click done. Sometimes HE doesn't register a change in a field until focus is lost.


Yeah, that's exactly what I've been trying...

Enter 1
Click somewhere else off the field
The field defaults back to 'null' / 'Click to set'

I've tried Brave, Chrome, and Safari...

Just worked for me...

Do you have a "number of buttons" entry on the DIM Lounge device page?


What kind of device is the button?

Exactly... That's why I am starting to go mental. I've even tried on my iPhone, same thing.

Which makes me think my Hue dimmer doesn't support that or is somehow not recognised...?

Anything obvious looking at this?

You have that dimmer in HE via the Hue Bridge Integration, correct?

No, Hue dimmers connected via Hue bridge don't appear in HE. So I unpaired it from my Hue Bridge and paired directly with HE.

However, I just tried a couple of other buttons that I have (cheapo Sonoff buttons that work fine for other lighting automations) -- same thing, the field just doesn't seem to accept & store any input...
1 push

Ah...out of my experience, all I have are Hue bulbs. But I don't get why none of your buttons are working at all. Really odd.

Maybe reboot your hub [grasping at straws].

Yeah, tried that a couple of times as well... :frowning:

Thanks for trying though!

Really odd...

@lewis.heidrick - any ideas? A stumper...

Literally tried any button. Tried doing the same thing in other 'Motion & Mode Lighting' child routines and no joy either...

I'm starting to lean towards you being a bad person. Can't think of anything else at the moment...


Do you have a lot of motion automations? If not, maybe remove and reinstall the Motion lighting app?

Yeah, I considered that...

Also, here is what someone suggested on Hubitat's Facebook group, where I asked the same question.

And now I'm also thinking that maybe I should move all of my motion automations to Simple Automation Rules that appears to have a very straightforward functionality to do exactly that (that may work for me, still to be tested...).

You could use other apps...but I think you should figure out what's messed up w/the motion lighting app and also confirm that it's only a motion lighting app issue. It should work...somethings not right here.

1 Like

I agree, it sounds like we need @bravenel to confirm there is no bug though.

1 Like

You should turn on logging to see what is happening or not happening.

Thanks for looking into this.

As mentioned earlier, I am trying to use the 'Button to disable off' function under ' Options for Additional Sensors, Lights-Off and Off options' to keep the light that was initially triggered by a motion sensor 'on'. To do that I am trying to use the same Hue dimmer switch that controls the light and is paired directly with HE (not via the Hue Bridge) -- standard Hue dimmer with 4 buttons, button 1 being the 'on' button.

When I pick my button and then try to enter the button number, it all seems alright.

However, as soon as I click anywhere outside of that '[DIM] Lounge buttons to disable off' field, the 1 disappears and the field defaults back to null.

Then I go to click 'Done' but it's pointless as I already know I am going to try to store a 'null' value rather than a '1'.

So, as I expected, nothing too interesting in the log. It's probably because there is no 'commit' command triggered at the point where I am having issues, i.e. any value entered in the field staying in there...

Also, the app events do not seem to be saying anything too interesting.

Further to the above, I've tried setting up a switch rather than a button (Aurora AOne Smart Dimmer) that I have in my kitchen. Because there was no requirement to input a button number it was accepted & saved.

However, it doesn't really work for me either. When the kitchen switch is on the lounge lights still turn off after no motion is detected + 1min.

I don't know if this is a separate issue that I am having or related to the one above, or I am simply clueless about what I am doing...

@bravenel - are there any more details that I could provide or things that I could try to identify what might be causing the issues? Thanks a lot.