Issues after C-5 to C-8 Pro Migration

I have a couple of quirks after migrating from my C-5 to C-8 Pro.

My roku TV's now don't seem to update their status on their own any longer, even after adjusting the refresh interval for the device info to 5 seconds. The DeviceInfo section just won't auto refresh for some reason. It did work on my last hub. If I hit refresh on the device it does refresh with the proper status.

I've tried removing the devices, removing the drivers and re-adding them. I've tried adding the TVs as a virtual device with the Roku TV driver or adding the TVs via the Roku Connect app.

Hubitat Package Manager
Can't seem to check for updates on this one. It just sits at the checking for updates screen. Everything else seems to work.

Thanks for any and all assistance.


@rlithgow1 has one or more Roku TVs, may have info to help w/that.


Try doing a repair of HPM (you can use HPM to repair HPM):

If that doesn't help - best to post questions on HPM in the HPM topic.

Hello, I am having trouble with HPM checking for updates since I have upgraded from my C5 to C8 Pro. HPM just seems to be stuck on the "Checking for Updates" screen. I haven't seen too much in logs, but I suppose I will attempt to let it update overnight to see if anything pops up (debugging is on).

I did try to repair HPM with HPM, but it failed with the following error:

HPM does allow me to match up current drivers to the repository.

Any help is appreciated.



I would try manually updating HPM. Go to Apps Code, find Hubitat Package Manager in the list, click/tap it, click the Import button in the top right, and use this URL if it's not already filled in for you:

If you were behind on HPM versions, this may solve the rest of the problems. If not, post back here with what you see if you can't figure it out -- and keep in mind and uninstall of HPM is always safe since it won't remove any app or driver code (you'll just have to do a "Match Up" after the reinstall to get it to recognize what it can handle again).

I've also moved your post back into this topic since it was essentially a duplicate (the suggestion above was to post in the linked "main" HPM topic/thread, not start a new post in the category--the former of which may still be helpful if none of this helps).


Thanks for that!

I’ve tried reimporting the Hubitat PM code and reinstalling, however the same symptoms persist.



Anyone have any thoughts, or other ideas for me to try?

Can you provide a screenshot of the new error? If you uninstalled and reinstalled HPM (after manually updating the code), you would not need to repair HPM, and that is the only entry from Logs I see above.

EDIT: Nevermind, I see you posted in the HPM topic, and you are likely to get a reply there. I would not make double posts (new topic or not isn't really the issue; that is).

1 Like

Discussion is being continued at: [RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity - #649 by wearesuperbusy