IRIS V1 Contact sensors all disconnected the same time

I was using Lowes IRIS system, converted to Hubitat last March (3/2019). My system has mostly zigbee devices, now it has 30 IRIS V1 contact sensors, 12 IRIS V1 plug, 4 generic zigbee plugs, 10 zigbee bulbs, 2 IRIS V2 plug, 2 zwave sensors.

The IRIS V1 devices were very stable, it drops off once a while (one in a month or two) in past year.

On March 30th, all my V1 contact sensors lost connection around the same time (from their event logs), but none of the other V1 plug, generic zigbee devices have been affected. Following this thread Iris V1 Contact Sensor Reconnect, I deleted all the sensors, rejoint them one by one, and tested it all works properly. However, last night (4/12), it all disconnected, again from the event logs of each V1 contact sensors, it all stop to report temperature around the same time. Checking my V1 plug events logs, it were all good, for those have usage, it continue reports the amp during the time of V1 sensor lost the connection.

I am very interesting to find out what may be the root cause of this. The zigbee network seems to be very stable, none of the non IRIS V1 contact sensors been affected. However, I can not confirm it.

Questions -

  • Is there any debugging information regarding zigbee network that is available ?

  • The device debug logs can only be enable for 30 minutes, can we kept it always on ?

I know I can replace all the V1 contact sensors for limited cost, as a product developer my self, to make thing work is the best part of using Hubitat,

Thanks for any suggestion you may have.

Just started looking into this on my network as well. I have about 20 v1 contact sensors and they all fell off on the same date. Everything else kept working and zigbee has been solid.

When you say fell off, did they remain on the net work but not report open and closing or did they disappear as devices on the system?

They are still there. Just no more events

It remains on the Hubitit device list, but stop communicating to the hub, or the hub drop the events from those devices. The contact sensor report open/close, battery level, temperature changes. Each device logs more then hundred events in the log every day. It was clear to see it all stop around the same time.

Here is why I ask. I have a lot of V1 devices and I lost electricity for several hours Saturday. When electricity returned all of my V1 devices went unresponsive. Smart plugs, buttons and contact sensors. In order to make them responsive I had to press the configure button in the device settings for every one of them. They have responded properly every since. I chalked it up to having lost power. Now I am wondering if that was the issue at all.

Were these all added in one shot at the same time? In other words did they all die in the same length of time?

The other thing I would have tried is either rebooting, or shut off the Zigbee radio for 20 seconds or so and see if they came back when Zigbee was turned back on.

I did this the other day when I flipped a breaker to replace a (non smart) outlet/receptacle. There was something Zigbee on that same circuit, and I didn't realize it at the time. Kill the repeater, and the devices fall off too.

As far as I can tell, no power glitch at the time. My Hubitat hub is on UPS, it stay on other then I power cycle it manually.

When you go into the page for one of the devices, does its status show something like "tamper"? I had one stop working about a month ago. It was showing tamper on the device page. I think it was caused by a low battery, but I had to delete and then rejoin it to get it to work again with the new battery. Though it seems unlikely all of yours ran out of battery at the same moment.

Those V1 contact sensors were not added at the same time.

I did power cycle Hubitat multiple time, shutdown -> power off 2 minutes -> power on; did not help.

Zigbee repeater failure may be the trigger, if there is a way to identify the repeater(s) in my network, I can simulate it to see what happen.

Tamper status all show clear, some battery level are low, most are above 50%. Those are unlikely to cause all sensors disconnect the same time.

1 Like

This is common with the V1's I've had it happen twice in the last year. After the last time it happened I bought a bag of V3's to replace the V1's with when it happens again.

1 Like

You misunderstood my statement. What I was saying that I originally thought that my issue was caused by a power failure. Now I think that it probably is not the case.

Without a doubt, there is some unknown parameters with the V1 accessories that know one here or on ST has figured out yet.. Frankly, I am surprised there has not been any old IRIS programmers lurking here that have jumped in to give us a clue. My V1 plug in outlets will sometimes randomly disappear until I manually turn them on and my biggest gremlin has been my two Iris orbit 12 station timers. I discovered that if my hub is power cycled they will cease accepting commands but still appear to be reporting to Hubitat, BUT this only happens if they pass thru a repeating device to reach Hubitat.. If they are communicating directly with Hubitat they have zero issues. A power cycle of the timers will restore the connection.

I have to theorize that there is some hidden Iris command that goes wonky on reboots. Chuck looked at this for me but could not figure it out..

The lowes V1 devices are not and never have been supported on smartthings.

The outlets are funky, when they initially power up they send a specific frame to the hub, if the device doesn't receive the response it disables the zigbee commands for turning it on and off...

All of the v1 devices are using very old very unsupported zigbee software.

My advice, if you're having chronic persistent issues with just the v1 devices (your mesh is fine otherwise), I would begin budgeting for their replacement...


Ahh, now that makes perfect sense why they stop working. I actually have a total of 4 of those sprinkler timers and have been avoiding the $400 to replace them as otherwise they work fine.. I may just wire them to a zigbee outlet that I can use to power cycle them when the hub reboots. It is a strange phenomenon that they stay connected when paired directly to the hub though.. As far as ST goes, I had read that some were using the orbit v1 spigot timer there and some mentioned this timer as well.

the sprinkler timers are not V1 devices in the sense of their firmware using the Zigbee alertMe profile, AFAIK these devices use the Zigbee ZHA 1.2 profile.

The power on issue I mentioned is specific to the Iris V1 outlets, no other device I'm aware of requires any special power on baby sitting...


This explains why I was unable to control the outlets after the power outage. The outlets powered on before the Zigbee radio was up and running. Hitting the config button fixed it but I guess I could have also just unplugged them and then plugged them in after the hub was powered up. Other than this one issue all of my Iris v1 devices have been rock solid. I still prefer them over a lot of the other devices that I have. Particularly those that use a button battery.

1 Like

There is really nothing more to figure out. All of the Iris code has been released to the public and I am sure that the developers here have taken a look at it.

Has the firmware code for the sensors been published? I didn't look deeply but it seemed like only the iphone/android/server portions were published.