Iris contact sensor joins as Device

IRIS iL06_1 was detected as "Device". Seems to work fine as a Generic zigbee contact.

Here are the clusters:

PS: it seems to be missing from the List of Compatible Devices

1 Like

That;s an iris Gen 1 device. Did you try to join it as Zigbee instead of Iris Gen 1?

1 Like

Actually, the iL06_1 is an Iris 3rd gen device...

First gen Iris Contact sensor was DWS800

2 Likes

"GreatStar" is an easy hint too.. That was their v3 Vendor.

Google lied to me!!!

image

(What actually happened is it Truncated in the absolute worst possilbe spot.)

That's what I thought because i have a v3 keypad but stupid me wanted to double check so I wouldn't be wrong. Should have stuck with my gut.

1 Like

If it joined as device, you can swap the driver to the Generic Zigbee Contact driver in the device edit page. Just make sure to hit configure after you do. If you aren't seeing commands reports passing back when it opens/closes you might want to remove the device and re-add it.

@mike.maxwell, is the fingerprint for the v3 Iris Contact in the Generic Zigbee Contact driver?

1 Like

no, I never was able to get my hands on one before they got yanked...

Ah...that explains it then. Well, now we do!

So, @jon1, just set the driver to Generic Zigbee contact sensor, click save and click configure.

1 Like

They are < $5 on eBay right now.

Do you have a link? I can't find any of them that cheap.

Same seller that’s had all of the other Iris listings. Please note that there are no magnets with these.

Ah...those lots with no magnets.

@mike.maxwell

I just got some of these and noticed it isn't recognised still (joins as device), maybe slipped through the cracks.

As mentioned above, works fine with Generic Contact Sensor (including temperature reading).

ID: 863C

Manufacturer: iMagic by GreatStar

Product Name:

Model Number: 1116-S

deviceTypeId: 176

more...

manufacturer : iMagic by GreatStar

idAsInt : 1

inClusters : 0000,0001,0003,0020,0402,0500,0B05,FC01,FC02

endpointId : 01

profileId : 0104

application : 00

outClusters : 0003,0019

initialized : true

model : 1116-S

stage : 4

dev:202020-01-08 16:40:53.063 debugparse: listResult [[name:battery, value:100, descriptionText:Door Window Sensor - Bedroom 2 battery is 100%, unit:%]]
dev:202020-01-08 16:40:53.062 infoDoor Window Sensor - Bedroom 2 battery is 100%
dev:202020-01-08 16:40:53.060 debugzigbee.parseDescriptionAsMap-read attr: [raw:863C0100010A20002020, dni:863C, endpoint:01, cluster:0001, size:0A, attrId:0020, encoding:20, command:01, value:20, clusterInt:1, attrInt:32]
dev:202020-01-08 16:40:53.058 debugparse: read attr - raw: 863C0100010A20002020, dni: 863C, endpoint: 01, cluster: 0001, size: 0A, attrId: 0020, encoding: 20, command: 01, value: 20
dev:202020-01-08 16:40:53.038 debugparse: listResult [[name:temperature, value:25.89, descriptionText:Door Window Sensor - Bedroom 2 temperature is 25.89°C, unit:°C]]
dev:202020-01-08 16:40:53.037 debugparseReportAttributeMessage: Temp resultMap: [name:temperature, value:25.89, descriptionText:Door Window Sensor - Bedroom 2 temperature is 25.89°C, unit:°C]
dev:202020-01-08 16:40:53.035 infoDoor Window Sensor - Bedroom 2 temperature is 25.89°C
dev:202020-01-08 16:40:53.033 debugzigbee.parseDescriptionAsMap-read attr: [raw:863C0104020C0000291D0A, dni:863C, endpoint:01, cluster:0402, size:0C, attrId:0000, encoding:29, command:01, value:0A1D, clusterInt:1026, attrInt:0]
dev:202020-01-08 16:40:53.032 debugparse: read attr - raw: 863C0104020C0000291D0A, dni: 863C, endpoint: 01, cluster: 0402, size: 0C, attrId: 0000, encoding: 29, command: 01, value: 1D0A
dev:202020-01-08 16:40:44.229 debugparse: listResult []
dev:202020-01-08 16:40:44.225 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0104 0402 01 01 0040 00 863C 00 00 0000 07 01 00, profileId:0104, clusterId:0402, clusterInt:1026, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:07, direction:01, data:[00]]
dev:202020-01-08 16:40:44.222 debugparse: catchall: 0104 0402 01 01 0040 00 863C 00 00 0000 07 01 00
dev:202020-01-08 16:40:44.196 debugparse: listResult []
dev:202020-01-08 16:40:44.193 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0000 8021 00 00 0040 00 863C 00 00 0000 00 00 F200, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[F2, 00]]
dev:202020-01-08 16:40:44.187 debugparse: catchall: 0000 8021 00 00 0040 00 863C 00 00 0000 00 00 F200
dev:202020-01-08 16:40:44.180 debugparse: listResult []
dev:202020-01-08 16:40:44.177 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0104 0001 01 01 0040 00 863C 00 00 0000 07 01 86002100, profileId:0104, clusterId:0001, clusterInt:1, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:07, direction:01, data:[86, 00, 21, 00]]
dev:202020-01-08 16:40:44.168 debugparse: catchall: 0104 0001 01 01 0040 00 863C 00 00 0000 07 01 86002100
dev:202020-01-08 16:40:44.158 debugparse: listResult []
dev:202020-01-08 16:40:44.156 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0000 8021 00 00 0040 00 863C 00 00 0000 00 00 F000, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[F0, 00]]
dev:202020-01-08 16:40:44.149 debugparse: catchall: 0000 8021 00 00 0040 00 863C 00 00 0000 00 00 F000
dev:202020-01-08 16:40:44.139 debugparse: listResult []
dev:202020-01-08 16:40:44.137 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0104 0001 01 01 0040 00 863C 00 00 0000 07 01 00, profileId:0104, clusterId:0001, clusterInt:1, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:07, direction:01, data:[00]]
dev:202020-01-08 16:40:44.131 debugparse: catchall: 0104 0001 01 01 0040 00 863C 00 00 0000 07 01 00
dev:202020-01-08 16:40:44.107 debugparse: listResult []
dev:202020-01-08 16:40:44.105 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0000 8021 00 00 0040 00 863C 00 00 0000 00 00 EE00, profileId:0000, clusterId:8021, clusterInt:32801, sourceEndpoint:00, destinationEndpoint:00, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:00, direction:00, data:[EE, 00]]
dev:202020-01-08 16:40:44.099 debugparse: catchall: 0000 8021 00 00 0040 00 863C 00 00 0000 00 00 EE00
dev:202020-01-08 16:40:43.099 debugparse: listResult [[name:battery, value:100, descriptionText:Door Window Sensor - Bedroom 2 battery is 100%, unit:%]]
dev:202020-01-08 16:40:43.096 infoDoor Window Sensor - Bedroom 2 battery is 100%
dev:202020-01-08 16:40:43.095 debugzigbee.parseDescriptionAsMap-read attr: [raw:863C0100010A20002020, dni:863C, endpoint:01, cluster:0001, size:0A, attrId:0020, encoding:20, command:01, value:20, clusterInt:1, attrInt:32]
dev:202020-01-08 16:40:43.093 debugparse: read attr - raw: 863C0100010A20002020, dni: 863C, endpoint: 01, cluster: 0001, size: 0A, attrId: 0020, encoding: 20, command: 01, value: 20
dev:202020-01-08 16:40:43.044 debugparse: listResult [[name:temperature, value:25.89, descriptionText:Door Window Sensor - Bedroom 2 temperature is 25.89°C, unit:°C]]
dev:202020-01-08 16:40:43.043 debugparseReportAttributeMessage: Temp resultMap: [name:temperature, value:25.89, descriptionText:Door Window Sensor - Bedroom 2 temperature is 25.89°C, unit:°C]
dev:202020-01-08 16:40:43.041 infoDoor Window Sensor - Bedroom 2 temperature is 25.89°C
dev:202020-01-08 16:40:43.039 debugzigbee.parseDescriptionAsMap-read attr: [raw:863C0104020C0000291D0A, dni:863C, endpoint:01, cluster:0402, size:0C, attrId:0000, encoding:29, command:01, value:0A1D, clusterInt:1026, attrInt:0]
dev:202020-01-08 16:40:43.037 debugparse: read attr - raw: 863C0104020C0000291D0A, dni: 863C, endpoint: 01, cluster: 0402, size: 0C, attrId: 0000, encoding: 29, command: 01, value: 1D0A
dev:202020-01-08 16:40:43.028 debugparse: listResult []
dev:202020-01-08 16:40:43.026 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0104 0500 01 01 0040 00 863C 00 00 0000 04 01 00, profileId:0104, clusterId:0500, clusterInt:1280, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:04, direction:01, data:[00]]
dev:202020-01-08 16:40:43.023 debugparse: catchall: 0104 0500 01 01 0040 00 863C 00 00 0000 04 01 00
dev:202020-01-08 16:40:43.004 debugparse: listResult []
dev:202020-01-08 16:40:43.002 debugzigbee.parseDescriptionAsMap-read attr: [raw:catchall: 0104 0500 01 01 0040 00 863C 00 00 0000 04 01 00, profileId:0104, clusterId:0500, clusterInt:1280, sourceEndpoint:01, destinationEndpoint:01, options:0040, messageType:00, dni:863C, isClusterSpecific:false, isManufacturerSpecific:false, manufacturerId:0000, command:04, direction:01, data:[00]]
dev:202020-01-08 16:40:42.996 debugparse: catchall: 0104 0500 01 01 0040 00 863C 00 00 0000 04 01 00
dev:202020-01-08 16:40:40.190 warnconfigure...
dev:202020-01-08 16:40:33.740 warndescription logging is: true
dev:202020-01-08 16:40:33.738 warndebug logging is: true
1 Like

Is this a Gen 3 contact sensor? I don't know that I've ever seen one. It's possible that the footprint was never added to the generic driver. Tagging @mike.maxwell to see if this needs to be added.

Anyone know why my Iris iL06 contact sensor keeps shutting off?
I found this under scheduled jobs on the device page
logsOff 2021-02-28 11:47:14 AM EST PENDING Once

I need to keep resetting the sensor to get it to report correctly. Works for a few minutes then just stops updating. Device shows whatever the last state it was in and just stays there.
Thanks

How many zigbee repeaters do you have? How close is this contact sensor to the Hubitat?

1 Like

This line in the logs simply indicates that the Debug Logging feature is scheduled to automatically disabled after 30 minutes. It does not indicate any cause for concern.

To get your device to properly report status updates:

  1. Make sure it has a fresh battery installed (just in case)
  2. Click the CONFIGURE button on the device details page, to tell the device when and how to report status updates to the hub.
1 Like

When I click on the configure button nothing happens.
New battery reporting 100%

Correct. You won't typically 'see' anything occur, but behind the scenes zigbee messages are being sent to the device to 'configure' it properly.

1 Like

Sorry a noob. I've tried removing and rediscovering the device several times. Each time it works for about 10 min then stops reporting. When I open and close the door the LED on the sensor goes on but nothing on the device page