Inovelli VZM35-SN Fan Switch pairing issue

@mike.maxwell @bravenel Not sure if it is the device or hub. I am getting an error message in the log:

2023-10-15 11:52:51.952 AMdebuginmaster There was an error while calling zigbee.getEvent: read attr - raw: C8D30100001A05004208565A4D33352D534E, dni: C8D3, endpoint: 01, cluster: 0000, size: 1A, attrId: 0005, encoding: 42, command: 01, value: 08565A4D33352D534E

Weird thing it says it has paired I can control for 5'ish seconds then nothing. It pairs to my C-7 without issue. I only have a few zigbee devices on this hub. I have tried pairing right next to hub, from across the room, rebooted hub, pair with keys in clear, and trying to avoid 3.0 repeaters. all with no joy.

I have also asked @ericm and Eric H(Inovelli) here ZigBee Fan Switch | Project Zephyr (Blue Series) - #488 by EricM_Inovelli - Projects & Roadmaps - Inovelli Community


You need to work with inovelli on this. They provide the drivers and testing.

@mike.maxwell @ericm asked that I reach out and tag/include him. I have tagged Eric for visibility. @mike.maxwell should I create a ticket or do you and Eric want to work issue.

There's no need for a ticket at this point, if Eric needs anything on our end he'll ping me directly.

@sky320 Just want to confirm that you attempted pairing with the device driver completely uninstalled and the results were the same? Initially pairs, but after a few seconds the LED flashes Red? Strange that there are several with a C8 and they aren't seeing this problem but a couple are. @mike.maxwell are there any deeper zigbee logs that you guys could possibly see to help figure it out? I have seen something similar in other scenarios where the key exchange is not completed successfully so the pairing fails.

1 Like

@ericm Yes, paired with driver completely removed from hub and within 5'ish seconds the device went back into pairing mode. I installed driver retried and same result. The strange thing is the hub shows that it paired and logs show no error. I can re-pair control another 5'ish seconds then right back to pairing mode on the VZM35.

you really need to capture this at the zigbee frame (sniffer) level as some of the security transactions are handled by the chip directly so the hub doesn't see them.

@sky320 Do you want to PM me your address and I can send you a Zigbee sniffer?

Any progress on this? I can send my info if @sky320 didn't respond.

@user6953 no nothing yet I have grabbed some logs and am waiting on Eric to get back to me?

@mike.maxwell something that our engineer is seeing: "At the beginning, VZM35 successfully joined the C8 network, but when vzm35 applied for the second Key, C8 did not reply"

We can provide the full log if needed. This lines up with what some are seeing where the switch works initially but then stops after a little while. The strange thing is that there are a lot of C8 users that do not have this problem . . . only some. Mine it is able to pair just fine.


email me the complete capture along with the transport key.

1 Like

@sky320 by a chance, does your Inovelli Fan Switch SoC MAC address start with 70-b3-d5 ?

I will have to look for it tomorrow

No the switch does not

You mean the first three hexadecimal digits of the ZIgbee ID are different?

That's correct mine 048727. I just tried adding a 2-1 switch and same result looks like it is on the controller side.

How did you pair the switch - in place or close to the HE hub?
C-8 or C-7?