In need of Zigbee mesh help on C-8

I recently upgraded one of my Hubitat locations from C7->C8. Running into a few issues with my Zigbee network and devices going unresponsive, rules failing to activate the device etc (the rule is called as it should according to the logs just the light does not come on, the lock does not lock etc). Try the same device 2 mins later and it works. Not seen Z-Wave issues since the upgrade.

Really like the new beta network map. Very helpful to have this. The Zigbee map does not show any of the locks, sensors, Sengled bulbs. They do show up in the list of devices. Is this expected or does it indicate a deeper problem with my Zigbee network? Similar devices do show up in the Z-Wave map.

Any pointers would be appreciated? Not sure what to do at this point short of swapping out all my Zigbee devices for Z-Wave (would be expensive).

I found the original user created zigbee map seems to be better at picking up battery devices. [Zigbee] Visual render for getChildAndRouteInfo

You might have to leave the page open for a few minutes before it sees all your devices.

But yeah, to answer your question, the way Zigbee works the hub itself does not have good visibility of the entire mesh if you have a lot of devices and repeaters (with devices connecting to the repeaters).

Thanks Jeff. I Ieft it running for about 30 mins. Sonoff and Hue sensors appeared eventually. One of my Kwikset 914 locks appeared but not the other two. The Sengled bulbs never appeared.

I installed the community version as you suggested. Get a 404 error when I try to load the graph.

And of course the bulbs are not battery devices.

Was able to get everything to appear on the map by accessing the devices through a rule. Looks like the access attempt forces the map to see them. So this does not explain my underlying problem which is the devices intermittently not responding to commands. Still struggling to get the Kwikset 914 locks in particular to do what they are supposed to. The Zigbee repeater switches they are routing via seem to be perfectly fine and working. Any ideas from anyone on where to look next would be appreciated?

Sorry I am not of much more use, more of a Z-Waver person myself. I did rename and move your post though, to hopefully attract some more attention.

Mind sending me a private message along with your hub id? I'd like to take a look at your hub's engineering log, assuming your hub is connected to the cloud.

Even w/all devices showing you may not have a completely current/accurate picture of your Zigbee mesh connections w/either the HE or the community version, especially where repeaters are involved. So the Zigbee graph may not be a huge help in looking at your Zigbee issues overall.

My best success w/Zigbee on the C8 has found me w/pretty much all of my devices connecting through repeaters, FWIW.

Other important changes:

  • Zigbee power set to 8
  • Zigbee channel reviewed/changed to avoid conflicts w/ 2.4GHz Wi-Fi channels



Have you tried adjusting the Zigbee power output. It is adjustable on the C-8 up to 20, but I would try small bumps and not just setting it to 20 unless you have a very controlled radio environment (ie. not an apartment, condo, etc).

1 Like

Thanks Ken. After the migration from C7 it was set to 8 and I have since bumped it up to 12 and still getting issues with the locks but have not seen issues with any switches for a couple of days now so maybe it helped with that. I am a little concerned about bumping it up further as I suspect that would make Wi-Fi interference more likely. None of these locks are very far from the hub and my one Kwikset 914 Z-Wave lock is rock solid, works every time. The switches on the other hand are more dispersed and I would assume it’s the devices that are further away from the hub that are most impacted by power level?

I have an eero mesh which does not allow me to change or select channels. I currently have the Zigbee set to channel 20.

As best I can tell from the graph all but a couple of sensors are connecting via the blue dots which are repeater switches. Certainly the devices I am having trouble with are all routing via a blue dot on the map.

I suspect the zigbee radio going offline for a short period of time is what is causing the device issue. Anyone know where to look to find out why it is going offline?

To be blunt, I find that graph/map to be completely worthless (I'd even contend it's detrimental) and a fool's errand to interpret, so I'm not a good person to ask about it.

My remarks about my mesh performing best when it leans primarily on repeaters (vs attempting to make direct connection with high radio power or other means) is based a long battle I had with my zigbee after moving from C7 to C8.

My issues resolved when I removed the couple of 1.2 repeaters I had from my mesh (all are 3.0 now), and when I dropped radio power down to 4 and moved from channel 15 to 25. My zigbee has been excellent ever since, but it was a lot of trial-&-error to get there. But that graph was never helpful to me in any way.

Noted and thank you. All my repeater switches are Jasco 43076. We are getting close to the limits of my knowledge here but the specs say they are Zigbee 3.0 certified so I assume that means the same thing in terms of the repeater being 3.0 that you mention.

Right on - cracking the right mix of things to get your zigbee humming smoothly on the C8 has been a chellenge for many of us here! It was a unexpected hurdle given how easy & smooth zigbee was on the C7.

Unfortunately, there's no single silver bullet that works for everyone, but I'd say there have been a few common things that help most folks... 1) The general idea of having good-quality 3.0 repeaters well-spaced in the mesh, and removing any questionable-quality or older 1.2 (mains-powered) devices. 2) Ensure the ZB channel is solidly deconflicted from your wifi and other ZB stuff (e.g. Hue). 3) Experiment with the ZB radio power, but in general, we plagued folks seem to have better luck with lower power than higher.

1 Like

I hear you. Had a bunch of Innr plugs I had to remove even when I was on C7 as they were causing havoc on my Zigbee. I have had Zigbee issues since day 1 on HE and very few Z-Wave issues. Been better since I went wifi with the plugs but not perfect. I was hoping the upgrade to C8 would make things better instead of worse. I even moved all my wifi switches/plugs on Kasa and Lutron to my C7 to share the load. Still getting issues. Anyway I don't think I have any older Zigbee devices left. Is there an easy way to check? I just changed my Zigbee channel from 20 to 25 to further separate it from channel 11 wifi. Apparently that takes 24 hours or more to fully update. We'll see what happens tomorrow. Pretty frustrating to have to put this much effort into getting back to where I was before.

A lot of people have found these problematic with iot including ST and Hubitat. I'm not sure why.... I use Unifi AP's myself (just the ap's and not switches or anything) and things are very solid.... As for the c8 as well, if you use a usb POE adapter with the unifi switches, that is problematic. (Works fine with the c7). Just mentioning things to keep on your diagnostic radar.. Xiaomi, Sonoff, and the like are horrible and drop off the mesh without a lot of care.

That's interesting you had issues with the Innr plugs - they've been solid overall for me (and I have a bunch - both the 224 and 234 versions). But just goes to show this is all frustratingly unique to troubleshoot.

Have you tried updating the firmware on the Innr plugs? Hubitat does have an update available for both versions, and it fixed network-dropping issues I was initially having with the 234s.