Hubitat Update 2.2.5 broke Rachio Integration

if your driver is out of date you still should be able to update it and configure it without loosing the devices.

It's a built-in driver. We have no control over the built-in drivers. Since it is built-in, the fix must come from Hubitat. I have had the driver for a very long time, and it has been working until now. obviously the easy fix is to delete the app, and reinstall, but that breaks all integrations, rules, etc, as the drivers are components of the integration app, where the problem is.


what about adding the app again.. configuring the device.. then removing or changing the id of the old and new controller device and or zones with the "edit " button to duplicate the old ids..

not sure if it will work but it may

yeah. that's my trick I have been doing for a while now with migrations, and updating of devices. This is not reported so I can have my devices fixed. I am not impacted by it. It is reported because it was discovered, and should be fixed. I don't have integrations, rules, etc for these device. for me, they are just informational. But if the issue affects me, it is likely to affect others.


Actually, that wouldn't work. The app id and device id are different than the device network id. The device network id can be edited, but these devices would physically get replaced.

This app hasn't changed in eons, over two years.
The errors indicated appear to be generated by rachios cloud services.

I am trying to help, but whatever. If no body cares, I have deleted and re-added the app and now it is working.
This refusal to acknowledge the flaws in your code is just beyond ridiculous. Just look at the very first screen. Are you telling me, that it is by-design that once you authenticate with the service, if anything should happen to break the authentication, that it is okay to have to Remove and re-install the app? that the only button in the app should be "Remove" ?

I understand you are all busy fixing the numerous bugs introduced by the update (3 releases now in less than 24 hours). But flat out dismissing the flaws because it is inconvenient is troubling.

1 Like

We can get into this or not, but you're the first to report an issue with this app in quite some time, take that to mean whatever you want.

1 Like

That’s fine. Like I said it worked before and it works now that I removed and re-added it. I only use the sprinkler controls for monitoring, so it doesn’t really affect me to have to remove and re-add. It may in the future, considering We are unable to re-configure authentication in the app, but for now, I was just trying get the issue looked at.

Frankly, the Rachio is a small issue, big issue is the broken Ring Keypad driver in my other thread.

FWIW, this also happened to me on the update. Yes, years later.

Have you attempted a soft reset and a database restore? FWIW, this is the first report of any issues with Rachio with 2.3.6.x, and there are plenty of Rachio users here.

Technically, it wouldn’t be the first if he is a me too case. It could be as simple as we changed our password. Then when the auth token expires, how do we re-enter our new credentials? It should be a simple lightbulb moment to realize there is no mechanism to re-authenticate and maybe it should be added for when the authentication fails.
That was the only reason for my initial post.

I don’t understand all the friction to this very simple observation. Nobody is pointing fingers, just expressing an observation.

Did this happen to your hub also after updating to 2.3.6? If that’s the case, I agree that his observation wouldn’t be the first after updating to 2.3.6.

I didn't mean to imply a connection between the latest update and this issue. This was simply the version running when I noticed that my Hubitat had the same Rachio app loss as the OP.

My resolution was to remove and re-install the app as noted, then go in and reconnect any broken device references in other apps.

That said, I will note that the logs held quite a few of these entries PRIOR, which is what triggered my investigation in the first place:
pollChildren cannot update children because it is missing the required parameters

No idea if that will help anyone beyond a future search. Anyway thanks for responding.

1 Like

This isn't about the upgrade at all. It's about the Rachio integration code has no ability to re-authenticate, so if authentication breaks (say if I changed my password on the Rachio servers) then the integration cannot be fixed unless you remove it and reinstall it. And this could be very disruptive on large or complex integrations.

Exact same problem. My Racchio integration broke. User name is populated. UserID is not.

I feel your frustration. It’s a simple fix, but I just haven’t gotten the acknowledgment from the developers that they acknowledge the problem, or desire to fix it.
All that they need to do is create a validate function that tests to make sure the three authentication values exist, if not, allow the user to re-authenticate. And if login failure is detected(http 401 or 403), allow user to re-authenticate.

As it is, the only fix is to delete the integration and start over.

Do you know if you get the same errors with rhe Rachio Community version of the integration? That community integration is built from the same base code as the native integration, so it would be an interesting comparison to see if there’s an issue with underlying code or an issue somewhere else. Since I actively maintain that community version, I wouldn’t mind looking into the issue on that version for you, if the errors in the native app are frustrating enough to move to a third party integration.

Appreciate the offer but this is not something that occurs frequently. It has happened to me twice now in several years and only this once can I confirm definitely the issue is as described because the first time I wasn’t aware of the settings view to diagnose it. It was many years ago. I would rather leave the system as is unless it becomes a recurring problem.