Hubitat status light stays blue

Hi all,

Second post to the hubitat forums for today, new user trying to discover and register my new hub in the cloud but I never seem to get a green status light on the front on the hub, it always stays blue. I have left the hub for 30 - 40 minutes per time between reboots but the light never turns green.

I am on the same LAN\Subnet as the hub and can ping it no problem.
image

The AutoDiscovery does not find the hub. if I look for the hub via IP, I can see it.
image

If I click the hub it takes me to a page cannot be displayed error
image

I've tried Firefox, google chrome and internet explorer but no joy from either brower, I have also tried via a couple of PC's and tried from various PC's and such but with the same results, the light always stays blue and has never turned green, I also tried portal.hubitat.com/portal.html but still unable to see the hub.

I then searched a little more and found that it could be that the hub doesnt have the Platform OS available and that it may need a factory reset, I found that if I go to http://192.168.25.75:8081/ I can load a page with some options, one of the options is a full reset
image

I press full reset and it then asks me to enter the MAC address, which I do but it is not accepting the mac, have tried lower case and upper case letters TNA I just get the following screen.
image

Can anyone suggest where I am going wrong here and what I need to do next please?

Hello & Welcome, FYI as a new user you're limited to 9 posts on day 1.
Anyway I've seen this comment, something about 24hrs needing to elapse before you can login via entering MAC as password. And I think you're right on about the Platform OS, but I think if you search you could find others with same issue.
found this:

Good luck

2 Likes

I wouldn't do that unless absolutely necessary. That is the nuclear option, you are nowhere near needing that yet.

The other step I would do if you have not done so it to assign Hubitat (and all home automation devices really) a static address in your router. The idea here is that 192.168.0.xxx is always the address of Hubitat, Lutron, Alexa, Hue, or whatever so you and the hub can always find the other devices.

1 Like

Thanks, it didnt work anyway as it didnt accept my MAC printed on the sticker on the back of the hubitat, Also I have quite a big network and everything is assgined a static IP, I keep record of this in a spreadsheet.

Doing some more reading on the forums I somehow am starting to beleive this might be a network block of some sort but have enabled emergency access in my firewalla gold coniguration for this which means there is no blocks.

I run a firewalla gold as my main router, my cable modem feeds the wan port on the Firewalla gold, one of the lan ports on the firewalla is hooked up a 24 port netgear prosafe managed switch, I have tried the Hubitat hub in one of the spare firewalla ports, So Cable Modem to Wan Port, Lan port 1 to 24 port switch, Lan Port 2 to Hubitat, but still have the same issue.

To encourage the hub diagnostic tool to upgrade immediately versus having to wait up to 24 hours, follow the instructions in this post...

4 Likes

Be sure that if this continues for much longer to contact support by emailing them. support@hubitat.com

BobbyD is the main support person, so you could also tag him on this thread, but it is usually better to get a trouble ticket open to get a faster response.

Support can see and have you try things that we cannot here in the community.

1 Like

Thanks Both, I have tried assigning a new LAN IP via my address reservations, the new IP I have assigned in now .61 rather than .75, I have also opened a few port forrwards for the hubitat, Port22, 2604 & 8081 as my Firewallabox can see thats what ports the device has been trying to use, I also enabled UPnP but still no joy, I also tried the http://192.168.25.61/hub/cloud/updateDiagnosticTool but just get a page cannot be displayed prompt.

I also opened a new case - number: 17730, Bobby did reply with some steps to try but had no joy and I believesupport is now closed I think, I am based in the UK so its nearly 11:30PM here.

I believe its 18:23 where support is and they closed @ 18:00 so will just need to wait till tomorrow I think, see what happens.

Thanks everyone for the help and support!

2 Likes

I know @ogiewon linked to this earlier (and you may have tried it already). However, just for s & g, would you consider turning your firewallabox off and trying it again?

Maybe officially, but keep an eye out for messages or emails. BobbyD is on all hours of the day and night. I don't know when some of these guys sleep.

3 Likes

Or is there a way to connect the hub directly instead of through a switch or two? Maybe just enough to get it set up and then put things back to normal.

2 Likes

I have just been away, turned off cable modem for 1 minutes, disconnected power Firewalla Box, Disconnected power to the switch and my WiFi mesh system, powered my PC Down, then powered up the cable modem, then the Firewalla gold router, then my switch then my Wifi Mesh system and finally my PC. Still get page cannot be displayed when trying http://192.168.25.61/hub/cloud/updateDiagnosticTool.

The Firewalla Gold does have 4 LAN ports, 1 for Wan and 3 for additional networks, I did earlier tonight try the Hubitat direct into the Firewalla gold but the same problem was met

Edit: I shoudl also mention the 3 Lan ports are all assigned to the same network as these can be assigned to different LAN's if need be but I dont have them set that way.

Have now also forward port 443 as I can see in the Firewalla Network flows the device is accessing service.cloud.hubitat.com (It's hitting various IP's within 52.84.138.XXX and using random ports to connect on from the local hubitat device) - It seems to be uploading and downloading a few kb's at a time.
Some screenshots:

Please check your PM.

1 Like

Thanks have replied to the PM, have a feeliong my Hub is broken, swapped out my Firewall box and have went back to the ISP provided modem\router combo, I have the Hubitat wired into the one of the ethernet ports and a PC and a Phone connected wirelessly.

Still get the exact same issue, cannot load a page on the browser and unable to discover the hub.

Once thing I noticed is that when I check the time on the hub it is saying 2015
image

And the update time option doesnt seem to work, Really no idea what is going on here and never had a device that has been as troublesome as this, where do we go next @bobbyD

Just confirming that you entered the MAC address with no : colons

So my new hub turned up today, done the same as last time, hub light went green this time, registered it in the portal without an issue and without any fuss, so happy it is working.

Would also like to thank @bobbyD and the guys at Ultrasmart whom I ordered the hub from for such the quick turn around for the replacement, they also sent me a free complimentary water leak sensor I guess due to the issues I had so can't thank them enough but over the moon now, now to start figuring out the world of hubitat and porting my devices across form smartthings, Thanks guys you get a thumbs up from me :+1:

4 Likes

So happy to hear this! Thanks for the follow up message and have fun!