Hubitat not responsive

Hi, in the last 2 months, my hubitat became unresponsive when I wake up (I have some integration with a google home on waking up). The only way to get it back is to unplug and plug back the hubitat. It never did that before. The only changes that happened recently are hubitat update and I added some rules for a motion detector. Is there a known issue since the last update ?

I just went through this last week with my C5, it was a bad port on the switch I was using. Took a few days of troubleshooting and finally moving it to the computer room with new power and cable off another switch and it worked fine.

Don't rule out hardware outside of the HE box being an issue. Mine was only failing overnight, unplug network cable and plug in fixed it until the outage

1 Like

No. Nothing that should cause sporadic freezes. What do the logs say?

What model hub do you have? When you say “unresponsive”, what do you mean? What color is the light on the front of the hub? Can you reach the diagnostic tools on port 8081?

I’m concerned that the repeated plug pulling power off might have corrupted your database.

Do you have a saved backup from before this issue started? If the only backup is older than the addition of the motion sensors, you might try:

  1. Make and download a backup (that prunes out bad records from your database;
  2. Soft reset from the diagnostic tools at port 8081
  3. Restore the downloaded backup.

Details here:
Soft Reset

Are the motion sensors paired with a security level (S2 or S0)? If so, you might try with no security pairing.

1 Like

I just emailed support with a very similar issue. My hub has been locking up daily for about a week now. I have moved the device to a different connection, and I have done a soft-reset/restore with the same result. I notice that when my hub stops responding, that I cannot ping the IP address. The only thing I have found to get the hub back online is to power cycle it.

I added a new ZigBee Advanced Bulb...( LCM-1C09-ZB) about 3 weeks ago. After this, I noticed that from time to time ZigBee automatons would stop. I could see ZibBee devices in the logs showing status changes (i.e. motion detector going active/inactive), but none of the automatons would respond. I tried changing the ZigBee channel and around that time is when the lockups started happening. Also, I had to re-pair all of my Sonoff motion detectors, because they did not seem to update to the new channel like my switches did.

Mine has been doing the same thing for 2 months now. I finally plugged it into a smart plug so I could restart it remotely. I sure would like to know how to fix the problem.

I will check my logs the next time it happens. Is there are way to look at the memory/cpu trend ? To see if there are some memory leak.

Next time, I will try to unplug the network only to see if it is only the network.

Yes. Install the Hub Information community driver.