Hubitat Mobile App Released


#365

So far, so good for both our iPhone 7 phones, running iOS 12.3. I also have the Hubitat app installed on both of our iPads for push notifications. Again, no issues so far.

Mobile presence on our iPhone 7's has been as reliable (if not better) as Life360 thus far. Push notifications are fast and have always been delivered.

Hope the situation improves for the users having issues.


#366

I had a strange thing happen. My phone has been on the app for days and I recently put my wife's on it too. I noticed another device in the list so I sent a text to it and it turned out to be my phone. I deleted the other one.

Why would it create a new one for me?

Also my wife's, after trying all the tricks, still does not respond to being outside the fence.


#367

Have you created an account for your wife and what have you labeled the devices in the hub?


#368

When you say created an account I went into the app and added her as a user. I haven't changed the name in the phone yet. I am still waiting for it to come in as a device. I started over.


#369

Think this gets done in the portal? You create an account for her then add her account to your hub?


#370

OK, thanks. I will go look at that.


#371

Hi @patrick
I've just logged into the mobile app and I had to re-log in. I selected my mobile device and when I look under settings my hub name is 'my new hub'. This is not the name of it.
Also the geofence has reset itself to the default.
I have completed a soft reset today to clear an issue.
Any ideas?

EDIT: @patrick I can see what the issue is.
On the portal.hubitat.com site my hub is called My New Hub.
image
If I click on it then in the settings for the hub it gives it its designated name.
Definitely some sort of issue here.
image


#372

Mine has done this several times including this morning. Did you ever get any response as to maybe why?


#373

No


#374

Just posted with headed under support. FYI


#375

All was working well until a few moments ago. I just missed a notification/push event for the 1st time. Tried opening the app on my phone and I now get this error: "Timed out waiting for hub dashboards". I'm on a Pixel 2XL running the latest Android Q Beta.

Quick update: Logged out of the app and back in. Now I have two Pixel 2XL devices in my HE device list.

Latest update: Reboot of phone and a log back into the app fixed the issue.


#376

I've had 2 separate instances where I've opened the app and needed to supply my login credentials again. Both times I was opening the app to check the geofence because my home hadn't registered that I had arrived. I suppose this is because, somehow, the app cleared my credentials.


#377

@bravenel Ok, I think I got my wife's phone added as a guest. But now my phone will trigger a present/not present on the device page if you move the fence but I cannot get a notification to come in.

My wife's phone is just the opposite, I can send a notification to her phone and it comes in But if I move the fence on her phone it never changes from present on the device page.

How do I fix? thanks

EDIT: Wife's started working, but my phone still doesn't receive a notification.


#378

Small issue however don't recall seeing this in the thread

Double log entries for nearly the exact same time

Rick


#379

Thank you very much to the devs for this awesome addition. I'll be trying it out on the iPhones in the house over the next few days.

@patrick Apologies if it has been asked already, don't have time right now to read the whole thread, but is there a chance that this will get release for the Amazon App Store? It would be awesome if I could use it every now and then on the tablets I am using for dashboards.


#380

At this point we don't have plans to release on Amazon's app store at this time.


#381

@patrick ok thank you for the quick response, no worries at all was wishful thinking :grin:


#383

Still not getting notifications on my phone. Geofence is working. Wife's phone receives notifications and shows change in geofence. Both phones are the same kind and are android.

Could there be a setting in the phone itself that could cause the notifications to not come in?

EDIT: Deleted app from phone and went through new process and re-adding my phone to the app. Seems to be working for now.


#384

@patrick I Think I am experiencing a couple of bugs (or at least undesirable functionality)

My copy of the app appears to be disabling the geo fence option intermittently. I just noticed while checking a dashboard when away from home. I accidentally tapped the [Geofence] button at the bottom of the display and got a pop up notification about enabling geofencing. (Please See photo below)

This keeps happening.

Also, if I am looking at a dashboard that is correctly updating them leave the app running in the background.... when I return the app to the foreground it does not start updating the app again until I fully close it, then reopen.

I have a dashboard feature request too.....
please can the buttons in the HSM pop up window give visual and Vibration feedback when they have been pressed. At present there is not cue that a button has been pressed.

The app means that I can finally complete my migration from SmartThings which make me very happy.

Many thanks.
Tim


#385

"Enable Geofence" turns itself off. I had posted this previously but I wanted to provide more info for the de-buggers. I woke up to my Iphone 6s this morning once again had toggled it off on its own. The app was left open in the background. My wife's Iphone 7 doesn't seem to do this. Also, her presence seems to be more reliable at this point. UPDATE: Wifes Iphone 7 has done the same thing. Geofence turning itself off.