Hubitat mobile app - dashboard does not load

Hello everyone,

I am new to hubitat, just got it in the mail this weekend. When I use the mobile app, the icon for hubitat keeps spinning on the screen and dashoards never load.

I have to go to settings and hit local hub to see the dashboards.

any one know what might be happening ?

Welcome to Hubitat!

Sounds like maybe you have not logged into the app as "user/admin" yet? If you force close the app and then reopen it does it give you the option "Log in as existing user"? If so make sure you log in once so it knows who you are and pushes you to the hub (have it create a new device as well for Geo-fenceing/notifications).

If you have not done so, setup a habitat user account at the link below, and use that to sign in.


From your hub’s admin gui (i.e. in a browser where you first installed the dashboards app onto your hub, not the mobile app), double check that each dashboard is configured to allow viewing from both local and cloud connections.

I just checked dashboard board settings., both are checked to allow access form cloud and local.

@TechMedX, yes I am logging into the app as an existing user and logging in with my portal account that is logged into the hub

just figured out how to move the geofence, that part is working but not dashboards

Location can be set in the "setting" screen on the hub UI (not the app). Zoom in/out and move it till you find the best location.

Try this. Open the app and make it so you can see the dashboard once. Then clicking full screen button

Next click your dash to open it in Chrome (or default browser). In Chrome click the 3 dots and then "Add to Home Screen".

Close hubitat and try opening the dash using the new shortcut. Does it go directly in that way?

EDIT: Another thought (semi drastic), if your new and don't have many dashboards setup, you could try deleting your dashboards, removing the app, reinstall the app, create a basic dashboard with one device, and check it.

Not 100% sure what happen, I tried it again being on LTE and it worked.

I re-installed and it still did not work, logged out and logged in again and when i checked not on wifi it worked. Now it works every time.

thanks for all the help everyone

1 Like

the dashboard loads on mobile data, but when on the house wifi, it does not load.

just stuck on this screen when on wifi

Did you try the suggestion I made above? Does a local link via Chrome work?

That will help tell us if it an app issue, or a problem with your local network routing.

I have no problems with either in chrome on the desktop

I can do local or cloud and it works

same from the phone , if I use local or cloud on phone in chrome zero issues

If I am on wifi and launch the app fresh, I get the above image. If i turn off wifi, dashboards load pretty fast with in the app

1 Like

Have you tried removing and reinstalling the app?

Also tagging @bobbyD to help, who may have a trick or two.

Yes, I re-installed before coming to the forums

at first I thought it was fixed, then i realized I was off wifi

I'm having the same exact problem as @sstretchh. New user, dashboard is enabled for both cloud and local, and I can only access my dashboard through the app if I turn off WiFi on my phone (I'm on the same local network as my hub). Would love a resolution.

1 Like

I am also having the same problem. Both Samsung tab S4 and S10+ wont bring up the local dashboard. I just get the spinning Hubitat icon. If I switch to cell data than the dashboards come up. I double checked that both dash boards are toggled on for local and cloud access. On occasion when going into the app I also get "unknown error contact support"'. If I close the app and reopen it I dont get the error. I have also restarted the hub and reinstalled the app.

1 Like

Welcome to all. Sorry you guys are having trouble with this. Seems odd to have this many reports of the issue. That would indicate it could be a problem on the HE side.

tagging @bobbyD (sorry for twice on one post, but I think there is an issue here) and @bravenel to see if they know of a cure for this.

Until they can get it sorted out, use a browser with a local/cloud link on your home screen to access dashboards, as posted above for a workaround.

1 Like

Sorry for the troubles. If you didn't do so already, please send us an email to along with the following details:

  • Mobile Device make and model
  • Operating system and current version
  • Hubitat Mobile app version (from "Settings" tab in the mobile app)
  • Screenshot of "Debug Information" page (on "Settings" tab in the mobile app)
  • Email address used to log into

You can also send these details to me via PM, if that is more convenient. @dgposey , @shaynedvs, @sstretchh

1 Like

Same issue on my wifes phone also

I will send an email to support and PM you the details Bobby. Heading to bed, will send details tomorrow

My work around has been to load the dashboard in chrome, and save a shortcut to my wallpaper

Thank you for your feedback. We have identified the problem and the fix will be released in the next beta update. Meanwhile, a possible work around is to go into "Settings" and select the hub again. We are sorry for the inconvenience that this may have caused.


A fix for this issue has been released to beta app. If you'd like to try the public beta app, you can sign up here:


I can confirm this worked for me, it's working !!


Thanks for the speedy response and fix. I switched from Wink and I can say I am very pleased.
The side effect is I am driving my wife nuts. I want to automate everything lol.